Package Details: slic3r 1.2.9-3

Git Clone URL: https://aur.archlinux.org/slic3r.git (read-only)
Package Base: slic3r
Description: Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
Upstream URL: http://slic3r.org/
Keywords: 3d-printing
Licenses: GPL
Conflicts: slic3r-git
Provides: slic3r
Submitter: nickoe
Maintainer: nickoe
Last Packager: nickoe
Votes: 32
Popularity: 1.013364
First Submitted: 2012-08-26 23:07
Last Updated: 2016-05-19 17:38

Dependencies (22)

Required by (1)

Sources (3)

Latest Comments

yar commented on 2015-10-31 21:45

When I compiled this on an i686 machine and ran it on a x86_64 machine, it gave me errors like "wrong ELF class: ELFCLASS32". I fixed it by replacing

arch=('any')

with

arch=('i686' 'x86_64')

mpan commented on 2015-09-06 20:14

If during slic3r build perl-extutils-cppguess fails to build because of a failed test, try building perl-extutils-cppguess before perl-extutils-makemaker-aur.

For yaourt users (assuming perl-extutils-makemaker-aur is not installed):
$ yaourt -S --asdeps perl-extutils-cppguess && yaourt -S slic3r

alhirzel commented on 2015-09-02 23:13

I needed to install perl-module-build.

nickoe commented on 2015-08-31 16:36

Added perl-module-build-withxspp as a dependency

fclad commented on 2015-08-31 13:08

Please add perl-module-build-withxspp as a dependency

yar commented on 2015-08-11 22:36

Seems to depend on perl-module-build-withxspp

nickoe commented on 2015-06-28 08:19

It seems like there is an issue in /usr/share/perl5/vendor_perl/Slic3r/GUI.pm:66

Where it lists:
$small_font->SetPointSize(11) if !&Wx::wxMSW;

But if I change the size to 8 (my system font size?!?) then it works. If I don't change this I get a segfault when loading a part.

To fix the previous mentioned issue you will have to recompile the perl wx related stuff.

ejona86 commented on 2015-06-27 22:46

The perl modules are very temperamental about what versions to use. You might try slic3r-bin for a while. Occasionally trying this package again to see if it got less crashy.

Slic3r-bin isn't perfect, but between this package and that one I can tend to get something that works.

nickoe commented on 2015-06-27 21:28

I am not sure why, but when I try to upgrade this package to 1.2.9 I get a segfault. http://dpaste.com/10GNR8C

I am trying to figure out why this happens. But if anyone has any feedback to resolve this, it would be nice.

nickoe commented on 2015-03-19 18:53

Bumped to 1.2.6 experimental.

swiftgeek commented on 2015-01-26 13:03

@crocowhile No sign of you at #slic3r irc.freenode.org

From your very inappropriate log interpretation (just use dpaste/gist) i can only assume that you have either badly/old build perl-wx and other deps and/or your are commenting against wrong package (slic3r-git lets you select different tags)

crocowhile commented on 2015-01-26 10:59

I cannot get this to work at all. I tried different tags/versions - The stable one is the only one that shows me the GUI but won't convert to gcode due to a out of memory bug. All the other ones will convert to gcode but won't show me a gui. Any experience with this?

nickoe commented on 2014-11-23 09:46

I bumped to version 1.2.1 experimental because it fixes a segfault that the 1.1.7 stable had, which ment that it could not be used with current perl. As a bonus you will get the UI features of slic3r.

mpan commented on 2014-09-24 15:09

@yar
The bug has been already fixed in master, so use slic3r-git and build using the master branch. I don't remember which commit has fixed this one, but I'm using 5a96bad now and the bug is no more there.

swiftgeek commented on 2014-09-24 08:46

1. makechrootpkg doesn't solve anything here as it is perl
2. works on my x86_64 so blame your outdated perl/any usage of cpanm

nickoe commented on 2014-09-24 06:34

What do you do when you get that?

yar commented on 2014-09-24 00:50

On x84_64, slic3r just fails with "Out of memory!" no matter what I do. Tried building with makepkg locally, and also with makechrootpkg.

nickoe commented on 2014-08-12 07:36

Not out of date, this is intended to be for stable. Reason with me for why I should package experimental.

jamesan commented on 2014-08-12 02:27

Latest version is 1.2.0, released last week.

nickoe commented on 2014-08-07 10:41

Update to 1.1.7 stable.

nickoe commented on 2014-07-17 05:56

Update to 1.1.6 stable.

nickoe commented on 2014-06-12 18:11

1.1.4 does not work withh perl 5.20

chrishamm commented on 2014-06-06 16:58

1.1.4 is out

nickoe commented on 2014-06-02 21:06

Maybe install the opts

nickoe commented on 2014-06-02 21:06

@aaronmueller, I also got that at some time, but I cleaned my srcdir and pkgdir and it built.

aaronfischer commented on 2014-06-02 20:45

Can't compile :(

In file included from src/Polyline.hpp:5:0,
from buildtmp/XS.c:184:
src/MultiPoint.hpp:12:7: error: forward declaration of ‘class Slic3r::BoundingBox’
class BoundingBox;
^
error building buildtmp/XS.o from 'buildtmp/XS.c' at /usr/share/perl5/core_perl/ExtUtils/CBuilder/Base.pm line 177.

nickoe commented on 2014-05-31 21:57

Bump pkgver to new experimental version

nickoe commented on 2014-05-15 20:55

Bump pkgver to new experimental version

gururise commented on 2014-05-15 19:01

1.1.2 is available.

nickoe commented on 2014-04-23 09:48

I just added perl-extutils-typemap as a depend, I am not sure what it provides, but I guess very few do not want it. I don
t see failing tests.

nickoe commented on 2014-04-23 05:48

Mmm, I will have a look at than later.

yar commented on 2014-04-23 04:28

The tests failed in makechrootpkg so I had to run with --nocheck

Also, it prints a warning if you don't have perl-extutils-typemap. Consider at least opt-depending on that.

swiftgeek commented on 2014-03-16 04:46

It does -.- this is how optdepends works ffs…
If You are not reading what is shown after first install, it's your own damn fault :<
http://dpaste.com/1733883/
When new optdepend is added, same thing happens on upgrade… pacman believes in your ability to »read«

mpan commented on 2014-03-16 04:35

Then remove "slic3r.desktop" file. It's misleading if package doesn't support GUI out of the box.

swiftgeek commented on 2014-03-16 04:19

GUI is optional and no one is forcing You to this particular one (It's in optdepends with appropriate comment -.-). Same goes for OpenGL and other stuff

mpan commented on 2014-03-16 00:30

"perl-wx" should be in dependencies. Without that it's not possible to run GUI.

mpan commented on 2014-03-16 00:29

"wx-perl" should be in dependencies. Without that it's not possible to run GUI.

nickoe commented on 2014-02-16 12:41

Updated to RC3

swiftgeek commented on 2013-11-19 12:10

http://slic3r.org/releases/1.0.0RC1

nickoe commented on 2013-07-24 18:50

@Hiroe, I see the failures also, but I don't have much time for the moment to correct it, but I have looked at it, but perl-math-clipper and perl-boost-geometry-utils is always a mess for slic3r, because they are made by the same person, so up to date perl packages does not work with old versions of slicer ususally. You are advise to use the slic3r-git instead, at least for the moment.

Anonymous comment on 2013-07-23 19:08

I've rebuilt everything and it still seems to fail all tests.

t/[LOTS OF STUFF] ..... Math::Clipper version 1.22 required--this is only version 1.17 at [EVERY MODULE PRETTY MUCH]

I've modified it to use 1.22 instead and it fails a lot less tests. Now it's just getting a "deep recursion error". Can anyone confirm that this a problem with the pkgbuild and not my system?

ejona86 commented on 2013-06-25 00:36

For those seeing my comment applying to version 0.9.9, 0.9.10 fixed the issue with perl 5.18.

nickoe commented on 2013-06-24 16:24

@ejona86 btw, I don't get any failures with the current PKGBUILD

swiftgeek commented on 2013-06-14 15:11

And 0.9.10 is out

swiftgeek commented on 2013-06-08 16:48

Do not worry about 0.9.9, only 4 issues left to 0.9.10 ;)

ejona86 commented on 2013-06-08 16:45

This patch (http://pastie.org/8023596) is commit 43814e99f6c8bfc1a2d8cc0eae4a44d01a08b2af from the perl-518 branch re-applied to slic3r-0.9.9. I get three failing tests with it, however. That is considerably fewer failures than when running tests on the perl-518 branch...

swiftgeek commented on 2013-06-08 15:41

-git since few days works with perl-5.18 if somebody is interested. But it wont be a part of 0.9.10

swiftgeek commented on 2013-05-20 15:04

To anyone that is using weird version of (my) packages from AUR:
How to downgrade my perl-* packages:
1. Change pkgver to whatever u want
2. Change md5sum of tar from CPAN to 'SKIP'
3. Insert """ IgnorePkg = $pkgname """ in /etc/pacman.conf ofc with $pkgname being a text, not a var
4. Have a good day ☺ and don't forget remove that line from pacman.conf before upgrading slic3r

nickoe commented on 2013-05-15 07:33

I know perl-math-clipper is too new, but I had trouble making the depend/conflicts array accept a version range. How can one specefy that?

And yes, as swiftgeek says, downgrade perl-math-clipper to 1.20 for slic3r 0.9.9.

I have now updated the PKGBUILD to include swiftgeeks sed removals, also the perl version warning. Please remember the perl warning if you are going to talk to alex that creates slic3r.

Sorry that I was soo slow, I cannot keep up with swiftgeeks responsiveness.

nickoe commented on 2013-05-15 07:15

I know perl-math-clipper is too new, but I had trouble making the depend/conflicts array accept a version range. How can one specefy that?

And yes, as swiftgeek says, downgrade perl-math-clipper to 1.20 for slic3r 0.9.9.

swiftgeek commented on 2013-05-15 00:10

2) Downgrade perl-math-clipper to 1.20 and insert 'SKIP' instead of md5sum if You are lazy like me ;)
Tell if this helps

swiftgeek commented on 2013-05-14 23:15

1) @Nickoe: look at my PKGBUILD and sed-out those stupid deps
2) perl-math-clipper has changed recently
3) -git is broken again and i wont have any time till monday to investigate. In case of -git it's probably safe to disable checks (PKGBUILD has line for that to uncomment).

balwierz commented on 2013-05-14 23:09


1) I am getting the following complains:
==> Starting build()...
Checking prerequisites...
recommends:
* Growl::GNTP is not installed

// but perl-growl-gntp is not available in AUR nor is in 'depends' of PKGBUILD

2) One of the tests fail (all 3 subtests). Is it related to my Perl version (5.16.3-3) ?

t/clipper.t .......... 1/3
# Failed test 'hole is preserved after intersection'
# at t/clipper.t line 33.
# Structures begin differing at:
# $got->[0]{outer}[0][0] = '20'
# $expected->[0]{outer}[0][0] = '10'

# Failed test 'union of two ccw and one cw is a contour with no holes'
# at t/clipper.t line 63.
# Structures begin differing at:
# $got->[0]{outer}[0][0] = '40'
# $expected->[0]{outer}[0][0] = '0'

# Failed test 'difference of a cw from two ccw is a contour with one hole'
# at t/clipper.t line 70.
# Structures begin differing at:
# $got->[0]{outer}[0][0] = '40'
# $expected->[0]{outer}[0][0] = '0'
# Looks like you failed 3 tests of 3.
t/clipper.t .......... Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/3 subtests

// I DO have perl-boost-geometry-utils.06, not version 0.09

nickoe commented on 2013-05-01 21:46

guruise, you have to use perl-boost-geometry-utils 0.06, I will update the pkgbuild.

nickoe commented on 2013-05-01 21:39

guruise, you have to use perl-boost-geometry-utils 0.06, I will update the pkgbuild.

gururise commented on 2013-05-01 20:01

build failing:

t/polyclip.t ......... Running Slic3r under Perl >= 5.16 is not supported nor recommended
t/polyclip.t ......... 1/24
# Failed test 'line is clipped to square with hole'
# at t/polyclip.t line 146.
# Structures begin differing at:
# $got->[0][0][0] = '152.742'
# $expected->[0][0][0] = '152'
# Looks like you failed 1 test of 24.

gururise commented on 2013-05-01 19:55

Getting the following error even though I have perl-boost-geometry-utils (v0.09) installed.

Failed 1/1 subtests
t/vibrationlimit.t ... Boost::Geometry::Utils version 0.06 required--this is only version 0.05 at /tmp/yaourt-tmp-gene/aur-slic3r/src/Slic3r-0.9.9/t/../lib/Slic3r.pm line 32.
BEGIN failed--compilation aborted at /tmp/yaourt-tmp-gene/aur-slic3r/src/Slic3r-0.9.9/t/../lib/Slic3r.pm line 32.
Compilation failed in require at t/vibrationlimit.t line 10.
BEGIN failed--compilation aborted at t/vibrationlimit.t line 10.
# Looks like your test exited with 255 before it could output anything.
t/vibrationlimit.t ... Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 9/9 subtests

gururise commented on 2013-05-01 19:50

Getting error building:

t/support.t (Wstat: 65280 Tests: 0 Failed: 0)
Non-zero exit status: 255
Parse errors: Bad plan. You planned 1 tests but ran 0.
t/vibrationlimit.t (Wstat: 65280 Tests: 0 Failed: 0)
Non-zero exit status: 255
Parse errors: Bad plan. You planned 9 tests but ran 0.
Files=20, Tests=3, 1 wallclock secs ( 0.06 usr 0.02 sys + 0.72 cusr 0.09 csys = 0.89 CPU)
Result: FAIL
Failed 19/20 test programs. 0/3 subtests failed.

nickoe commented on 2013-04-09 13:35

Yes

xoan commented on 2013-04-09 11:54

Forget it :)

I just reinstalled, edited PKGBUILD and change pkgver and md5sum. Is it the right way?

xoan commented on 2013-04-09 11:51

How can I downgrade perl-boost-geometry-utils to version 0.6?

swiftgeek commented on 2013-04-09 11:41

Use perl-boost-geometry-utils 0.6 for this snapshot of slic3r

-git is broken upstream temporally again ;)

xoan commented on 2013-04-09 11:38

I'm using this package version. Not tested with slic3r-git.

BTW, the last update to this package returns some fail tests [1] and slic3r couldn't be installed. Previous slic3r version just works (with perl 5.16 warning).

I'll give a try to slic3r-git.

[1] http://sprunge.us/Ubeh

nickoe commented on 2013-04-09 10:55

Hmm, I have not seen that occuour, I will test when I get proper time. But does this also occour with slic3r-git?

xoan commented on 2013-04-09 10:41

Any workaround for this [1] DBUS related issue?

[1] https://github.com/alexrj/Slic3r/issues/1015

nickoe commented on 2013-04-07 14:34

I have now added the perl-boost-geometry-utils version constraint and made the PKGBUILd utilize the package function.

Ratfink commented on 2013-04-06 20:22

Version 0.9.9 depends on perl-boost-geometry-utils >= 0.06, please update the package's dependencies.

nickoe commented on 2013-01-19 12:29

Added depend

ejona86 commented on 2013-01-19 02:52

slic3r now also depends on perl-encode-locale.

nickoe commented on 2013-01-18 21:53

swiftgeek, I think that your comment to luk156, may be hard to understand, though I get it, and do agree, but I still choose to maintain the releases. :) And still thank you for maintaining the depends.

nickoe commented on 2013-01-18 21:49

Updated to 0.9.8

swiftgeek commented on 2013-01-18 14:05

@luk156 use -git. It's slic3r - not linux kernel

Anonymous comment on 2013-01-18 14:02

new version 0.9.8, please update

nickoe commented on 2012-11-30 22:03

So you say that I should download it from git? Instead of bundeling in the tar?

swiftgeek commented on 2012-11-30 22:00

.desktop file should be also a part of the source (git) and PNG for 256x256 (which is in .ico) is missing. Also there should be a SVG version

nickoe commented on 2012-11-30 21:59

What do you mean swiftgeek? I fail to get your point.

swiftgeek commented on 2012-11-30 21:05

s/package/source

swiftgeek commented on 2012-11-17 18:05

.desktop file should be also a part of the package and PNG for 256x256 (which is in .ico) is missing. Also there should be a SVG version

ejona86 commented on 2012-11-17 18:04

Fix what upstream? The .desktop is part of this package, not part of upstream. Slic3r upstream does not provide a .desktop file as far as I can tell. Slic3r upstream includes both PNGs and an ICO as part of its installation (both in /usr/bin/vendor_perl/var).

swiftgeek commented on 2012-11-17 17:59

Then go fix this upstream (in slic3r).

ejona86 commented on 2012-11-17 17:58

@swiftgeek. But ICO is a different format than PNG. The Icon Theme Specification went on to say 'and the extension must be ".png", ".xpm", or ".svg"'. I have tried a ico before, and it didn't work for me. If you see any documentation that says that ico is supported or preferred, I would love to see it.

swiftgeek commented on 2012-11-17 17:54

ico is just a container for eg. png -.-
And the highest resolution provided by the source is 256x256 in that ico file…

ejona86 commented on 2012-11-17 17:52

It should not be ico. It should be xpm, png, or svg. http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html#id2680905 references the Icon Theme Specification. http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html says "The image files must be one of the types: PNG, XPM, or SVG".

swiftgeek commented on 2012-11-17 17:46

it should be ico... or svg

ejona86 commented on 2012-11-17 17:44

slic3r.desktop's Icon= should point to /usr/bin/vendor_perl/var/Slic3r_128px.png instead of /opt/slic3r/res/Slic3r.ico.

nickoe commented on 2012-11-10 13:05

Tectu, depends now added

Tectu commented on 2012-11-08 16:56

It's missing the following depency: perl-math-convexhull-monotonechain

nickoe commented on 2012-10-23 06:42

@swiftgeek yes, probably, but I have to modify more than a version numbder don't I? I will be glad to discuss on #archlinux.

swiftgeek commented on 2012-10-23 06:39

With slic3r the git version is stable and tagged versions .... are just tagged ;]

nickoe commented on 2012-10-23 06:35

I have now updated the package according to ejona86's version of the PKGBUILD. I am happy that it now does not use a binary precompiled slic3r but a source tar.

@swiftgeek I think it is nicer to have a dedicated "no-suffix" package, when you wan't a stable version of a program, hence I maintain this package. The -git package is still nice to have when I wan't to test new features. I like to have a PKGBUILD that I don't have to modify to get the stable/official latest version.

ejona86 commented on 2012-10-23 04:26

@swiftgeek. My PKGBUILD requires no modification to use a tag instead of master (thus, I think easier), is obvious which version is installed (-git PKGBUILDs don't tell you which commit the code was) (thus, again, easier), and is fewer lines of code because of no double "git cloning" and other git bits (cleaner). The tar.gz mine downloads is 512K; git clone downloads 2.81MB (less bandwidth). My PKGBUILD is "normal" in that it could also become part of community if it was popular enough.

I have no issue with *-git PKGBUILDs, but I only want to use them if there is a bug in the current version of the package but fixed on master (or that new shiny feature just got added to master :-) ).

swiftgeek commented on 2012-10-23 02:56

but You can use git to download tagged branch... which seems to be way easier, cleaner and takes less bandwidth ;)

ejona86 commented on 2012-10-23 02:52

I disagree with swiftgeek, in that I don't want the git version. I do want the code built though (as is standard for PKGBUILDs of open-source components), and not using the binaries like this package is doing now.

I adapted swiftgeek's git-based PKGBUILD for handling release tags (version 0.9.3): http://pastebin.com/Pgpfb3uu .

swiftgeek commented on 2012-09-06 11:25

There is no reason to use "stable" code - unless it's a package in official repo.
Current GIT version is always better here.

And use git even for the official package - there are tags in this repo.
https://github.com/alexrj/Slic3r/tree/0.9.2

swiftgeek commented on 2012-09-06 11:19

There is no reason to use "stable" code - unless it's a package in official repo.
GIT is always better here.