Package Details: slime-git 2.20.9.gcdb7e0ca-1

Git Clone URL: https://aur.archlinux.org/slime-git.git (read-only)
Package Base: slime-git
Description: The Superior Lisp Interaction Mode for Emacs - from git
Upstream URL: http://common-lisp.net/project/slime
Licenses: GPL
Conflicts: slime
Provides: slime
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 22
Popularity: 0.002375
First Submitted: 2014-03-03 13:19
Last Updated: 2017-12-16 12:06

Dependencies (7)

Required by (1)

Sources (1)

Latest Comments

1 2 3 Next › Last »

Stenten commented on 2015-02-28 20:27

FYI the package fails to compile if you have texinfo-legacy installed. Running 'pacman -S texinfo' will replace 'texinfo-legacy' with 'texinfo' and allow everything to run smoothly.


==> Starting package()...
cat ../ChangeLog ../contrib/ChangeLog | \
sed -ne '/^[0-9]/{s/^[^ ]* *//; s/ *<.*//; p;}' | \
sort | \
uniq -c | \
sort -nr| \
sed -e 's/^[^A-Z]*//' | \
LC_ALL=C awk -f texinfo-tabulate.awk \
> contributors.texi
makeinfo slime.texi
slime.texi:6: Unknown command `codequoteundirected'.
slime.texi:7: Unknown command `codequotebacktick'.
makeinfo: Removing output file `/home/stenten/builds/slime-git/src/slime/doc/slime.info' due to errors; use --force to preserve.
Makefile:38: recipe for target 'slime.info' failed
make: *** [slime.info] Error 1
==> ERROR: A failure occurred in package().
Aborting...

nitralime commented on 2014-08-26 19:07

I have tried to build it again (version: slime-git 2.9.7.g1d5586c)
and it has worked without any problem on both systems where I encountered
the reported build error(s).

haawda commented on 2014-08-16 12:15

I still cannot reproduce the error unless I use pacaur or yaourt, and in case of pacaur it helps to set BUILDDIR to a local path.

nitralime commented on 2014-08-16 09:38

I'm still getting the error:
...
In toplevel form:
slime-fancy.el:13:24:Error: Symbol's value as variable is void: slime-fuzzy-complete-symbol
Makefile:16: recipe for target 'slime-fancy.elc' failed
make[1]: *** [slime-fancy.elc] Error 1
make[1]: Leaving directory '/home/nik/AUR/build/slime-git/src/slime/contrib'
Makefile:91: recipe for target 'contrib-compile' failed
make: *** [contrib-compile] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Is there any workaround or solution for that?

nitralime commented on 2014-08-16 09:34

I'm still getting the error:

In toplevel form:
slime-fancy.el:13:24:Error: Symbol's value as variable is void: slime-fuzzy-complete-symbol
Makefile:16: recipe for target 'slime-fancy.elc' failed
make[1]: *** [slime-fancy.elc] Error 1
make[1]: Leaving directory '/home/nik/AUR/build/slime-git/src/slime/contrib'
Makefile:91: recipe for target 'contrib-compile' failed
make: *** [contrib-compile] Error 2
==> ERROR: A failure occurred in build().
Aborting...

haawda commented on 2014-07-14 20:45

I can now reproduce the error using both pacaur or yaourt. But rohendra gets the same error with plain makepkg, where I do not.

Someone out there using an aur-helper not written in bash?

krstoff commented on 2014-07-14 00:51

Getting the same errors as previous users when I use pacaur, but not when I just makepkg the pkgbuild. During compilation cl-lib isn't being loaded in the former case but not in the latter. I don't have any answers as to why.

haawda commented on 2014-06-21 09:06

FiyreWyrkz, no, you have a build problem with slime-git 2.7.2.g250dda5, as your log says. It is exactly the same error as rohendra has, which I still cannot reproduce here, sorry.

FiyreWyrkz commented on 2014-06-19 22:18

I seem to be having a buld error with slime-git 2.6.7.g892f503-2 (Arch x86_64)

Here's a paste to my attempted build. http://pastebin.com/ShFkYJ8w

rohendra commented on 2014-05-31 19:59

I have mailed you the logs.