Package Details: slime-git 2.24.r1.g01531b09-1

Git Clone URL: https://aur.archlinux.org/slime-git.git (read-only)
Package Base: slime-git
Description: The Superior Lisp Interaction Mode for Emacs - from git
Upstream URL: http://common-lisp.net/project/slime
Licenses: GPL
Conflicts: slime
Provides: slime
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 22
Popularity: 0.001765
First Submitted: 2014-03-03 13:19
Last Updated: 2019-06-01 07:35

Dependencies (7)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

haawda commented on 2014-05-30 22:44

As you may have noticed from my previous post, I cannot reproduce your error. I now installed emacs from [extra] repo and still cannot. At least it is clearly not yaourt's fault - often it is in such cases.

Can you post the complete log using some pastebin service or e-Mailing me?

rohendra commented on 2014-05-29 20:08

I have recently installed Arch and I am new to emacs too.
So, I am not sure about whether yaourt is AUR-3.0 aware or not.

emacs version is 24.3-6

I have tried installing slime-git manually using makepkg but still getting the same error.

haawda commented on 2014-05-29 11:52

Is yaourt AUR-3.0 aware already?

And, what version of emacs do you use?

haawda commented on 2014-05-29 11:51

Is yaourt AUR-3.0 aware already?

rohendra commented on 2014-05-28 22:44

I am facing below issue while installing slime-git using yaourt. Please help me in figuring this out.

error-
In toplevel form:
slime-fancy.el:13:24:Error: Symbol's value as variable is void:
slime-fuzzy-complete-symbol
Makefile:16: recipe for target 'slime-fancy.elc' failed
make[1]: *** [slime-fancy.elc] Error 1
make[1]: Leaving directory
'/tmp/yaourt-tmp-rohendra/aur-slime-git/src/slime/contrib'
Makefile:89: recipe for target 'contrib-compile' failed
make: *** [contrib-compile] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build slime-git.
==> Restart building slime-git ? [y/N]

haawda commented on 2014-03-06 09:30

Probably that is an good idea.

nitralime commented on 2014-03-05 19:09

I've cloned the git repository and excuted "make" directly on my notebook
at home, and got again the same compilation error as reported yesterday:
...
In toplevel form:
slime-clipboard.el:70:40:Error: Wrong type argument: sequencep, value
Makefile:16: recipe for target 'slime-clipboard.elc' failed
...

I'm running a fresh archlinux installation without any special settings.
Should I report it to the slime mailing list?

haawda commented on 2014-03-05 15:59

Still cannot reproduce. IMHO defun* is defined by cl.el, which should be required autoamtically. Did you do something special to prevent that?

Wih AUR helper I mean something like yaourt or packer, i.e. a tool to download and build AUR packages automatically.

nitralime commented on 2014-03-05 09:34

I've tried to build it on another machine and got the following error:
....
In toplevel form:
slime-package-fu.el:2:1:Error: Symbol's function definition is void: defun*
Makefile:16: recipe for target 'slime-package-fu.elc' failed
make[1]: *** [slime-package-fu.elc] Error 1
make[1]: Leaving directory '/AUR/sources/slime/contrib'
Makefile:79: recipe for target 'contrib-compile' failed
make: *** [contrib-compile] Error 2
==> ERROR: A failure occurred in build().
Aborting...

I'm using emacs 24.3-6 from extra!
What do you mean by AUR helper?

haawda commented on 2014-03-04 10:16

Cannot reproduce. I both tried with emacs 24.3 from [extra], emacs-lucid-bzr and emacs-xwidget-bzr from AUR.

You seem to use some aur helper, did you try without such a helper?