Package Details: smartgit 7.1.3-1

Git Clone URL: https://aur.archlinux.org/smartgit.git (read-only)
Package Base: smartgit
Description: Git client with Hg and SVN support.
Upstream URL: http://www.syntevo.com/smartgit
Keywords: git hg svn vcs
Licenses: custom
Replaces: smartgithg
Submitter: alyst
Maintainer: alyst
Last Packager: alyst
Votes: 121
Popularity: 3.957993
First Submitted: 2014-11-17 17:04
Last Updated: 2016-04-26 15:47

Latest Comments

xgdgsc commented on 2015-05-17 03:01

Please update to 6.5.8

alyst commented on 2015-01-14 15:44

@Brinox Thanks for reporting. The URL to the tar.gz was changed on Syntevo site. I've updated the PKGBUILD.

alyst commented on 2015-01-14 15:10

@Brinox Thanks for the report. I could reproduce the issue, but the problem is that the sum in PKGBUILD is what they list on their site at the moment. I've written to Syntevo support, and I don't recommend installing the package from that source until they would sort out the things.

Brinox commented on 2015-01-14 12:40

The MD5 hash of smartgit-generic-6_5_4.tar.gz seems to be incorrect, please have a look on this. Thanks!

ryuzy commented on 2015-01-03 14:30

I got this at the end of the install:
update desktop mime database...
Error in file "/usr/share/applications/dassault-systemes_draftsight.desktop": "application-vnd.dassault-systemes.draftsight-dwg" is an invalid MIME type ("application-vnd.dassault-systemes.draftsight-dwg" does not contain a subtype)
Error in file "/usr/share/applications/dassault-systemes_draftsight.desktop": "application-vnd.dassault-systemes.draftsight-dwt" is an invalid MIME type ("application-vnd.dassault-systemes.draftsight-dwt" does not contain a subtype)
Error in file "/usr/share/applications/dassault-systemes_draftsight.desktop": "application-vnd.dassault-systemes.draftsight-dxf" is an invalid MIME type ("application-vnd.dassault-systemes.draftsight-dxf" does not contain a subtype)

alyst commented on 2014-12-20 19:29

@Firef0x thanks, I've added your translations

Firef0x commented on 2014-12-20 12:47

Hello, @alyst !

SmartGit 6.5.3 is released! BTW, would you mind adding Chinese translation into the smartgit.desktop ? Pls refer to https://build.opensuse.org/package/view_file/home:firef0x/smartgithg/smartgit.desktop?expand=1

Pls rest assured that I can speak Simplified Chinese(zh-CN) and Traditional Chinese(zh-HK and zh-TW).

Hope for your reply!

Thanks and regards!

xgdgsc commented on 2014-12-13 03:56

Why am I getting this error:
$ yaourt -S smartgit

==> Downloading smartgit PKGBUILD from AUR...
==> ERROR: smartgit not found in AUR.

alyst commented on 2014-12-12 06:43

@jhrdka @flaccid Thanks! I've incorporated your suggestions into 6.5.2-1.

jhrdka commented on 2014-11-26 18:38

Hello,
I've created icon links into /usr/icons/hicolor, so the absolute icon path in .desktop file can be removed (to allow icon themes do their work).

Also as I'am Czech I just had to add Czech .desktop comment translation.. ;)

Could you please merge my changes?
Thanks!

https://www.dropbox.com/s/jqe1t9k7dfhcito/smartgit-6.5.1-3.src.tar.gz?dl=0

flaccid commented on 2014-11-21 01:39

Would be handy to add a replaces=(smartgithg)

alyst commented on 2014-11-17 17:11

Syntevo has released SmartGit 6.5.0. Note that the name was reverted to SmartGit. To avoid confusion the AUR package name was also updated. There's now smartgit-6.5.0 available in the AUR. "smartgithg" should soon be merged into it.

cedricziel commented on 2014-10-09 08:38

Would you mind setting the retrieval URL to use https? I have serious issues with a proxy on this package only and it's available over https anyways..

orschiro commented on 2014-06-09 17:46

I was able to trace back the issue. It was caused by freshplayerplugin-git from the AUR. It is a package to provide a sandboxed Flash player. For some reasons it conflicts with smartgithg.

Muflone commented on 2014-06-04 23:17

@orschiro
I've never issued any command to let it to work.
Just only once, when smartgit 6.1 started gave me the warning about disable stack guard, then an error dialog was shown asking to inform the developers about the error. Closed such dialog the program started and never shown again any error dialog.
The warning about disable stack guard is still printed on the terminal but no errors are shown apart that warning message.

So I think you have a different issue, not related to the previous warning.

On another Arch x86_64 installation the error dialog was never shown at all.

orschiro commented on 2014-06-04 21:25

@Muflone

Thanks for your comment!

What command did you issue exactly to disable stack guard?

Muflone commented on 2014-06-04 19:05

@orschiro
I'm having the same warning about OpenJDK and disabled stack guard but smartgit works properly after an error dialog was shown only once.

orschiro commented on 2014-06-04 07:00

@alyst

Thanks! Anyone else having issues with launching smartgit?

v6.1 did not fix the issue for me. It's still crashing. :(

dflt commented on 2014-06-03 13:17

After latest update I get: /opt/smartgithg/bin/smartgithg.sh: /opt/smartgithg/bin/smartgithg.sh: cannot execute binary file

alyst commented on 2014-06-03 10:25

@orschiro I'm not sure. On Syntevo site it's implied that OpenJDK should be supported, but I have not tested. You can try Oracle's JDK. Or maybe the issue is fixed in the 6.0.1 version.

orschiro commented on 2014-05-29 08:34

@alyst

Thanks. So could it be an issue related to openjdk?

~ pacman -Q | grep jd
jre7-openjdk 7.u55_2.4.7-1
jre7-openjdk-headless 7.u55_2.4.7-1

alyst commented on 2014-05-28 22:03

@orschiro I have similar warning for libjnidispatch.so, but smartgit itself does not crash and functions normally. I guess it's related to java version. Mine is

java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

orschiro commented on 2014-05-28 21:55

With the latest update to version 6, smartgithg executes with an error after showing the loading bar screen:

Can someone confirm this?

~ smartgithg
OpenJDK 64-Bit Server VM warning: You have loaded library /home/orschiro/Dotfiles/smartgit/.smartgit/6/jna-tmp/com/sun/jna/linux-i386/libjnidispatch.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
NOT SANDBOXED
[ERROR:flash/platform/pepper/common/pep_process.cpp(19)] CHECK(g_process_type == PROCESS_TYPE_UNKNOWN) failed
java version "1.7.0_55"
OpenJDK Runtime Environment (IcedTea 2.4.7) (ArchLinux build 7.u55_2.4.7-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
/usr/bin/smartgithg: line 99: 29470 Aborted (core dumped) $_JAVA_EXEC $_VM_PROPERTIES -Xmx${SMARTGITHG_MAX_HEAP_SIZE} -Xverify:none -Dsmartgit.vm-xmx=${SMARTGITHG_MAX_HEAP_SIZE} -jar "$SMARTGIT_HOME/lib/bootloader.jar" "$@"

alyst commented on 2014-05-28 14:41

@Muflone I guess that's because they have just released version 6. fixed

Muflone commented on 2014-05-28 13:38

wrong source url for the *.tar.gz file

alyst commented on 2014-05-27 16:40

@Muflone thanks for suggestion, I've updated smartgithg.desktop as you recommend

Muflone commented on 2014-05-05 15:38

@alyst
please, would you add
StartupWMClass=SmartGit/Hg
in the .desktop file in order to allow to window managers like GNOME overview or Unity to track the smartgit windows instead of creating two icons.
See http://askubuntu.com/a/40327

alyst commented on 2013-06-11 07:03

@dapolinario java-environment is suggested by namcap, when checking the smartgithg package. If that dependency creates any inconveniences I will revert it to java-runtime for the next upstream version.

dapolinario commented on 2013-06-11 02:20

Java-environment is not necessary, only the java-runtime, as stated in: http://www.syntevo.com/smartgithg/download.

dapolinario commented on 2013-06-11 02:20

Java-environment is not necessary, only the java-runtime, as stated in: http://www.syntevo.com/smartgithg/download; jsessionid = B9B012A8F2378CA8CD6CF12351558B76

alyst commented on 2013-06-02 17:51

@roentgen thx for pointing out, it was there since I forked the package off smartsvn. In principle, post_remove() should have been handling the removal of the symlink. Now chmod/ln is in package(), the removal of the old package might be required.

roentgen commented on 2013-06-02 15:01

alyst, I wonder why did you choose to do the chmod and ln stuff in the post_install instead putting those in the package() section of the PKGBUILD.

It leaves untracked files in /usr/bin.

Muflone commented on 2013-05-31 13:33

New version 4.5.4 is available

alyst commented on 2013-01-29 07:45

@jjacky thanks, added proper conflicts/provides for 4.0.1

lxuyrbwy commented on 2013-01-24 11:31

I suggest applying the intermediate build[1] that fixes a bug when fetching repositories with external submodules that require authentication.

It is an incremental update, so, just make the PKGBUILD unpack the contents of the zip to the /opt/smartgithg

According to syntevo, the bug will be fixed on 4.0.1 release.

[1] http://www.syntevo.com/smartgithg/intermediate-builds.html

jjacky commented on 2013-01-20 11:58

I think there might be some "mistakes" in the conflicts/provides arrays, for this and smartgithg-ea.

smartgithg has conflicts=(smartgithg-ea) which I'm guessing might be intended because they're the same version now, but if so I think it should be smartgithg-ea that contains the (versionned) conflict then.
smartgithg however probably should have a conflicts=(smartgit) and maybe a provides=(smartgit) as well.

And smartgithg-ea should provide (and conflict with) a versionned smartgithg, in addition to conflict with smartgit-ea.

alyst commented on 2013-01-18 23:44

The upstream was rebranded into SmartGit/Hg.
The new AUR package is https://aur.archlinux.org/packages/smartgithg/

alyst commented on 2013-01-18 23:41

smartgit(https://aur.archlinux.org/packages/smartgit) package was rebranded as SmartGit/Hg.

alyst commented on 2012-09-22 20:48

@MorGothmog Thanks, added gtk2 dependency to the update.

MorGothmog commented on 2012-09-03 15:23

The package should depend on gtk2, as SmartGit cannot start without it - although not having gtk2 might be an uncommon case.

MorGothmog commented on 2012-09-03 15:21

The package should depend on gtk2, as SmartGit cannot start without it - although not having gtk2 might be an uncommon case.

heaven commented on 2012-08-03 05:50

Md5 c8eb38f3bd1f0845141381c288429996 for 3.0.8

alyst commented on 2012-06-28 09:44

Updated to 3.0.7. As indicated in the changelog, the GitHub integration should be working again.

jiuren commented on 2012-06-15 14:38

The 3.0.6 version is ready. 3.0.5 doesn't work with github anymore since it's still using the V2 api.

alyst commented on 2012-05-23 20:24

@rp9 thanks!
I've updated the package

rp9 commented on 2012-05-23 11:25

@alyst: seems the dropped the session auth. I can directly download now: http://www.syntevo.com/download/smartgit/smartgit-generic-3_0_4.tar.gz
updated my smartsvn package.

Anonymous comment on 2012-05-23 07:05

Temporary solution until the downloader gets fixed:
- download the tarball, extract, cd to the new folder, and try one makepkg -s which will fail (this will create the required folders)
- manually download the smartgit-generic-3_0_4.tar.gz file from http://www.syntevo.com/smartgit/download.html?5&file=smartgit/smartgit-generic-3_0_4.tar.gz
- place this file inside your above folder, inside the src folder
- edit PKGBUILD and comment out the line below:

python3 downloader.py $_pkgdownload_path $_pkgfile_param
- run makepkg -s again

alyst commented on 2012-05-22 22:00

The syntevo website is updated, the current downloader cannot cope with it.
It looks like now there's one redirect and one set-cookie more (just before the last redirect to an actual file).
I cannot reproduce yet the correct response with the current downloader script (it doesn't have this final set-cookie header that I see in the browser).
I'll appreciate if someone can solve this :)

American_Jesus commented on 2012-05-22 17:07

Out-of-date, downlaod fail:

Initiating smartgit-generic-3_0_4.tar.gz download from www.syntevo.com...
Connecting to www.syntevo.com...
Request URL: http://www.syntevo.com/smartgit/download.html?file=smartgit/smartgit-generic-3_0_4.tar.gz
Agreeing with the license...
Traceback (most recent call last):
File "downloader.py", line 97, in <module>
sys.exit(downloader.suck())
File "downloader.py", line 62, in suck
raise RuntimeError( 'Error parsing license agreement html\n' )
RuntimeError: Error parsing license agreement html

Anonymous comment on 2012-04-13 15:14

@alyst Thanks!!!

alyst commented on 2012-04-12 07:35

@PatricioArenas You should specify /usr/bin/git and optionally /usr/bin/hg in the SmartGit setup, pacman manager has nothing to do with that settings.
But thanks for pointing out that git and hg are not listed as the packages SmartGit depends upon (i.e. they should be installed before you can use SmartGit).
Fixed in the updated PKGBUILD.

Anonymous comment on 2012-04-12 00:50

hi
i have a problem with the Setup SmartGit, in the step wich Git Executable and Hg Executable is required.
I put /usr/bin/pacman in both. But I supposed that is wrong because when i press next, the installer says that Git executable is not valid:
>>'/usr/bin/pacman' seems to be no valid Git executable. Git version 1.7.1 or newer is required.
>>Even if the Git executable is valid, there are a couple of possible mis.configurations which result in improper behavior of 'git --version'; for details refer e.g. >>to: http://stackoverflow.com/questions/3431361

regards

alyst commented on 2012-01-27 22:19

@Superpiffer
Thanks, fixed the script to work with their updated site, -ea series as well.

Superpiffer commented on 2012-01-27 09:27

Version 2.1.7 released and PGKBUILD not working anymore, please update. Thanks.

Superpiffer commented on 2012-01-19 12:11

The software requires a change to the executable file to use it with openjdk changing the line
_VM_PROPERTIES="-Dsun.io.useCanonCaches=false -Dsun.java.command=SmartGit"
in
_VM_PROPERTIES="-Dsun.io.useCanonCaches=false -Dsun.java.command=SmartGit -Dsmartgit.checkIncompatibleJava=false"
Exist a workaround for prevent the editing? Thank you.

alyst commented on 2011-12-10 13:32

@heaven
Thanks, I've incorporated your changes. The $pkgver, however, stays the same to conform to Arch packaging guidelines.

heaven commented on 2011-12-10 13:03

#Maintainer: Alexey Stukalov <astukalov@gmail.com>
#forked from smartgit AUR package, maintainer Rene Peinthor
pkgname=smartgit
pkgver=2.1
pkgrel=6
pkgdesc="A Git GUI client written in Java"
arch=("any")
url="http://www.syntevo.com/smartgit/index.html"
license=('custom')
depends=("java-runtime" "desktop-file-utils" "sh")
makedepends=("python>=3")
provides=(smartgit=$pkgver)
source=(smartgit.desktop downloader.py)
install="smartgit.install"
md5sums=('1d4bb1a70a3c6a6d04fe938beb28808b'
'abf1fe0a54b0d0370cc99350063f83ce')
smartgitmd5sum='bce918bcb74c25ee88347587fb9a3526'

_pkgver=$(echo $pkgver | sed 's/\./_/')
extracted="$pkgname-$_pkgver"_"$pkgrel"
srcname="$pkgname-generic-$_pkgver"_"$pkgrel.tar.gz"

build() {
cd "$srcdir"
python3 downloader.py smartgit $srcname

echo "${smartgitmd5sum} *$srcname" | md5sum -c || (error "md5sum doesn't match" && return 1)

tar xzf $srcname
}

package() {
cd "$srcdir"

install -D -m644 "${extracted}"/license.html "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
mkdir -p "${pkgdir}"/opt
mv "${extracted}" ${pkgdir}/opt/$pkgname || return 1

install -D -m644 smartgit.desktop "${pkgdir}"/usr/share/applications/smartgit.desktop
}

heaven commented on 2011-12-10 12:16

Thanks for the package!

agaida commented on 2011-11-14 05:02

Smartgit don't work with openjdk.

florianbw commented on 2011-09-29 11:36

Thanks for the package. Please change jre to java-runtime which is provided by jre but also by openjdk.

alyst commented on 2011-09-01 17:32