Package Details: smtp-cli 3.7-1

Git Clone URL: https://aur.archlinux.org/smtp-cli.git (read-only)
Package Base: smtp-cli
Description: Perl based command line SMTP client
Upstream URL: http://www.logix.cz/michal/devel/smtp-cli
Licenses: GPL
Submitter: sh0
Maintainer: severach
Last Packager: severach
Votes: 3
Popularity: 0.000001
First Submitted: 2010-09-13 08:42
Last Updated: 2016-09-12 04:54

Latest Comments

gojun077 commented on 2015-01-25 10:25

Version 3.7 is available from https://github.com/mludvig/smtp-cli

edited the PKGBUILD as follows:
...
pkgver=3.7
...
url="https://github.com/mludvig/smtp-cli"
...
source=('git+https://github.com/mludvig/smtp-cli.git')
md5sums=('SKIP')
...
package() {
install -Dm755 "$srcdir/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
}

CrookedNixon commented on 2014-10-15 07:12

Updated to current version of smtp-cli 3.6

Also updated to the new PKGBUILD standards.

gojun077 commented on 2014-07-10 03:39

Please update pkgver to 3.6 and m5sums, which should now be:

71e8b4812c2944c6c95c7f673084dd14

to psytoolkit:

I was able to install the package without the module libmagic and have verified that smpt-cli works properly.

to maintainer:

The PKGBUILD needs to be updated to adhere to pacman 4.1 syntax:
https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

remove the build{} clause and replace with:

package() {
install -Dm755 "$srcdir/$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
}

psytoolkit commented on 2014-07-01 12:56

You need to add the perl module LibMagic, but there is no package for this. To fix this, I logged in as root and typed the following to manually install the perl module in the command line prompt:

cpan install File::LibMagic

Then it works perfectly at the time of writing, and is an alternative for sendEmail, which at the time of writing does not work due to a bug in the ssl module.

psytoolkit commented on 2014-07-01 12:55

You need to add the perl module LibMagic, but there is no package for this. To fix this, I logged in as root and typed the following to manually install the perl module:


cpan install File::LibMagic for smtp-cli

Then it works perfectly at the time of writing, and is an alternative for sendEmail, which at the time of writing does not work due to a bug in the ssl module.