Package Details: snapmaker-luban 4.10.2-1

Git Clone URL: https://aur.archlinux.org/snapmaker-luban.git (read-only, click to copy)
Package Base: snapmaker-luban
Description: Snapmaker Luban is an easy-to-use 3-in-1 software tailor-made for Snapmaker machines.
Upstream URL: https://github.com/Snapmaker/Luban
Licenses: AGPL v3
Submitter: josesj
Maintainer: TurboPunk
Last Packager: TurboPunk
Votes: 6
Popularity: 0.000235
First Submitted: 2020-04-21 15:15 (UTC)
Last Updated: 2024-01-17 13:46 (UTC)

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

TurboPunk commented on 2023-01-11 14:56 (UTC)

@rubenvb, thanks for the feedback. I'm unable to reproduce your error so far.

I did however encounter other errors when trying more systems then I used for testing earlier. I've added some more make dependencies to get around them.

Can you please retry and see if it works. If it doesn't, please provide some more information on your installation.

rubenvb commented on 2022-12-24 17:34 (UTC)

I get these errors building it, seems like a missing dependency somewhere? I also get lots of "outdated version" warnings, but I suppose most versions are defined by the Luban devs and not this package?

[18:23:11] Finished 'production' after 5.3 min
npm notice 
npm notice New major version of npm available! 7.24.0 -> 9.2.0
npm notice Changelog: https://github.com/npm/cli/releases/tag/v9.2.0
npm notice Run npm install -g npm@9.2.0 to update!
npm notice 
> snapmaker-luban@4.4.0 electron-builder
> electron-builder --publish never
• electron-builder  version=22.9.1 os=6.0.12-arch1-1
• loaded configuration  file=package.json ("build" field)
• writing effective config  file=output/builder-effective-config.yaml
• installing production dependencies  platform=linux arch=x64 appDir=/home/ruben/.cache/pikaur/build/snapmaker-luban/src/Luban-4.4.0/dist/Luban
⨯ /home/ruben/.cache/pikaur/build/snapmaker-luban/src/.nvm/versions/node/v12.22.12/bin/node exited with code ERR_ELECTRON_BUILDER_CANNOT_EXECUTE
Error output:
Error output:
npm ERR! code ETARGET
npm ERR! notarget No matching version found for mime-types@~2.1.34.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/ruben/.npm/_logs/2022-12-24T17_24_09_059Z-debug.log
stackTrace=
Error: /home/ruben/.cache/pikaur/build/snapmaker-luban/src/.nvm/versions/node/v12.22.12/bin/node exited with code ERR_ELECTRON_BUILDER_CANNOT_EXECUTE
Error output:
Error output:
npm ERR! code ETARGET
npm ERR! notarget No matching version found for mime-types@~2.1.34.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/ruben/.npm/_logs/2022-12-24T17_24_09_059Z-debug.log
at ChildProcess.<anonymous> (/home/ruben/.cache/pikaur/build/snapmaker-luban/src/Luban-4.4.0/node_modules/builder-util/src/util.ts:243:14)
at Object.onceWrapper (events.js:421:26)
at ChildProcess.emit (events.js:314:20)
at maybeClose (internal/child_process.js:1022:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

TurboPunk commented on 2022-11-15 23:10 (UTC)

@philb38, could you please share the errors you get so I could try to resolve them? For me the package builds fine on 2 different machines.

philb38 commented on 2022-11-15 17:00 (UTC)

The package seems to fail building on both of my machines. I have switched to the binary package, and it is much better... ;)

TurboPunk commented on 2022-11-10 21:20 (UTC)

You're right, thanks for pointing that out!

I've duplicated the binary package to snapmaker-luban-bin and I've changed this package to build the application from source.

Keeping the binary package up to date was the only experience I had with packages up till now. Improvements are welcome!

svenstaro commented on 2022-11-04 12:21 (UTC)

The package currently repackages upstream binary packages. It should rather build stuff from source (https://github.com/Snapmaker/Luban/blob/master/docs/Development.md) and a separate package called snapmaker-luban-bin may repackage the upstream binary packages in order to keep with AUR guidelines.

Quantasy commented on 2022-05-25 11:26 (UTC)

Thank you for the swift update!! You made my day!

TurboPunk commented on 2022-03-14 22:11 (UTC)

@gatonero, upstream seems to have re-released 4.2.2, resulting in a different build. I've corrected the sha256sum. Thanks for the feedback!

gatonero commented on 2022-03-14 21:07 (UTC)

The correct sha256sums for snapmaker-luban.deb is '23155a59b56ab520c279d491d9a16bc038a2e0926ece475674c0dd25ccfe299f'