Package Details: snapper-gui-git 0.1.r2.gc1b454a-1

Git Clone URL: https://aur.archlinux.org/snapper-gui-git.git (read-only, click to copy)
Package Base: snapper-gui-git
Description: Gui for snapper, a tool of managing snapshots of Btrfs subvolumes and LVM volumes
Upstream URL: https://github.com/ricardomv/snapper-gui
Licenses: GPL2
Conflicts: snapper-gui
Provides: snapper-gui
Submitter: maz-1
Maintainer: Saren
Last Packager: Saren
Votes: 43
Popularity: 0.97
First Submitted: 2015-10-26 14:12 (UTC)
Last Updated: 2016-12-14 16:42 (UTC)

Dependencies (10)

Required by (0)

Sources (1)

Latest Comments

sjnims commented on 2022-03-11 04:30 (UTC) (edited on 2022-03-11 17:45 (UTC) by sjnims)

Was able to make and install the package without problem, but then couldn't open any snapshots...made sure all permissions were set correctly...opened via terminal and saw the following error message whenever I hit "Open":

Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/snappergui/mainWindow.py", line 141, in on_open_snapshot_folder
    subprocess.Popen(['xdg-open', mountpoint])
  File "/usr/lib/python3.10/subprocess.py", line 966, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib/python3.10/subprocess.py", line 1842, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'xdg-open'

Installed xdg-utils package and no more issues. Maybe add that as a depends?

yochananmarqos commented on 2021-10-11 14:08 (UTC)

@SkorpEN: Those are already dependencies, what do you mean? Please unflag the package, it's not out date.

SkorpEN commented on 2021-10-11 13:35 (UTC)

python-dbus seems required other dependencies from https://github.com/ricardomv/snapper-gui python-gobject python-setuptools Rest seems not really needed in newer gtk.

ricardomv commented on 2016-12-06 12:58 (UTC)

please remove the .desktop file included in the package as the upstream project ships it's own.

ryuzy commented on 2016-06-11 08:03 (UTC)

@STREBLO you can use snapper from the official repo. snapper-git isn't necessary.

Saren commented on 2016-06-06 08:31 (UTC)

Any updates on the disown request?

coolmast commented on 2016-05-18 11:28 (UTC)

The version of the package does not match the installed version - leading to confusement

Mechanix commented on 2016-04-06 14:44 (UTC)

Doesn´t build: ==> Starting pkgver()... fatal: No names found, cannot describe anything. ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version: ==> ERROR: Makepkg was unable to build . ==> Restart building snapper-gui-git ? [y/N] ==> ----------------------------------------

johnramsden commented on 2016-03-17 22:20 (UTC)

Is snapper-git(AUR) required or can snapper from official repo be used instead?