Package Details: snd-usb-audio-lowlatency-dkms 4.19.9-1

Git Clone URL: https://aur.archlinux.org/snd-usb-audio-lowlatency-dkms.git (read-only)
Package Base: snd-usb-audio-lowlatency-dkms
Description: snd-usb-audio kernel module modified for low latency
Upstream URL: https://www.kernel.org/
Licenses: GPL2
Submitter: net147
Maintainer: net147
Last Packager: net147
Votes: 1
Popularity: 0.000468
First Submitted: 2018-08-11 13:51
Last Updated: 2018-12-15 11:54

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

funkmuscle commented on 2018-08-15 02:57

I did... or so I thought.. will try tomorrow and give you feedback!

net147 commented on 2018-08-14 22:02

@funkmuscle The output shows that you didn't remove src directory from previous build as I indicated previously. Please add -C argument to makepkg (capital C) so it doesn't try to apply patch to source files that were already patched.

funkmuscle commented on 2018-08-14 20:15

@net147 PKGBUILD: GNU nano 2.9.8 PKGBUILD

Maintainer: Jonathan Liu net147@gmail.com

pkgname=snd-usb-audio-lowlatency-dkms _basepkgname=snd-usb-audio-lowlatency _srcname=linux-4.9.84 pkgver=4.9 pkgrel=3 pkgdesc="snd-usb-audio kernel module modified for low latency" arch=('any') url="https://www.kernel.org/" license=('GPL2') depends=('dkms') source=( "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz" "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz" 'dkms.conf' 'lowlatency.patch' ) validpgpkeys=( 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman ) sha256sums=('6cb86c89762ce8b75a51045d12d00a88040d0b6ab9dfbcafabfe8b127caf1bb7' 'efb18504cd318e573d0635ea18a49d63d317f1d01f05e5b48c99b003877b8906' '69f325c3af92c4098c9d118b2eab7de76eba691677864f714697bce5f47005e2' 'c2b7784899d184b142c5969c1be17cc949f11f4e59fbe5b1a8ffe062a1c4a88f')

prepare() { cd "${_srcname}" patch -Np1 -i ../patch-${pkgver} patch -Np1 -i ../lowlatency.patch }

package() { cd "${_srcname}" install -Dm644 ../dkms.conf "${pkgdir}/usr/src/${_basepkgname}-${pkgver}/dkms.conf" sed -e "s/@PKGVER@/${pkgver}/" -i "${pkgdir}/usr/src/${_basepkgname}-${pkgver}/dkms.conf" cp -a sound/usb/* "${pkgdir}/usr/src/${_basepkgname}-${pkgver}/" }

vim:set ts=2 sw=2 et:

OUTPUT: https://pastebin.com/3EYaueQ7

net147 commented on 2018-08-14 03:03

@funkmuscle I didn't make any changes to arch/parisc/lib/fixup.S at all for r3. Can you provide the full PKGBUILD and output?

funkmuscle commented on 2018-08-14 02:49

yep.. built the first time after your help.. now trying to get r3 and that where I'm getting the error

net147 commented on 2018-08-14 02:31

@funkmuscle Works for me. Did you remove the pkg and src directories before building?

funkmuscle commented on 2018-08-14 00:56

getting this now: can't find file to patch at input line 217560 Perhaps you used the wrong -p or --strip option? The text leading up to this was:


|diff --git a/arch/parisc/lib/fixup.S b/arch/parisc/lib/fixup.S |index 1052b747e011..a5b72f22c7a6 100644 |--- a/arch/parisc/lib/fixup.S |+++ b/arch/parisc/lib/fixup.S


File to patch:

net147 commented on 2018-08-13 22:06

@funkmuscle It should still compile properly for patch releases (third number in the Linux version). So if there are no interesting changes in sound/usb then it isn't necessary to adjust for every patch release. I have updated the package to r3 to improve stability at the cost of around 8 additional samples of round trip latency at 48 KHz 24-bit.

funkmuscle commented on 2018-08-13 17:55

@net147 thanx bud, it worked. will this need to be adjusted as the kernel up grades?

net147 commented on 2018-08-13 12:10

@funkmuscle The PKGBUILD needs to be modified to match your kernel version:

  1. Replace 4.17.14 with 4.9.84

  2. Replace 4.17 with 4.9

  3. Run "updpkgsums"

  4. Run "makepkg -Cis"