Package Details: snooscraper-git 0.1-5

Git Clone URL: https://aur.archlinux.org/snooscraper.git (read-only)
Package Base: snooscraper
Description: A small program to scrape subreddits, reddit accounts and other sites, downloading content matching your criteria
Upstream URL: https://notabug.org/odg/snooscraper
Keywords: download downloader dump images imgur instagram pinterest reddit scrape scraper subreddit
Licenses: GPL
Conflicts: snooscraper
Provides: snooscraper
Submitter: odg
Maintainer: odg
Last Packager: odg
Votes: 0
Popularity: 0.000000
First Submitted: 2018-07-01 15:24
Last Updated: 2018-07-31 17:44

Latest Comments

hexadecagram commented on 2018-11-11 03:08

@jswagner: I am seeing similar errors.

The PKGBUILD should read arch=('any') not arch=('all') (which is what I see in 0.1-5). Otherwise, makepkg fails with "snooscraper-git is not available for the 'x86_64' architecture."

If I make the appropriate change in PKGBUILD, I get the following output, which is similar but not exactly the same. Note that the path says "aurman", which is what I normally use for AUR, but I get the same result (shown) by changing into the directory and running makepkg -scri.

$ makepkg -scri

. . .

==> Starting package()...
install: cannot create regular file '/home/hexadecagram/.cache/aurman/snooscraper/pkg/snooscraper-git/usr/bin/snooscraper': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...

jswagner commented on 2018-08-20 01:13

I'm getting this error despite your arch=('any') declaration. I can install other packages that use this same declaration in their PKGBUILD (I tested with 'aurvote', for example).

➜  makepkg -s
==> ERROR: snooscraper-git is not available for the 'x86_64' architecture.

Hacking the field to read x86_64, I run into other issues (your script's filename is snooscraper but makepkg is trying to create a folder in the same directory named snooscraper):

➜  snooscraper makepkg -s
==> Making package: snooscraper-git 0.1-5 (Sun 19 Aug 2018 06:10:22 PM PDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning snooscraper git repo...
fatal: destination path '/home/jason/build/snooscraper/snooscraper' already exists and is not an empty directory.
==> ERROR: Failure while downloading snooscraper git repo
    Aborting...