Package Details: snort 2.9.13-1

Git Clone URL: https://aur.archlinux.org/snort.git (read-only)
Package Base: snort
Description: A lightweight network intrusion detection system.
Upstream URL: http://www.snort.org
Licenses: GPL
Submitter: Snowman
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 58
Popularity: 0.001460
First Submitted: 2012-11-16 17:33
Last Updated: 2019-04-14 22:37

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

esclapion commented on 2014-01-28 18:58

Problem of checksum on emerging-rules : emerging.rules.tar.gz ... ÉCHEC

bidulock commented on 2014-01-17 20:04

There was a disable static daq flag? Doh!

robertfoster commented on 2014-01-17 18:45

added --disable-static-daq flag to configure script. now it builds

bidulock commented on 2014-01-17 06:15

You need to install libdaq-static from AUR: yaourt -S libdaq-static
You need to replace libdaq with libdaq-static to compile snort.
You can yaourt -S libdaq after compile and replace libdaq-static.

The problem is that the latest libdaq from community discards the static library that is needed to compile snort.

ncom511 commented on 2014-01-16 19:53

add makedepends=("libdaq-static") to PKGBUILD only shows upp as missing depend..

ncom511 commented on 2014-01-16 19:52

ERROR! daq_static library not found, go get it from
http://www.snort.org/.
==> ERROR: A failure occurred in build().
Aborting...

Still i have libdaq installed..??

community/libdaq 2.0.1-1 [installed]
Data Acquisition library for packet I/O.

?????????????

bidulock commented on 2014-01-04 14:55

add makedepends=('libdaq-static') to PKGBUILD

suawekk commented on 2013-09-19 05:43

Hello, package does not build - file emerging.rules.tar.gz has changed.

patch for PKGBUILD:

diff -u snort_fixed/PKGBUILD snort_orig/PKGBUILD
--- snort_fixed/PKGBUILD 2013-09-19 07:40:23.171141835 +0200
+++ snort_orig/PKGBUILD 2013-09-18 20:02:48.000000000 +0200
@@ -58,7 +58,7 @@
}

md5sums=('8629c6353d28cb9dad689fbf615151d2'
- 'a85f919903da7970abd0b38cbb77cb2d'
+ '203cc13fbecb4f81739a21bab749ab48'
'361b8b9e40b9af0164f6b3e3da2e8277'
'b4fb8a68490589cd34df93de7609bfac'
'0d898dfe906fe45ad8562c500c36facb')

cellardoor commented on 2013-09-13 15:14

This package needs the packages bison and flex added as dependencies.

I add to install them both separately before snort would compile.

einseenai commented on 2013-08-02 15:49

==> Validating source files with md5sums...
snort-2.9.5.3.tar.gz ... Passed
emerging.rules.tar.gz ... FAILED
snort ... Passed
snort.conf.d ... Passed
snort.service ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build snort.
==> Restart building snort ? [y/N]