Package Details: softethervpn-git v4.21.9613.beta-1

Git Clone URL: https://aur.archlinux.org/softethervpn-git.git (read-only)
Package Base: softethervpn-git
Description: Multi-protocol VPN software from University of Tsukuba
Upstream URL: http://www.softether.org/
Keywords: vpn
Licenses: GPL2
Submitter: mytbk
Maintainer: ava1ar
Last Packager: ava1ar
Votes: 25
Popularity: 0.442276
First Submitted: 2014-01-08 01:43
Last Updated: 2016-07-15 00:55

Required by (0)

Sources (5)

Latest Comments

aixki commented on 2017-01-18 16:23

I've managed to build it by creating a new patch that matches correctly the line numbers. I've also removed the configure_server_ssl_tls.patch which seems to break the build.

Here the new patch : https://gist.github.com/aixki/b5225c88d6a0f92767aa500614dedf25

ouyangjun commented on 2016-12-27 13:06

build error
patching file src/Mayaqua/Network.c
Hunk #1 FAILED at 12981.
1 out of 1 hunk FAILED -- saving rejects to file src/Mayaqua/Network.c.rej

jvybihal commented on 2016-11-21 08:55

/usr/lib/softethervpn/vpncmd/vpncmd: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

Looks like upstream issue. Readline was bumped up to 7.0-1.

Workaround: Symlinking seems to work.
libreadline.so.6 -> libreadline.so.7*
libreadline.so.6.0 -> libreadline.so.7.0*

ava1ar commented on 2016-03-20 19:13

Made some changes:
- cloning only master branch now, since cloning whole repository (> 1GB) is slow and not needed for build;
- updated dependencies (bash, openssl and zlib are added)
- some hardening added to the systemd units

ava1ar commented on 2016-03-20 17:51

Error is caused by using the SSLv3 by client in SoftEtherVPN (see i.e. https://github.com/SoftEtherVPN/SoftEtherVPN/issues/179). ArchLinux now builds openssl with SSLv3_method disabled, so SoftEtherVPN can't be build anymore. I added small patch to disable the SSLv3, so now TLSv1 is forced for client.

LizzyTrickster commented on 2016-03-15 11:00

When trying to build this I get the following error: https://pastebin.com/hCXXCQai on an x64 system

ava1ar commented on 2015-11-14 04:54

makedepends added

techmunk commented on 2015-11-14 04:00

Can this package please get a makedepends=('git') so that it can be cleanly built in a chroot, using for example clean-chroot-manager. Thanks!

ava1ar commented on 2015-06-03 03:34

Note: I changed the package file structure, so please be sure to migrate vpn_server.config after upgrade.

ava1ar commented on 2015-06-03 03:19

Adopted and updated. Mentioned issues partially addressed. Also I changed the versioning scheme. Please try and report any issues.

All comments