Package Details: softmaker-office-2016-bin 2016.765-2

Git Clone URL: https://aur.archlinux.org/softmaker-office-2016-bin.git (read-only, click to copy)
Package Base: softmaker-office-2016-bin
Description: Softmaker Office 2016, proprietary office suite; word processing, spreadsheets, presentations
Upstream URL: http://softmaker.com
Licenses: custom
Submitter: jdarch
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 14
Popularity: 0.000000
First Submitted: 2015-11-21 20:05
Last Updated: 2018-10-17 11:33

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

WorMzy commented on 2017-03-13 22:12

Thanks for letting me know. Remember to mark the package out of date if there's a new version.

killajoe commented on 2017-03-13 19:52

PKGBUILD for 765
http://pastebin.com/raw/qm0Bmw5M

killajoe commented on 2017-03-13 19:42

softmaker-office-2016-765.tgz is aviable!

gish commented on 2017-02-28 14:13

Please disown this package if you don't want to keep it updated.

treborz commented on 2016-12-12 19:51

I modified PKGBUILD to new version 763 here http://pastebin.com/WM2qx0qz

darzki commented on 2016-11-30 23:00

I can confirm that PKGBUILD provided by @ZeroBit works like a charm. Thank you!

ZeroBit commented on 2016-11-23 12:11

I modified PKGBUILD to new version 761 here http://pastebin.com/HLmd1UeY

a-bostaurus commented on 2016-05-22 02:07

Some days ago there has been a new version of this app. I would be very glad, if updating would be possible. Thanks a lot!

jdarch commented on 2016-03-03 20:37

mbroemme: thank you for your suggestion, I will add the lines in the next revision of the PKGBUILD, maybe you could write a short HOWTO about the 'SMOFFICE_GUI' environment variable for the benefit of its potential users?

mbroemme commented on 2016-02-17 16:38

SoftMaker Office has some undocumented GUI override options. They are needed for users who have simple window managers (e.g. Fluxbox or Openbox) where detection of GUI integration fails. The result is that fonts in menus are broken (no anti aliasing, crappy hinting, etc...). You can specify the following to textmaker16, presentations16 and planmaker16 as CLI option:

-gui:gnome
-gui:kde

It would be great if you could change the scripts in '/usr/bin' and add the following:

# Check GUI mode override.
[ -z "$SMOFFICE_GUI" ] && /opt/smoffice2016/textmaker "$@" || /opt/smoffice2016/textmaker "$SMOFFICE_GUI" "$@"

This is just the example for '/usr/bin/textmaker16'. In this case it works when you start it from shell or via MIME integration from inside other applications.

If SMOFFICE_GUI is empty, auto detection is used (preferred under GNOME or KDE)
If SMOFFICE_GUI is non-empty, GUI detection is overridden (required under Fluxbox or Openbox).