Package Details: sogo 4.0.8-1

Git Clone URL: https://aur.archlinux.org/sogo.git (read-only)
Package Base: sogo
Description: groupware server built around OpenGroupware.org (OGo) and the SOPE application server
Upstream URL: http://www.sogo.nu/
Licenses: GPL
Replaces: sogo2
Submitter: DJ_L
Maintainer: deons
Last Packager: deons
Votes: 7
Popularity: 0.001084
First Submitted: 2016-05-05 01:05
Last Updated: 2019-08-03 06:06

Dependencies (16)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

DJ_L commented on 2018-10-08 16:27

FYI: https://sogo.nu/bugs/view.php?id=4566

DJ_L commented on 2018-10-08 16:25

I too am seeing the issue now. OpenSSL-1.1.1 is the cause. I did not have time to address this morning, but I'll try and update again this evening and see what I can do to track it down. Assuming it's not a dependent library someplace, a cursory glance suggests that we need only to add a conditional in SOGo for SSL version and then use OPENSSL_init_ssl() rather than SSL_load_error_strings(). Again, I didn't really have time to look at it and IANAP, so I may be over simplifying. SOPE uses GNUTLS by default, so no worries there, but it should fixed anyway for the off chance that GNUTLS is not available as well (both should be done upstream, but will have to be done locally in the interim assuming that I'm even correct, of course).

deons commented on 2018-10-05 07:44

Hi DJ_L and chetwisniewski,

I am using openssl-1.1.1-1, here is the error messages that I am getting.

sogod[29991]: Error (objc-load):/usr/lib/GNUstep/SOGo/MailPartViewers.SOGo/MailPartViewers: undefined symbol: SSL_load_error_strings

sogod[29991]: Oct 05 08:16:29 sogod [29991]: [so-product-registry] could not load product: MailPartViewers

sogod[29991]: Error (objc-load):/usr/lib/GNUstep/SOGo/MailerUI.SOGo/MailerUI: undefined symbol: __objc_class_name_UIxMailSizeFormatter

sogod[29991]: Oct 05 08:16:29 sogod [29991]: [so-product-registry] could not load product: MailerUI

It does appear that it is something with ssl that is causing the issue but I cant find what it is.

DJ_L commented on 2018-09-28 03:22

OpenSSL-1.1.1?

chetwisniewski commented on 2018-09-27 19:38

I am getting the same error. It appears related to SSL in some way:

sogod[1194]: Error (objc-load):/usr/lib/GNUstep/SOGo/MailPartViewers.SOGo/MailPartViewers: undefined symbol: SSL_load_error_strings

Also using LDAP auth, but I think that is a red herring.

Downgrading to 4.0.1 fixed me as well, but I also downgraded sope out of caution.

DJ_L commented on 2018-09-02 06:06

Also, if still happening, what happens with version mismatch? SOPE-4.0.2 with SOGo-4.0.1? Another, any customizations for WebUI?

DJ_L commented on 2018-09-01 15:31

Yes, https://wiki.archlinux.org/index.php/SOGo#Active_Directory_4 Is it working for you now?

deons commented on 2018-09-01 09:12

I have updated package to 4.0.2

DJ_L that report that you found is the exact problem that I am having, thanks for sharing. Are you using LDAP for your authentication?

DJ_L commented on 2018-09-01 04:45

FYI, the most recent instance I can find is this: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906271

DJ_L commented on 2018-09-01 04:32

I built with existing patches, updated only version, release, and sha256sums. I am not seeing the problem. I had not been using the web GUI and hadn't yet run the update script /usr/lib/sogo/scripts/sql-update-3.2.10_to_4.0.0-mysql.sh, so I was getting the scrolling quick_update for the contacts list. Ran that script, and all was well with contacts view. My environment is per the current Arch wiki article, with Samba, MariaDB, Postfix, Dovecot, and Apache for the web server.

Where does the error occur, on the login screen, immediately after (MailerUI), or somewhere else?

Try and see if anything interesting in say 'journalctl -r -u sogo | head -n 100 | grep "ERROR" '