Package Details: solunar2-git r3.ace69a7-1

Git Clone URL: https://aur.archlinux.org/solunar2-git.git (read-only, click to copy)
Package Base: solunar2-git
Description: Calculate sun and moon, rise and set times
Upstream URL: https://github.com/kevinboone/solunar2
Keywords: calculator date moon solar sun time
Licenses: GPL3
Conflicts: solunar, solunar2
Provides: solunar2
Submitter: caltlgin
Maintainer: None
Last Packager: caltlgin
Votes: 3
Popularity: 0.000006
First Submitted: 2020-06-28 22:49 (UTC)
Last Updated: 2020-07-01 05:09 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

dreieck commented on 2021-02-13 20:10 (UTC) (edited on 2021-02-13 20:12 (UTC) by dreieck)

$pkgver calculation is wrong.

solunar has it's own notion of a package version:

solunar --version:

solunar: solunar version 2.0a
[...]

This should be the leading characters of $pkgver (It can be extracted from "${srcdir}/solunar2/Makefile": grep -E '^[[:space:]]*VERSION[[:space:]]*:+=' "${srcdir}/solunar2/Makefile" | awk '{print $3}').

Thanks for maintaining (whoever will take ownership).

dreieck commented on 2021-02-13 20:06 (UTC) (edited on 2021-02-13 20:06 (UTC) by dreieck)

Dear possible future Maintainer:

Can you add =${pkgver} to the provides=("solunar2")-entry?

Thanks for maintaining!

m040601 commented on 2021-02-06 21:10 (UTC) (edited on 2021-02-07 15:33 (UTC) by m040601)

This PKGBUILD needs an update, or, better yet, it should be removed from the AUR.

The "url" doesnt exist anymore, http://kevinboone.net/README_solunar.html

It should be updated to

url='https://github.com/kevinboone/solunar_cmdline'

And more important, this is what the developer has to say:

RETIRED!

(..)
Please note that this utility is obsolete, and I won't be developing it any    further, or fixing any more bugs. I've started an entirely new implementation, which is avilable here:

https://github.com/kevinboone/solunar2

(...)

And we already have in fact, https://aur.archlinux.org/pkgbase/solunar2-git/

Although it seems to be orphan.

willspoke commented on 2018-04-12 14:31 (UTC)

Thank you for the workaround. All is fine now.

dreieck commented on 2018-04-10 12:17 (UTC)

@willspoke: Thanks for reporting.

Seems to be an error upstream: Execution permission not set.

I added a workaround to the PKGBUILD, should build now.

willspoke commented on 2018-04-05 19:27 (UTC)

I am receiving the following error message when trying to install:

Building 'solunar-git', version '0.1.3b.d20180131.r02956b2'. >>>

./parse_zoneinfo.pl make: execvp: ./parse_zoneinfo.pl: Permission denied make: *** [Makefile:25: cityinfo.h] Error 127 ==> ERROR: A failure occurred in build(). Aborting...