Package Details: sourcery-codebench-arm-none-eabi 2014.05-1

Git Clone URL: https://aur.archlinux.org/sourcery-codebench-arm-none-eabi.git (read-only)
Package Base: sourcery-codebench-arm-none-eabi
Description: Sourcery CodeBench Lite for ARM NONE EABI
Upstream URL: http://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/
Licenses: custom
Submitter: gifts
Maintainer: dmitry3l
Last Packager: dmitry3l
Votes: 26
Popularity: 0.000000
First Submitted: 2014-02-17 21:38
Last Updated: 2015-08-16 11:00

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

anatolik commented on 2014-02-15 13:56

The name of the package is too confusing IMO. It should be renamed to something like 'sourcery-codebench-lite' or 'sourcery-codebench-lite-bin'

iorbitearth commented on 2014-02-05 00:01

After the most recent update, linking executables causes a fatal error:

Linking C executable ../../bin/project.elf
arm-none-eabi-gcc: fatal error: selected multilib 'thumb2' not installed
compilation terminated.

This error was mentioned previously in the arm-none-eabi-gcc AUR package thread, but the user got around the problem by installing this package. Building, linking, and debugging with this package worked great before the 2014-02-01 10:58 update.

alex.novitsky commented on 2014-01-31 07:30

Sourcery CodeBench Lite 2013.11-24 release was made on 4 December 2013.
GNU Binary Utilities (2.23.52-sg++)
GNU C & C++ Compilers (4.8.1-sg++)
GNU Debugger (7.6.50.20130726-cvs-sg++)
Newlib C Library (2.0.0-sg++)

gifts commented on 2013-11-19 22:16

71GA, I don't exactly understand when "process hangs". When you use original PKGBUILD or not? Pierrec link leads to previous version of arm-none-eabi, and generally, you shouldn't use it (if you want you should also fix md5sum in PKGBUILD). And on original PKGBUILD I can't reproduce issue with hanging on freshly installed Archlinux.

71GA commented on 2013-11-18 05:50

When iI started to build with "makepkg -si" the process just hangs. This is because in PKGBUILD we need to change sources to the destination provided by @pierrec. But when i do this i get an error during the "makepkg -si" saying:

==> Validating source files with md5sums...
arm-2012.09-63-arm-none-eabi-i686-pc-linux-gnu.tar.bz2 ... FAILED
==> ERROR: One or more files did not pass the validity check!

71GA commented on 2013-11-18 05:46

When iI started to build with "makepkg -si" the process just hangs. This is because in PKGBUILD we need to change sources to the destination provided by @pierrec. Maintainer please fix that :)

71GA commented on 2013-11-18 05:30

When starting makepkg -si the process just hangs.

gifts commented on 2013-07-15 12:10

Updated. Thx kalenz.

Please, mark package as Out-Of-Date, if you see new version avaliable, I will try to update as fast as I can.

kalenz commented on 2013-07-15 09:39

PKGBUILD updated to 2013.05-23: http://pastie.org/8142220

gifts commented on 2013-03-07 04:17

New version 2012.09-63. Thanks to pierrec