Package Details: sozi-extras_media 18.01-2

Git Clone URL: https://aur.archlinux.org/sozi.git (read-only)
Package Base: sozi
Description: An Inkscape extension for adding audio/video elements
Upstream URL: http://sozi.baierouge.fr/
Licenses: custom:MPL2.0
Submitter: linkmauve
Maintainer: sbmomeni
Last Packager: sbmomeni
Votes: 73
Popularity: 1.024702
First Submitted: 2010-10-28 11:53
Last Updated: 2018-02-10 12:01

Dependencies (7)

Required by (1)

Sources (616)

Latest Comments

sbmomeni commented on 2018-02-14 16:30

@lylambda The error message is saying "Aucun espace disponible sur le périphérique" which means "No available space on the device." You should either free some space on that device or change the build path to another device.

lylambda commented on 2018-02-12 18:50

Thanks for your response sbmomeni.

I test your command : [lylambda@nobody ~]$ semver -r "^6.14.0" "6.24.1" "5.4.2" node: error while loading shared libraries: libicui18n.so.57: cannot open shared object file: No such file or directory

So I install icu.57 with aur (my system have icu.60). Then : [lylambda@nobody ~]$ semver -r "^6.14.0" "6.24.1" "5.4.2" 6.24.1

Great ! I try to install sozy and : ==> Lancement de build()... Installing babel-preset-es2015-6.24.1 ... dep babel-preset-es2015-6.24.1 -> babel-plugin-check-es2015-constants-6.22.0 ... [...] cp: impossible de créer le lien direct 'node_modules/babel-plugin-transform-es2015-modules-umd/.is-completely-installed' vers '/tmp/pamac-build-lylambda/sozi/src/build/babel-plugin-transform-es2015-modules-umd-6.24.1/.is-completely-installed': Aucun espace disponible sur le périphérique ==> ERREUR : Une erreur s’est produite dans build(). Abandon...

More here : https://framabin.org/?5e3f4f461e58c84d#fE26l/s62+blz4XtgAwfnGwMjQhgM1uaGpQFt/bLFEE=

That's not the same error than before but... can you help me ?

sbmomeni commented on 2018-02-11 19:23

@lylambda The "semver" program is used for detecting package versions. In ArchLinux, "semver" depends on "nodejs" which depends on "icu" which provides the "libicui18n.so" file which is missing in your system. Search for "/usr/lib/libicui18n.so" file and install the package which provides it in Manjaro OS.

You can test your system by running

semver -r "^6.14.0" "6.24.1" "5.4.2"

which should output

6.24.1

lylambda commented on 2018-02-11 11:51

<hr>

[...] node: error while loading shared libraries: libicui18n.so.57: cannot open shared object file: No such file or directory Installing babel-preset-es2015- ... bsdtar: Error opening archive: Failed to open '/tmp/pamac-build-lylambda/sozi/src/babel-preset-es2015-.tgz' ==> ERREUR : Une erreur s’est produite dans build(). Abandon...

<hr>

Something didn't works for me :( (OS = Manjaro) What can I do ?

rplanchuelo commented on 2018-02-10 14:51

@sbmomeni: It's OK. Thanks.

sbmomeni commented on 2018-02-10 12:03

@rplanchuelo: fixed.

rplanchuelo commented on 2018-02-10 11:33

Maybe it isn't neccesary. From https://www.npmjs.com/package/acorn5-object-spread:

acorn5-object-spread Spread and rest properties support in acorn 5

NPM version

Since spread and rest properties are part of ECMAScript 2018, acorn now supports them out of the box. Just make sure that you use acorn >= 5.4.1 and set ecmaVersion >= 9. This plugin is deprecated.

rplanchuelo commented on 2018-02-10 11:29

I cann't update because there is a error with acorn5-object-spread-5.0.1.tgz:

% Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 3 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 2 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 1 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 curl: (22) The requested URL returned error: 500 ==> ERROR: Hubo fallos durante la descarga de https://registry.npmjs.org/@browserify%2facorn5-object-spread/-/acorn5-object-spread-5.0.1.tgz

macxcool commented on 2017-12-12 11:32

@sbmomeni Thanks for the explanation. I appreciate it. I may try a bin package, just for the fun of it ;-)

sbmomeni commented on 2017-12-12 10:51

@macxcool Now that our installation script is merged in upstream repo, a "-bin" package can use that approach. But it does not necessarily work as the ArchLinux continues updating. For example, we had to use a different electron version previously.

All comments