Package Details: spacedrive-bin 1:0.2.2-1

Git Clone URL: https://aur.archlinux.org/spacedrive-bin.git (read-only, click to copy)
Package Base: spacedrive-bin
Description: A file manager from the future.
Upstream URL: https://spacedrive.com
Keywords: file manager, rust
Licenses: AGPL3
Conflicts: spacedrive
Provides: spacedrive
Submitter: 0xnim
Maintainer: xrtxn
Last Packager: xrtxn
Votes: 4
Popularity: 0.037905
First Submitted: 2023-07-11 08:22 (UTC)
Last Updated: 2024-01-29 20:01 (UTC)

Pinned Comments

xrtxn commented on 2024-03-08 15:35 (UTC)

I currently can't update this package because onnxruntime 1.17.1 is needed but it is not yet available from the repositories.

Latest Comments

1 2 Next › Last »

xrtxn commented on 2024-03-08 15:35 (UTC)

I currently can't update this package because onnxruntime 1.17.1 is needed but it is not yet available from the repositories.

negativems commented on 2023-11-01 12:48 (UTC)

I have the segmentation fault error too

$ spacedrive
2023-11-01T12:43:57.524379Z  INFO sd_core: Starting core with data directory '/home/mbh/.local/share/spacedrive'
2023-11-01T12:43:57.525578Z  INFO sd_core::p2p::p2p_manager: Node '12D3KooWNrCww3oL9S2BMdyJDRY8PWDWLK7LY6KDcukiySHBMKbf' is now online listening at addresses: {}
2023-11-01T12:43:57.606459Z  INFO sd_core: Spacedrive online.
2023-11-01T12:43:57.606643Z  INFO sd_desktop::tauri_plugins: Internal server listening on: http://127.0.0.1:33469
[1]    119723 segmentation fault (core dumped)  spacedrive

TurtleRuss commented on 2023-10-17 06:02 (UTC)

after install the app,it fails to start and throw Segmentation Fault

$ spacedrive 
2023-10-17T06:02:06.742539Z  INFO sd_core: Starting core with data directory '/home/russ/.local/share/spacedrive'
2023-10-17T06:02:06.744660Z  INFO sd_core::p2p::p2p_manager: Node '12D3KooWFXLnGMQcmFExDxqJ19CUM4eFrk3qaqc3NyMimcTCdsti' is now online listening at addresses: {}
2023-10-17T06:02:06.783666Z  INFO sd_core: Spacedrive online.
2023-10-17T06:02:06.783836Z  INFO sd_desktop::tauri_plugins: Internal server listening on: http://127.0.0.1:40135
[1]    293206 segmentation fault (core dumped)  spacedrive

FabioLolix commented on 2023-10-13 09:52 (UTC)

@jogai I have tested before upload, it need that depends

$ spacedrive
spacedrive: error while loading shared libraries: libavutil.so.56: cannot open shared object file: No such file or directory
[fabio@archlinux spacedrive-dev-bin]$ pkgfile libavutil.so.56
extra/ffmpeg4.4

xrtxn commented on 2023-10-13 09:49 (UTC) (edited on 2023-10-13 09:52 (UTC) by xrtxn)

Hey jogai, I checked, but using the main dependencies doesn't work. It shouldn't be a problem because the dependencies don't conflict.

jogai commented on 2023-10-13 05:52 (UTC)

And I think the ffmpeg dependency can be the regular one instead of ffmeg-4.4, and maybe you can make webkit2gtk optional for the people that have webkit2gtk-4.1 installed?

FabioLolix commented on 2023-10-12 14:20 (UTC)

  • For the third time, re-upload as spacedrive-dev-bin
  • your 4 line of tar,install,cp can be replaced with 1 line of bsdtar, see the link I posted

xrtxn commented on 2023-10-12 13:46 (UTC)

Hey FabioLolix, thank you for the contribution, added the required dependencies, and removed the first line.

aur1456 commented on 2023-10-12 13:18 (UTC)

spacedrive is not startable .

EndavorOS with KDE

FabioLolix commented on 2023-10-11 21:27 (UTC)

Hello xrtxn,

  • please re-upload as spacedrive-dev-bin since v0.1.0 is not a stable release
  • libheif is not needed as dependency, it is included in the package (despite what namcap says), real depends are missing
  • ar x "Spacedrive-linux-x86_64.deb" is not needed because a first round of decompression is made by default with bsdtar
  • your 5 line of ar,tar,install,cp can be replaced with 1 line of bsdtar, see the link I posted