Package Details: sparse 0.5.0-2

Git Clone URL: (read-only)
Package Base: sparse
Description: Semantic parser for C
Upstream URL:
Licenses: custom:OSL
Submitter: None
Maintainer: osandov
Last Packager: osandov
Votes: 20
Popularity: 0.503225
First Submitted: 2007-07-11 04:16
Last Updated: 2015-07-03 07:41

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

osandov commented on 2015-03-31 19:09

I've adopted the package and added the required patch.

norg commented on 2015-01-23 11:24

Since this is a necessary kernelpart for developing i would recommend sparse being added into the main repo.

anish commented on 2015-01-23 00:42

Please update with the patch mentioned by IooNag, it's been quite (4+ months) that this has been broken

IooNag commented on 2014-10-17 19:42

I confirm skroll's patch fixes the build. It has also been applied upstream: . Could you please add this patch to the package?

skroll commented on 2014-10-10 16:08

Build fails when llvm is installed due to link library issues.

I wrote a patch that fixed the build (you just need to add it to the PKGBUILD and have it run it in prepare())

benjo commented on 2013-08-06 19:47

Sorry for the long delay

Anonymous comment on 2013-05-08 08:30

Not sure how makepkg works, but I think there is a problem in PKGBUILD :
make PREFIX=/usr DESTDIR=$startdir/pkg install
should be :
make PREFIX=/usr DESTDIR=$startdir/pkg/$pkgname install

Idem for following lines installing LICENSE file.

Without this, makepkg gives me an empty package.

t-8ch commented on 2011-08-26 23:34

Seems like 0.4.3 has been out for some time