Package Details: sphinxbase 5prealpha-6

Git Clone URL: (read-only)
Package Base: sphinxbase
Description: Common library for sphinx speech recognition.
Upstream URL:
Keywords: recognition speech
Licenses: BSD
Submitter: None
Maintainer: marcs
Last Packager: marcs
Votes: 73
Popularity: 2.143584
First Submitted: 2008-08-08 21:35
Last Updated: 2016-09-29 17:12

Pinned Comments

marcs commented on 2016-09-29 17:27

Update to release 6, seems that the timing-fix patch is no longer necessary.

Latest Comments

marcs commented on 2016-09-29 17:27

Update to release 6, seems that the timing-fix patch is no longer necessary.

marcs commented on 2016-06-01 10:04

Hi martchus,

Thank you for your contribution, appreciate it very much.
I agree with your corrections, I left the comment for libsamplerate, doesn't mean that is strictly necessary for building, but for optional features.

I also added the patch.

Martchus commented on 2016-05-28 12:14

Please have a look at:

It now also contains another patch by maxrd2 which would be required for the subtitlecomposer package.

Since you didn't respond to my last comment 18 days ago I'll submit a request.

Martchus commented on 2016-05-10 15:58

I'm not able without python and python2 when building in clean chroot. However, it builds without libsamplerate.

Here is an updated version (also with current checksums):

marcs commented on 2016-03-04 14:28

updated md5 for new version.

dvv854 commented on 2016-03-04 14:17

md5 ea27ea80bc14b96ad0a55fd5c94025d5 for the snapshot

marcs commented on 2016-02-02 19:48

md5 sum updated

underdoeg commented on 2016-02-01 09:45

updated md5 sum for sphinxbase-5prealpha.tar.gz is a6e1e258d1124f59fa8c8a53fc9313f5

marcs commented on 2015-12-08 14:32

Added reconfiguration to automake 1.15 on prepare phase, should work now.

Anonymous comment on 2015-12-08 08:22

Package won't build on my installation:

CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /tmp/packerbuild-1000/sphinxbase/sphinxbase/src/sphinxbase-5prealpha-py2/missing aclocal-1.13 -I m4
/tmp/packerbuild-1000/sphinxbase/sphinxbase/src/sphinxbase-5prealpha-py2/missing: line 81: aclocal-1.13: command not found
WARNING: 'aclocal-1.13' is missing on your system.
You should only need it if you modified 'acinclude.m4' or
'' or m4 files included by ''.
The 'aclocal' program is part of the GNU Automake package:
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
Makefile:425: recipe for target 'aclocal.m4' failed
make: *** [aclocal.m4] Error 127
==> ERROR: A failure occurred in build().
The build failed.

/usr/bin/aclocal is aclocal-1.15

marcs commented on 2013-09-15 14:29

I've included cython2 in the depends array.

Thank you for the info.

Anthony25 commented on 2013-09-15 14:00

Sources for my previous post :

Anthony25 commented on 2013-09-15 13:59

In fact cython should be a depends, because if you don't have it, some source files are not recompiled and you get an error when you try to import sphinxbase in python.
Thank you for the PKGBUILD update, it's working now with cython installed !

marcs commented on 2013-09-15 13:13

Ok now it should work if cython or cython2 is installed or both.

marcs commented on 2013-09-15 12:30

The problem appears only if i'm installing from yaourt. Using makepkg everything works fine. Thank you Anthony for spotting the problem. I'll try to fix it.

marcs commented on 2013-09-15 11:59

Added bison the the makedepends array.
I've tried to install cython and/or cython2 but i didn't have any compilation errors.

electron commented on 2013-08-07 22:25

bison should be in the build dependencies since it is required by the configure script.

Anthony25 commented on 2013-08-04 14:53

If you have Cython, during the compilation it will recreate some ".c" files (using Cython), and you will get an error.

The Makefile has to be modified to use Cython2 (and not cython), or you just have to remove the cython package on your system (but you will get an error if you import the sphinxbase module in python).

Anthony25 commented on 2013-07-25 19:44

In a clean-chroot the compilation passed without any problem.

On one computer I didn't have to build it in a clean-chroot, but on my laptop I get an error if I don't.

marcs commented on 2013-07-03 17:17

I'll try to compile on clean installation and see if some dependencies are not contained in the PKGBUILD.

cookiecaper commented on 2013-07-03 03:30

Same breakage here.

hseara commented on 2013-06-22 13:53

Hi, I have the same problem!!

make[1]: Entering directory `/tmp/yaourt-tmp-test_kde/aur-sphinxbase/src/sphinxbase-0.8/python'
cython -o sphinxbase.c sphinxbase.pyx

Error compiling Cython file:
self.hc = huff_code_build_str(symbols, frequencies, nsym)

def read(self, infile):
if not isinstance(infile, file):

sphinxbase.pyx:537:38: undeclared name not builtin: file
make[1]: *** [sphinxbase.c] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-test_kde/aur-sphinxbase/src/sphinxbase-0.8/python'
make: *** [all-recursive] Error 1

Nothing speciall in my python installation.

marcs commented on 2013-06-15 07:41

I can build the package.

This is weird, you should have the python keyword "file":

I suppose is a problem related to your python2 installation.

Anonymous comment on 2013-06-10 20:55

cannot build with current setup. Error is:
def read(self, infile):
if not isinstance(infile, file):
sphinxbase.pyx:537:38: undeclared name not builtin: file

marcs commented on 2013-01-10 22:28

Updated to .8 version.

td123 commented on 2011-05-19 13:13

removed. It seemed upstream updated the 0.7 source file silently

Anonymous comment on 2011-05-19 10:27

The cythonfix seems to have been applied to the actual source. Please update your package PKGBUILD.

td123 commented on 2010-11-26 03:14

please update the pythondir and there are errors during the build

td123 commented on 2010-06-14 18:24

Fixed your PKGBUILD, new one can be found here: