Package Details: spice-vdagent 0.17.0-1

Git Clone URL: https://aur.archlinux.org/spice-vdagent.git (read-only)
Package Base: spice-vdagent
Description: Spice agent xorg client that enables copy and paste between client and X-session and more
Upstream URL: http://www.spice-space.org/
Licenses: GPL
Submitter: mutantmonkey
Maintainer: mutantmonkey
Last Packager: mutantmonkey
Votes: 24
Popularity: 0.665358
First Submitted: 2012-08-28 02:58
Last Updated: 2016-06-18 23:21

Latest Comments

danielkza commented on 2016-04-20 08:01

The systemd service won't work straight after installation due to the missing `/var/run/spice-vdagentd` directory. It should be created by `systemd-tmpfiles` as configured by `/usr/lib/tmpfiles.d/spice-vdagentd.conf`, but that won't happen until the next reboot or `systemd-tmpfiles --create spice-vdagentd.conf` is run. It could be a good idea to do so in a post install script.

testtube commented on 2016-03-06 22:07

now works. (Last Updated: 2016-03-06 20:50)

testtube commented on 2016-03-06 18:15

0.16.0-4:
==> Validating source files with sha256sums...
spice-vdagent-0.16.0.tar.bz2 ... Passed
spice-vdagent-0.16.0.tar.bz2.sign ... Skipped
spice-vdagentd.conf.d ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build spice-vdagent.

pmattern commented on 2016-03-03 21:35

spice-vdagentd.service is expecting an environment variable SPICE_VDAGENTD_EXTRA_ARGS but file spice-vdagentd.conf[.d] is providing SPICE_VDAGENTD_ARGS and hence doesn't work as expected.

mutantmonkey commented on 2016-02-20 07:35

Looks like libsystemd 229 no longer provides a separate libsystemd-login.so. This was deprecated with systemd 209, released two years ago, so I cannot explain why upstream continues to use it. I've updated the package with a patch to get it building again.

Deprecation announcement: https://lists.freedesktop.org/archives/systemd-devel/2014-February/017146.html
Upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=94209

zigarrre commented on 2016-02-19 17:38

Build fails with:

[...]
checking for LIBSYSTEMD_LOGIN... no
configure: error: libsystemd-login support explicitly requested, but some required packages are not available

I have all listed dependencies installed. Is anybody else having the same problem?

mutantmonkey commented on 2015-12-19 19:47

Downloads from spice-space.org seem to still be working for me. OlafLostViking, are you still having this issue?

OlafLostViking commented on 2015-12-18 11:12

spice-space.org seems to have removed their downloads. Using github with the PKGBUILD on the pastebin[1] works, though.

[1] http://pastebin.archlinux.fr/1801680

Lekensteyn commented on 2015-08-05 20:58

This is missing a build-time dependency on alsa-lib.

Please apply these changes:
* add to depends: 'alsa-lib' 'glib2'
* move from depends to makedepends: 'spice-protocol>=0.12.8'
* Replace "....bz2" by "....bz2"{,.sign}
* Add 'SKIP' between the two sha256sums
* add validpgpkeys=('94A9F75661F77A6168649B23A9D8C21429AC6C82')
* add backup=('etc/conf.d/spice-vdagentd.conf')
* (bump pkgrel to 2)

See https://github.com/Lekensteyn/aur/commit/7f71120a

(I think that only libsystemd is needed as makedepends, but it works now.)

mutantmonkey commented on 2015-03-14 02:32

Hi izmntuk,
Thanks for the feedback, updated.

All comments