Package Details: spice-xpi 2.8.90-11

Git Clone URL: https://aur.archlinux.org/spice-xpi.git (read-only)
Package Base: spice-xpi
Description: XPI client for interacting with SPICE servers. This package contains a mozilla browser client for interacting with SPICE servers.
Upstream URL: http://spice-space.com
Licenses: GPL
Conflicts: browser-plugin-spice
Provides: browser-plugin-spice
Submitter: None
Maintainer: k0ste
Last Packager: k0ste
Votes: 9
Popularity: 0.256191
First Submitted: 2010-10-20 19:23
Last Updated: 2016-02-02 05:35

Latest Comments

digger commented on 2014-12-08 19:37

I dont get the options that I normally see in a Redhat client. e.g. right click the title bar and then have USB options as in the image in the following links:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization_for_Desktops/2.2/html/User_Guide/User_Guide-Configuring_USB_policy_on_a_virtual_machine.html

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5-Beta/html/User_Guide/Using_USB_Devices_on_Virtual_Machines_-_Legacy_Mode.html

My log also has the following which I suspect is the cause?

Dec 08 08:59:57 linux-rocks firefox.desktop[1378]: (plugin-container:1473): SpiceXPI-CRITICAL **: controller connect: No such file or directory
Dec 08 08:59:57 linux-rocks firefox.desktop[1378]: SpiceXPI-Message: failed to run spice-xpi-client, running spicec instead

ilikenwf commented on 2014-08-19 04:20

Need to get a TU to let you take ownership of spice-xpi

k0ste commented on 2014-07-20 12:26

Try now.

Anthony25 commented on 2014-07-20 11:25

Hello,
The source address rejects a 404 error.

jeffshere commented on 2014-05-09 17:32

Broken on 3.14.2-1-ARCH x86_64:

In file included from nsScriptablePeer.cpp:54:0:
/usr/include/xulrunner-29.0/nsError.h:186:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(((nsresult)0) < ((nsresult)-1),
^
/usr/include/xulrunner-29.0/nsError.h:188:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(sizeof(nsresult) == sizeof(uint32_t),
^
Makefile:509: recipe for target 'libnsISpicec_la-nsScriptablePeer.lo' failed

pi3r1k commented on 2012-09-28 09:31

You need to add patch for python2 to the pkg:
patch: **** Can't open patch file ../../python2-fixes.patch : No such file or directory

aderumier commented on 2012-08-14 13:29

Hi, I have updated spice-xpi to 2.7.

Anonymous comment on 2011-10-12 07:49

please upgrade

Anonymous comment on 2011-06-07 13:27

Hey, there is a newer version of the spice-xpi (2.5), available at http://www.spice-space.org/download.html