Package Details: spl-linux-headers 0.7.12_4.19.1.arch1.1-1

Git Clone URL: https://aur.archlinux.org/spl-linux.git (read-only)
Package Base: spl-linux
Description: Solaris Porting Layer kernel headers.
Upstream URL: http://zfsonlinux.org/
Licenses: GPL
Conflicts: spl-dkms, spl-dkms-git, spl-headers
Provides: spl-headers
Submitter: demizer
Maintainer: minextu (archzfs-bot)
Last Packager: archzfs-bot
Votes: 93
Popularity: 0.480740
First Submitted: 2016-04-21 08:34
Last Updated: 2018-11-14 02:26

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

1 2 3 4 5 Next › Last »

thunderforce commented on 2018-09-19 23:43

thank @minextu! I haven't done installs without dependency check, but will definitely keep that in mind next time :) for now going the lazy route and adding the archzfs repo

minextu commented on 2018-09-19 22:42

@thunderforce You need to install zfs/spl-utils-common without dependency check first (pacman -Ud zfs-utils-common-7.11... spl-utils-common-7.11...) and then compile + install zfs/spl-linux.

Even easier would be to use the archzfs repo (http://archzfs.com/#using-the-archzfs-repository)

thunderforce commented on 2018-09-19 22:25

Havent' done this in a while.... when I try pacman -Syu, I get :: installing linux (4.18.8.arch1-1) breaks dependency 'linux=4.18.5.arch1-1' required by spl-linux :: installing linux (4.18.8.arch1-1) breaks dependency 'linux=4.18.5.arch1-1' required by spl-linux-headers :: installing linux (4.18.8.arch1-1) breaks dependency 'linux=4.18.5.arch1-1' required by zfs-linux

I've tried updating manually, but I can't figure how to update to spl-utils-common=0.7.9 because of :: installing spl-utils-common (0.7.11-1) breaks dependency 'spl-utils-common=0.7.9' required by spl-linux :: installing spl-utils-common (0.7.11-1) breaks dependency 'spl-utils-common=0.7.9' required by spl-linux-headers

is there an best order to update packages that I'm missing?

ShaunPC commented on 2017-08-21 19:57

It is pointed to 4.12.8-1 when the title and current linux package are 4.12.8-2. Can you correct this please?

demizer commented on 2017-07-28 10:16

New packages with OpenZFS 0.7.0 support have been pushed to the archzfs repo for linux and linux-lts kernels

However, the PKGBUILDs for spl-linux and zfs-linux have been changed to split packages and I cannot upload the updated PKGBUILDS to AUR until the (spl|zfs)-${KERNEL}-headers repos are removed by the admins.

demizer commented on 2017-06-15 01:06

A new stable release of OpenZFS version 0.6.5.10 is out, but it does not address the gcc 7.1.1 build errors. These packages will remain out-of-date until a stable release of OpenZFS is made fixing the gcc build issues. That might take some time. Until then, if anyone really needs to update their kernel, use the archzfs-git packages.

demizer commented on 2017-01-29 21:57

This package cannot be updated for kernel 4.9 until the ZFS on Linux project makes a new stable release that supports kernel 4.9.

See https://github.com/archzfs/archzfs/issues/98#issuecomment-275831181

breul99 commented on 2016-11-18 02:07

Does not currently build
configure: error:
*** Please make sure the kernel devel package for your distribution
*** is installed and then try again. If that fails, you can specify the
*** location of the kernel source with the '--with-linux=PATH' option.

demizer commented on 2016-08-14 18:34

Package update cannot be made currently. See pinned comment at https://aur.archlinux.org/packages/zfs-linux/

resuni commented on 2016-08-08 18:17

To anyone else who checked here to find out why their system no longer updates, first read demizer's comment below.

This forum post elaborates more on the steps to safely transition to the new repository: https://bbs.archlinux.org/viewtopic.php?pid=1625082#p1625082

For me, updating caused my pools to fail to mount on the next reboot, but re-importing them with the -f flag in the recovery shell seemed to work. I only had to do this once for them to start automatically mounting on boot again.

And as always, back up your data if it is important! This can never be stated enough.