Package Details: spotify-beta 1.0.28.89-3

Git Clone URL: https://aur.archlinux.org/spotify-beta.git (read-only)
Package Base: spotify-beta
Description: A proprietary peer-to-peer music streaming service
Upstream URL: http://www.spotify.com
Keywords: music streaming
Licenses: custom:"Copyright (c) 2006-2010 Spotify Ltd"
Conflicts: spotify
Submitter: Perry3D
Maintainer: dundee
Last Packager: dundee
Votes: 52
Popularity: 5.462769
First Submitted: 2015-03-26 23:53
Last Updated: 2016-04-29 08:43

Latest Comments

rafaelsoaresbr commented on 2016-04-29 13:34

Shouldn't that "# Copy protocol file if KDE is installed" be on a post-install script?

dundee commented on 2016-04-22 07:59

Thanks, added.

harbind commented on 2016-04-22 06:54

zenity is missing from dependencies (optional perhaps). It's used at least when changing the cache location.

dundee commented on 2016-04-11 10:03

Updated, thanks!

Ekaradon commented on 2016-04-10 07:54

i386 version out too: http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.27.73.g602ced10-2_i386.deb

brittyazel commented on 2016-04-08 21:45

The pulled the 1.0.26 build from their servers, so right now this package fails to install

dundee commented on 2016-04-08 17:13

Thanks, I will probably wait until the i386 version is ready.

Ekaradon commented on 2016-04-08 11:40

MPRIS support out!
http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.27.71.g0a26e3b2-9_amd64.deb
https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Linux-Spotify-client-1-x-now-in-stable/m-p/1323233#M154625

dundee commented on 2016-04-06 12:23

Added, thanks.

mis commented on 2016-04-06 12:15

Please add rtmpdump to dependencies.

/usr/share/spotify/spotify: error while loading shared libraries: librtmp.so.1: cannot open shared object file: No such file or directory

eycsigfy commented on 2016-03-15 20:03

I hate pulse audio, sorry for the spam. I thought this was related to spotify, not the sound server.

eycsigfy commented on 2016-03-15 19:46

I can't get playback to work at all on this. I'm running a relatively fresh install of Arch with XFCE. What can I do?

dundee commented on 2016-03-12 18:04

Thanks, I added the scale factor as default to PKGBUILD.

dsifford commented on 2016-03-11 23:39

--force-device-scale-factor > 1 also worked for me.. Thanks everyone! I've been dying for this to work! :)

ceides commented on 2016-03-11 12:17

I can confirm that running with --force-device-scale-factor solves the crash for me
> spotify --force-device-scale-factor=1.0000001

warmwaffles commented on 2016-03-10 22:13

> spotify --force-device-scale-factor=1.0000001

This worked for me even after reinstall all deps

c4software commented on 2016-03-09 14:40

I have reinstall all deps but the problem still remain. I also try to removed my profil, but after the login the app crash :

/usr/bin/spotify : ligne 2 : 16362 Erreur de segmentation (core dumped)LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify $@


[Edit]

Really strange, when i run Spotify by specifying a specific device scale factor the problem disappear... (only if i set a force-device-scale-factor higher than 1)

Exemple :
spotify --force-device-scale-factor=1.0000001

dundee commented on 2016-03-09 11:54

Strange, it works for me. Try to reinstall all deps.

c4software commented on 2016-03-09 11:13

Hi,

Same here the latest version still crash on startup :

11:12:51.910 D [gaia_protobuf_device.cpp:237 ] GAIA: GaiaProtobufDevice::triggerAllCallbacks
[1] 21057 segmentation fault (core dumped) LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify


dundee commented on 2016-03-09 10:44

tobru: When did it crash? During startup or after some specific action?

tobru commented on 2016-03-09 09:44

Segfaults with

/usr/bin/spotify: line 2: 1581 Segmentation fault (core dumped) LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify $@

Using 1.0.24.104-3

dundee commented on 2016-02-22 15:50

find "${pkgdir}" -type d -exec chmod 755 {} +

is also not correct, because it changes rights of other dirs, not only the changed ones.

FadeMind commented on 2016-02-22 09:58

NOT

chmod 755 "${pkgdir}/usr"
chmod 755 "${pkgdir}/usr/bin"
chmod 755 "${pkgdir}/usr/share/doc"
chmod 755 "${pkgdir}/usr/share/spotify"
chmod 755 "${pkgdir}/usr/share/doc/spotify-client"

Just

find "${pkgdir}" -type d -exec chmod 755 {} +




I have warnings about this (in polish lang)

Pakiety (1) spotify-beta-1.0.23.93-3

Do zainstalowania: 177,06 MiB
Zmiana po aktualizacji: 0,00 MiB

:: Kontynuować instalację? [T/n]
(1/1) sprawdzanie kluczy w bazie [################################################] 100%
(1/1) sprawdzanie spójności pakietów [################################################] 100%
(1/1) wczytywanie listy plików [################################################] 100%
(1/1) sprawdzanie konfliktów plików [################################################] 100%
(1/1) sprawdzanie dostępnego miejsca na dysku [################################################] 100%
:: Przetwarzanie zmian pakietu...
(1/1) aktualizowanie spotify-beta [################################################] 100%
ostrzeżenie: Różne uprawnienia dla katalogu dla /usr/share/spotify/
system plików: 775 pakiet: 755
ostrzeżenie: Różne uprawnienia dla katalogu dla /usr/share/doc/spotify-client/
system plików: 775 pakiet: 755

Freso commented on 2016-02-22 09:56

Perhaps add "spotify" to $provides in addition to $conflicts?

dundee commented on 2016-02-22 09:49

FadeMind: Thanks, fixed.

FadeMind commented on 2016-02-19 09:27

I have a warning about permissions for directiories:

:: Processing package changes...
(1/1) reinstalling spotify-beta [################################################] 100%
warning: directory permissions differ on /usr/
filesystem: 755 package: 775
warning: directory permissions differ on /usr/bin/
filesystem: 755 package: 775
warning: directory permissions differ on /usr/share/doc/
filesystem: 755 package: 775

Simple fix is adding in package() at the end:

find "${pkgdir}" -type d -exec chmod 755 {} +

dundee commented on 2016-02-19 09:13

audiophiel: Thanks, updated to new version.

audiophiel commented on 2016-02-19 07:12

The file http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.19.106.gb8a7150f_amd64.deb ist not available (error 404).

dundee commented on 2015-12-08 11:40

adamundercover: Added, thanks.

mazzolino commented on 2015-12-06 16:10

@adamundercover: Thanks for the hint! Didn't even know it was possible to specify the scaling factor for Spotify.

For detecting HiDPI displays, I suppose a wrapper script for spotify (using xrdb?) would be needed.

adamundercover commented on 2015-12-06 11:59

An update to the PKGBUILD that detected HIDPI displays would be useful.

When installed, the spotify.desktop runs the application without any scaling, meaning that the user has to manually append --force-device-scale-factor=x to the file.

This could potentially be adjusted by allowing it to be configured in the PKGBUILD manually.

dundee commented on 2015-12-04 14:00

xnart: Updated, thanks.

xnart commented on 2015-12-03 22:36

pkgver=1.0.19.106
_anotherpkgver=gb8a7150f

sha256sums=('af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3')
sha256sums_x86_64=('be6b99329bb2fccdc9d77bc949dd463576fdb40db7f56195b4284bd348c470be')
sha256sums_i686=('128b5d04dda8a052802fb9e664a996250569696fac359e94ea35043472f5dbcb')

dundee commented on 2015-10-29 07:45

Turski: Thanks, updated.

Turski commented on 2015-10-28 21:59

diff --git a/PKGBUILD b/PKGBUILD
index 1b68fe0..24782b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Christopher Reimer <mail+aur[at]c-reimer[dot]de>

pkgname=spotify-beta
-pkgver=1.0.16.104
-_anotherpkgver=g3b776c9e
-pkgrel=2
+pkgver=1.0.17.75
+_anotherpkgver=g8f111100
+pkgrel=1
pkgdesc="A proprietary peer-to-peer music streaming service"
arch=('x86_64' 'i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
@@ -22,8 +22,8 @@ source=('spotify.protocol')
source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}.${_anotherpkgver}_amd64.deb")
source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}.${_anotherpkgver}_i386.deb")
sha256sums=('af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3')
-sha256sums_x86_64=('2b3e7a7cccadaa4567450e9d3c801a2f72ec9a5ad9295241701874310f6bd96a')
-sha256sums_i686=('b61ba5b2a42db6e888f002094d3bae7493997e18f2f7821208bcf90b6b129aff')
+sha256sums_x86_64=('65ad49871a5f281aa7248690c0379fc18c17c063ab640590bbfa7edc02cb223f')
+sha256sums_i686=('480d8791d4de95f43ba95e4c5d31fc5a02662c6e041c3eb45f481a5ef6bd39b0')

package() {
cd "${srcdir}"

B_E commented on 2015-10-18 10:49

You can pull 1.0.16.104 from https://github.com/beheh/spotify-beta.git

Edit: Disregard, I just noticed the "spotify" package is on that version already.

zettaone commented on 2015-10-18 02:19

Update vars in PKBUILD:

For 64 bits:

pkgver=1.0.16.104
_anotherpkgver=g3b776c9e

sha256sums_x86_64=('2b3e7a7cccadaa4567450e9d3c801a2f72ec9a5ad9295241701874310f6bd96a')

gat commented on 2015-10-09 09:15

Spotify does not seem to be working with Alsa, only with Pulseaudio. See discussion on https://aur.archlinux.org/packages/spotify/?comments=all

dundee commented on 2015-10-09 06:27

monkeynaleo: strange, it works for me.

monkeynaleo commented on 2015-10-09 01:25

Does anybody know what is up? After the new update, sound will not work at all. I checked, and the sound is turned all the way up, both in alsamixer, and spotify.

dundee commented on 2015-10-08 07:52

Thanks, updated.

hertog commented on 2015-10-08 07:30

There has been a new release 2 days ago;
spotify-client_1.0.15.137.gbdf68615_amd64.deb 06-Oct-2015 15:22
spotify-client_1.0.15.137.gbdf68615_i386.deb 06-Oct-2015 15:23

nerayan commented on 2015-09-20 16:48

As an interim solution, update the PKGBUILD while installing with the version numbers from karlstav's comment and the sha256sum '6fed225815ada3a290dd588c7f19a5c83df2712cd016d8e6ad0a2bba4ef66257' for the 64bit version.

B_E commented on 2015-09-19 10:34

You can clone/pull here for the updated version (1.0.14.122/124): https://github.com/beheh/spotify-beta.git

karlstav commented on 2015-09-18 16:44

new release today:

spotify-client_1.0.14.122.gf29d9be0_i386.deb 18-Sep-2015 07:33 69292192
spotify-client_1.0.14.124.g4dfabc51_amd64.deb 18-Sep-2015 07:33 65887386

getting 404 since old sources are removed, are there some way to update the source paths automaticaly?

strebski commented on 2015-09-14 16:21

@dundee

Works fantastic (installed via yaourt)! Thanks so much! :-)

dundee commented on 2015-09-14 07:27

CReimer: Thanks, merged.

CReimer commented on 2015-09-13 10:40

dundee: That's not how it's done right.

There are architecture specific arrays: source_x86_64=() and source_i686=()

I fixed it for you. Would you please pull from here "git pull https://github.com/CReimer/spotify-beta.git"

Thanks

dundee commented on 2015-09-11 13:05

strebski: Added, please try if it works.

strebski commented on 2015-09-10 16:36

Hi, please provide also 32bit version in this package. Both versions are on the same source: http://repository.spotify.com/pool/non-free/s/spotify-client/ Thank you for your great job! :)

stathisq commented on 2015-09-05 18:46

@dundee: dundee thanks for the answers...I deleted the spotify folder inside the .config and the problem has gone! thanks for your time...

evana commented on 2015-09-03 23:37

Client received a minor version bump today

http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.13.112.g539ef41b_amd64.deb

Fixes the "add to queue" button missing.

dundee commented on 2015-09-02 10:19

@stathisq: Gnome3

stathisq commented on 2015-09-02 10:11

@dundee: Under which DE? I'm currently using Cinnamon...

dundee commented on 2015-09-01 14:04

stathisq: I am running fine in window.

stathisq commented on 2015-09-01 14:02

Am I the only one whose spotify runs only on fullscreen?

dundee commented on 2015-09-01 06:44

Thanks, updated.

evana commented on 2015-08-31 18:14

Notable in this update is the return of dbus support

https://community.spotify.com/t5/Spotify-Announcements/Spotify-beta-1-0-13-for-Linux-released/td-p/1197675

episyron commented on 2015-08-31 17:08

New version available:

http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.13.111.g6bd0deca_amd64.deb

dmrobotix commented on 2015-08-29 17:20

This works great, I had zero problems with installation.

dundee commented on 2015-08-16 10:07

Thanks, added.

doweaver commented on 2015-08-15 22:06

It looks like this package requires libxss - I had to install manually from pacman before I could launch. The error I was seeing was:

$ spotify
/usr/share/spotify/spotify: error while loading shared libraries: libXss.so.1: cannot open shared object f

acidflash commented on 2015-08-10 08:11

Trying to upgrade to spotify-beta 1.0.11.131-1
Get this error:
:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [#############################################] 100%
(1/1) checking package integrity [#############################################] 100%
(1/1) loading package files [#############################################] 100%
(1/1) checking for file conflicts [#############################################] 100%
error: failed to commit transaction (conflicting files)
spotify-beta: /usr/share/applications/spotify.desktop exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-jonbys
==> ERROR: unable to update

To fix it i did: mv /usr/share/applications/spotify.desktop /usr/share/applications/spotify.desktop.old

After that the upgrade worked out..

acidflash commented on 2015-08-10 08:05

@blackwolf12333 what i know did dbus stop work after 1.X upgrade..

blackwolf12333 commented on 2015-08-04 17:05

Any idea why the dbus integration doesn't work in this version, but does work in the stable version?

zexias commented on 2015-08-04 15:11

weird... for me didn't work, I had to did that. But, thanks @evana for alert me

evana commented on 2015-08-04 14:36

@zexias libcurl-compat is a dependency already. Also, if you remove and reinstall the package the spotify executable should be fixed to use LD_PRELOAD.

zexias commented on 2015-08-04 14:33

New file http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.11.131.gf4d47cb0_amd64.deb

-pkgver=1.0.11.131
-_anotherpkgver=.gf4d47cb0

md5sum: af4bd4604c29d5d0ed2dde6e84453537

I had to install libcurl-compat to make it works.
I'm running spotify with: `LD_PRELOAD=libcurl.so.3 spotify`. Because just `spotify` I was getting CURL_OPENSSL_3 not found.

zexias commented on 2015-08-04 13:52

New file http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.11.131.gf4d47cb0_amd64.deb

-pkgver=1.0.11.131
-_anotherpkgver=.gf4d47cb0

md5sum: af4bd4604c29d5d0ed2dde6e84453537

jeekajoo commented on 2015-07-31 22:08

for those who need to build it against x86, here is a patch:

--- PKGBUILD_amd64 2015-08-01 00:01:44.203061632 +0200
+++ PKGBUILD_x86 2015-08-01 00:02:33.887062497 +0200
@@ -3,21 +3,21 @@
# Contributor: EvanA <evan@thelinuxman.us>

pkgname=spotify-beta
-pkgver=1.0.11.131
-_anotherpkgver=.gf4d47cb0
+pkgver=1.0.11.129
+_anotherpkgver=.g61510de3
pkgrel=1
pkgdesc="A proprietary peer-to-peer music streaming service"
-arch=('x86_64')
+arch=('i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
url="http://www.spotify.com"
changelog='spotify.changelog'
options=('!strip')
conflicts=('spotify')

-source=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}_amd64.deb"
+source=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}_i386.deb"
'spotify.protocol'
)
-md5sums=('af4bd4604c29d5d0ed2dde6e84453537'
+md5sums=('4e467409f2de399e99d13cde84dc2f3d'
'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')

depends=("alsa-lib>=1.0.14" "glibc>=2.6" "openssl" "gconf" "nss" "systemd" "gtk2" "libxtst" "libx11" "libcurl-compat")
@@ -49,4 +49,3 @@
install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kde4/services/spotify.protocol"
fi
}

dundee commented on 2015-07-30 17:28

Thanks, updated.

harrygallagher4 commented on 2015-07-30 15:48

New version released today:
http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.11.131.gf4d47cb0_amd64.deb

The current PKGBUILD is not working as the old .deb files have been removed.

matthias.lisin commented on 2015-07-25 01:37

Update absolutely not worth it.
If you have the 1.0.7.x beta, KEEP IT!

dundee commented on 2015-07-19 08:52

crepererum: thanks, fixed.

crepererum commented on 2015-07-18 14:18

Your wrapper script does not forward command line arguments

LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify
should be
LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify $@

jpapadopoulos commented on 2015-07-12 18:08

Modified the PKGBUILD to install 1.0.9, but it seems it's broken due to curl symbol changes.

Weegee commented on 2015-07-11 12:45

Seems like a new version is out, 1.0.9.133.gcedaee38

http://repository-origin.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.9.133.gcedaee38_amd64.deb

evana commented on 2015-06-07 12:30

32 bit client is coming soon.

zota commented on 2015-06-07 11:29

Who knows when they will relase a i686 client? Much appreciated.

ZaZam commented on 2015-06-07 09:42

You should update the description as Spotify no longer uses peer-to-peer networking.

evana commented on 2015-06-06 21:35

Dbus support has been removed from the initial 1.x beta. They did a full re-write of the client, so many features are missing. They will be reimplementing dbus in later betas

jbbr commented on 2015-06-06 14:57

Playback control with playerctl/dbus isn't working for me. Dbus destination org.mpris.MediaPlayer2.spotify is missing - Non beta aur package "spotify" is working for me.

Is this an upstream issue or related to this package?

Perry3D commented on 2015-06-06 09:04

Thank you evana. I just renamed your package.

evana commented on 2015-06-06 01:24

I updated the package based on the mainline Spotify package. Several dependencies can be removed, including libgcrypt15, qtwebkit, nspr, libxss, and dbus. New dependencies are libxtst and libx11. My work is available here: https://github.com/linuxman94/spotify-aur

episyron commented on 2015-06-05 11:17

New beta version 1.0.7.153.gb9e8174a has been released.

https://community.spotify.com/t5/Spotify-Announcements/Spotify-Client-1-x-beta-for-Linux-has-been-released/m-p/1147084/thread-id/7253