Package Details: spotify-dev 1.2.31.1205-1

Git Clone URL: https://aur.archlinux.org/spotify-dev.git (read-only, click to copy)
Package Base: spotify-dev
Description: A proprietary music streaming service
Upstream URL: https://www.spotify.com
Licenses: custom
Conflicts: spotify
Provides: spotify
Submitter: imp0
Maintainer: imp0 (midnightfox, sorcix)
Last Packager: imp0
Votes: 25
Popularity: 0.000277
First Submitted: 2019-02-19 21:06 (UTC)
Last Updated: 2024-02-29 18:00 (UTC)

Required by (19)

Sources (4)

Latest Comments

1 2 3 4 5 Next › Last »

imp0 commented on 2023-10-04 22:26 (UTC)

Dependencies updated, thx for reporting!

coder2000 commented on 2023-09-28 13:35 (UTC) (edited on 2023-09-28 13:35 (UTC) by coder2000)

There is a new dependency of libayatana-appindicator for the latest version

imp0 commented on 2023-04-03 13:33 (UTC)

Spotify seems to have removed that version from its repo's.

The package is now updated to the latest release, which resolves the issue.

notx commented on 2023-04-03 07:35 (UTC)

"spotify-client_1.2.7.1277.g2b3ce637_amd64.deb" is not available online. Only available version is "spotify-client_1.2.8.923.g4f94bf0d_amd64.deb".

See: http://repository.spotify.com/pool/non-free/s/spotify-client/

terdon commented on 2022-02-05 13:32 (UTC)

If it complains about missing key:

==> Verifying source file signatures with gpg...
    spotify-1.1.72.439-3-Release ... FAILED (unknown public key 5E3C45D7B312C643)
==> ERROR: One or more PGP signatures could not be verified!
:: Unable to build spotify - makepkg exited with code: 1

Run the curl command given in the PKGBUILD file on line 41:

# Import key with:
# curl -sS https://download.spotify.com/debian/pubkey_5E3C45D7B312C643.gpg | gpg --import -
validpgpkeys=('F9A211976ED662F00E59361E5E3C45D7B312C643') # Spotify Public Repository Signing Key <tux@spotify.com>

danoe commented on 2022-01-22 05:51 (UTC)

@evgfilim1: Importing the key was already correct, but also edit line 42

replace: validpgpkeys=('8FD3D9A8D3800305A9FFF259D1742AD60D811D58') with: validpgpkeys=('F9A211976ED662F00E59361E5E3C45D7B312C643')

evgfilim1 commented on 2022-01-14 08:38 (UTC)

Cannot install :(

$ makepkg -si
==> Making package: spotify-dev 1.1.72.439-1 (Fri 14 Jan 2022 01:36:36 PM +05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify-Release
  -> Found spotify-Release.sig
  -> Found spotify-1.1.72.439-x86_64.deb
  -> Found spotify-x86_64-Packages
  -> Found LICENSE
==> Validating source files with sha512sums...
    spotify-Release ... Skipped
    spotify-Release.sig ... Skipped
    spotify-1.1.72.439-x86_64.deb ... Passed
    spotify-x86_64-Packages ... Skipped
    LICENSE ... Passed
==> Verifying source file signatures with gpg...
    spotify-Release ... FAILED (unknown public key 5E3C45D7B312C643)
==> ERROR: One or more PGP signatures could not be verified!
$ gpg --keyserver keyserver.ubuntu.com --recv-key 5E3C45D7B312C643    1
gpg: key 5E3C45D7B312C643: public key "Spotify Public Repository Signing Key <tux@spotify.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1
$ makepkg -si
==> Making package: spotify-dev 1.1.72.439-1 (Fri 14 Jan 2022 01:36:23 PM +05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify-Release
  -> Found spotify-Release.sig
  -> Found spotify-1.1.72.439-x86_64.deb
  -> Found spotify-x86_64-Packages
  -> Found LICENSE
==> Validating source files with sha512sums...
    spotify-Release ... Skipped
    spotify-Release.sig ... Skipped
    spotify-1.1.72.439-x86_64.deb ... Passed
    spotify-x86_64-Packages ... Skipped
    LICENSE ... Passed
==> Verifying source file signatures with gpg...
    spotify-Release ... FAILED (invalid public key F9A211976ED662F00E59361E5E3C45D7B312C643)
==> ERROR: One or more PGP signatures could not be verified!

thaibeouu commented on 2021-04-16 17:13 (UTC)

pamac build spotify-dev

Choose e to edit build files. Add this line to PKGBUILD

DLAGENTS=("http::/usr/bin/wget -r -np -nd -H %u")

Save and apply transaction. Good luck!

twomby commented on 2021-04-16 10:37 (UTC) (edited on 2021-04-16 12:49 (UTC) by twomby)

***Please disregard, I was able to fix this by reseting build files through pamac. Thanks!

Server seems to work on my end but I also get the checksum fail error, and I don't understand how to fix this even though I went through the comments. Newbie question of the day... What is a clean build ?Would really appreciate some help. New Arch user, I'm used to Debian. Thanks in advance!

Error message:

==> Starting prepare()... spotify-x86_64-Packages: OK spotify-1.1.56.595-x86_64.deb: FAILED sha512sum: WARNING: 1 computed checksum did NOT match ==> ERROR: A failure occurred in prepare(). Aborting...