Package Details: spotify-legacy 0.9.17-3

Git Clone URL: https://aur.archlinux.org/spotify-legacy.git (read-only, click to copy)
Package Base: spotify-legacy
Description: A proprietary music streaming service.
Upstream URL: https://www.spotify.com/download/linux/
Licenses: custom
Conflicts: spotify, spotify-beta, spotify-stable, spotify094
Provides: spotify
Submitter: olejon
Maintainer: olejon
Last Packager: olejon
Votes: 34
Popularity: 0.016458
First Submitted: 2016-04-30 17:14 (UTC)
Last Updated: 2017-06-09 10:36 (UTC)

Required by (19)

Sources (2)

Pinned Comments

olejon commented on 2019-03-09 17:37 (UTC) (edited on 2019-03-09 18:44 (UTC) by olejon)

It is a problem with the ffmpeg0.10 package. The solution is posted below and in that package's comments, and x264 (video decoding) is not needed for local files playback - you have the regular ffmpeg package alongside this installed for that - so no problem not compiling it in.

Latest Comments

1 2 3 Next › Last »

usuariopolivalen commented on 2021-09-16 09:28 (UTC)

incredible im using it yet.. xD okey, now better to say, testing it vs the new one

00zerozero commented on 2021-08-15 23:30 (UTC)

tried to install, compiling took over an hour so I quit.

olejon commented on 2019-03-09 17:37 (UTC) (edited on 2019-03-09 18:44 (UTC) by olejon)

It is a problem with the ffmpeg0.10 package. The solution is posted below and in that package's comments, and x264 (video decoding) is not needed for local files playback - you have the regular ffmpeg package alongside this installed for that - so no problem not compiling it in.

andmars commented on 2019-03-08 04:33 (UTC)

doesn't build:

"libavcodec/libx264.c: In Funktion »X264_init_static«: libavcodec/libx264.c:595:9: Fehler: »x264_bit_depth« nicht deklariert (erstmalige Verwendung in dieser Funktion); meinten Sie »x264_picture_t«? if (x264_bit_depth == 8) ^~~~~~~~~~~~~~ x264_picture_t make: *** [common.mak:45: libavcodec/libx264.o] Fehler 1 ==> FEHLER: Ein Fehler geschah in build(). Breche ab..."

olejon commented on 2017-06-09 11:32 (UTC)

I have updated this package now with the dependencies needed to run. It runs fine here, but have not tested during time.

Rapti commented on 2017-05-14 20:28 (UTC)

The latest version of qt4 causes Spotify to crash from a segmentation fault a few seconds after startup on my machine. This can be temporarily fixed by downgrading qt4 to a previous version.

l444 commented on 2017-05-13 15:37 (UTC)

NIIICE, hate the new version. WIll keep this till it stops working

usuariopolivalen commented on 2017-04-25 07:31 (UTC)

there is a workaround for getting spotify to launch, see spotify aur page for more information if you want to get spotigy work or if you want to include in spotify legacy aur page

usuariopolivalen commented on 2017-04-24 17:14 (UTC) (edited on 2017-04-24 17:15 (UTC) by usuariopolivalen)

since the last update of openssl and other spotify is imposible to launch...

Scimmia commented on 2016-08-25 15:38 (UTC) (edited on 2016-08-25 15:45 (UTC) by Scimmia)

You will need to uninstall 0.9.17-1 before updating to 0.9.17-2. Sorry, the old package put untracked files all over the place, nothing else we can do. If you still get conflicting file errors, please see https://wiki.archlinux.org/index.php/Pacman#.22Failed_to_commit_transaction_.28conflicting_files.29.22_error It's very possible even uninstalling doesn't completely clean up the mess.