Package Details: spotube-bin 3.6.0-1

Git Clone URL: https://aur.archlinux.org/spotube-bin.git (read-only, click to copy)
Package Base: spotube-bin
Description: Open source Spotify client that doesn't require Premium nor uses Electron! Available for both desktop & mobile!
Upstream URL: https://github.com/KRTirtho/spotube/
Keywords: audio flutter foss music player spotify youtube
Licenses: BSD-4-clause
Submitter: KRTirtho
Maintainer: KRTirtho
Last Packager: KRTirtho
Votes: 24
Popularity: 3.69
First Submitted: 2022-02-06 04:10 (UTC)
Last Updated: 2024-04-15 14:12 (UTC)

Latest Comments

1 2 Next › Last »

Erwin_Iosef commented on 2024-05-09 16:12 (UTC) (edited on 2024-05-09 16:20 (UTC) by Erwin_Iosef)

Why is mpv a dependency?

krafairus commented on 2024-02-18 14:54 (UTC)

@raevn And the website doesn't allow you to unmark it as "obsolete"?

raevn commented on 2024-02-08 16:19 (UTC)

Apologies, I mistakenly flagged this as "out-of-date"

KRTirtho commented on 2024-01-09 16:02 (UTC) (edited on 2024-01-09 16:03 (UTC) by KRTirtho)

To fix the checksum error, simply clear the AUR cache of yay or pacman. And reinstall.

For e.g.

$ yay -Sc
$ yay -Sy spotube-bin

agarbathi commented on 2024-01-08 23:26 (UTC) (edited on 2024-01-08 23:27 (UTC) by agarbathi)

Please fix the checksum:

AUR (1)          Alte Version  Neue Version   Nur Make
aur/spotube-bin  3.4.0-1       3.4.0-2        Nein

:: Mit Überprüfung fortfahren? [J/n]: j

:: Lade PKGBUILDs herunter…
 PKGBUILDs sind aktuell
:: Änderungen akzeptieren? [J/n]: j
devel Informationen werden empfangen...
==> Erstelle Paket: spotube-bin 3.4.0-2 (Di 09 Jan 2024 00:23:23 CET)
==> Empfange Quellen...
  -> spotube-linux-3.4.0-x86_64.tar.xz gefunden
==> Überprüfe source Dateien mit md5sums...
    spotube-linux-3.4.0-x86_64.tar.xz ... FEHLGESCHLAGEN
==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung!
Fehler: Quellen für ‚spotube-bin-3.4.0-2‘ konnten nicht heruntergeladen werden: 
Fehler: Pakete konnten nicht erstellt werden: spotube-bin-3.4.0-2

md5sums=("755febc05dd051500a9327cc692dc8b2") <- this solution isn't working!

MioKira commented on 2024-01-02 18:29 (UTC) (edited on 2024-01-04 07:51 (UTC) by MioKira)

please fix the checksum

==> Making package: spotube-bin 3.4.0-2 (Вт 02 янв 2024 21:27:54) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found spotube-linux-3.4.0-x86_64.tar.xz ==> Validating source files with md5sums... spotube-linux-3.4.0-x86_64.tar.xz ... FAILED ==> ERROR: One or more files did not pass the validity check! -> error making: spotube-bin-exit status 1 -> Failed to install the following packages. Manual intervention is required: spotube-bin - exit status 1

the checksum should be 755febc05dd051500a9327cc692dc8b2

update :

so the solution for me was adding "" in the checksum field

md5sums=("755febc05dd051500a9327cc692dc8b2")

mikesco3 commented on 2024-01-02 00:43 (UTC)

Works great again after the recent udpate!!

mikesco3 commented on 2023-12-31 02:32 (UTC) (edited on 2023-12-31 02:32 (UTC) by mikesco3)

I'm getting a blank screen right after putting in my spotify credentials.
I launched from the terminal just in case, and here is what I get:

(process:230809): GLib-GObject-CRITICAL **: 20:29:02.364: g_object_new_is_valid_property: object class 'MyApplication' has no property named 'com.github.KRTirtho.Spotube'

(spotube:230809): Gdk-CRITICAL **: 20:29:02.427: gdk_window_get_state: assertion 'GDK_IS_WINDOW (window)' failed
package:media_kit_libs_linux registered.
flutter: media_kit: WARNING: package:media_kit_native_event_loop not found.
flutter: Configure AudioServiceLinux.
method call InitSystemTray
SystemTray::set_system_tray_info title: , icon_path: /usr/share/spotube-bin/data/flutter_assets/assets/spotube-logo.png, toolTip: (null)
flutter: setQueue() has not been implemented.
flutter: Get org.mpris.MediaPlayer2.Player.Volume not implemented
flutter: GetPosition(): 0:00:00.000000
flutter: Get org.mpris.MediaPlayer2.Player.Volume not implemented
flutter: GetPosition(): 0:00:00.000000
flutter: Get org.mpris.MediaPlayer2.Player.Volume not implemented
flutter: GetPosition(): 0:00:00.000000
flutter: Get org.mpris.MediaPlayer2.Player.Volume not implemented
flutter: GetPosition(): 0:00:00.000000
method call CreateContextMenu
value_to_menu_item type:label, label:Show/Hide
value_to_menu_item type:label, label:Play/Pause
value_to_menu_item type:label, label:Next
value_to_menu_item type:label, label:Previous
value_to_menu_item type:label, label:Quit
method call SetContextMenu

I'm running the latest manjaro on xfce just in case....

Aftermath commented on 2023-05-08 20:15 (UTC) (edited on 2023-05-08 20:15 (UTC) by Aftermath)

Interesting that this was suggested to me by many Arch users, but only 4 votes?

malcolm commented on 2023-03-11 18:03 (UTC)

please, update the md5sums