Package Details: springseed 2.0-11

Git Clone URL: https://aur.archlinux.org/springseed.git (read-only)
Package Base: springseed
Description: Simply awesome note taking
Upstream URL: https://github.com/spsdco/notes
Keywords: notes office
Licenses: MIT
Submitter: devrs0
Maintainer: None
Last Packager: gspu
Votes: 29
Popularity: 0.000000
First Submitted: 2013-08-02 17:46
Last Updated: 2018-05-05 16:17

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

reefland commented on 2015-03-11 02:17

1) There does not appear to be a search box anymore.

2) Where exactly does your content get saved? "~/.config/Springseed" does not seem to be used anymore.

devrs0 commented on 2015-01-06 15:49

Thanks for catching this, James. The issue has been resolved.

thx1138 commented on 2015-01-03 06:00

This, from the people at "pacman", at
https://bugs.archlinux.org/task/43309


"Handling of symlink directories has changed in pacman-4.2, as noted in the release announcement: (Ctrl-F for "Directory Symlink Handling")

http://allanmcrae.com/2014/12/pacman-4-2-released/

So this is not a bug; packages which try to install to /bin/ are now intentionally in conflict with core/filesystem, and need to be fixed to install to /usr/bin/ instead."

So, there it is. The install should be modified. The release notes, from the above link, explain:

"Directory Symlink Handling: Example time! Arch Linux has a /lib -> /usr/lib symlink. Previously, if pacman was installing a package and it found files in /lib, it would follow the symlink and install it in /usr/lib. However the filelist for that package still recorded the file in /lib. This caused heaps of difficulty in conflict resolving – primarily the need to resolve every path of all package files to look for conflicts. That was a stupid idea! So now if pacman sees a /lib directory in a package, it will detect a conflict with the symlink on the filesystem. If you were using this feature to install files elsewhere, you probably need to look into what a bind mount is! Note that this change requires us to correct the local package file list for any package installed using this mis-feature, so we bumped the database version. Upgrade using pacman-db-upgrade. Thanks to Andrew!"

This seems to require simply changing, in the PKGBUILD, "package(){...}",

mkdir ${pkgdir}/bin

to

mkdir -p ${pkgdir}/usr/bin


James

thx1138 commented on 2015-01-02 22:25

On install, produces:

...
(1/1) checking for file conflicts
error: failed to commit transaction (conflicting files)
springseed: /bin exists in filesystem
...

where the springseed package includes:

...
drwxr-xr-x root/root 0 2015-01-02 12:24 bin/
drwxr-xr-x root/root 0 2014-06-21 01:53 usr/
drwxr-xr-x root/root 0 2015-01-02 12:24 usr/share/
drwxr-xr-x root/root 0 2014-06-21 01:53 usr/bin/
...

with, of course,

$ls -l /
...
lrwxrwxrwx 1 root root 7 Oct 25 12:41 bin -> usr/bin
...

Using: pacman 4.2.0-5. Is that a pacman bug?

Installing with "--debug" adds:

debug: checking possible conflict: /bin/
debug: found file conflict /bin, packages springseed and (filesystem)

in contrast to:

debug: checking possible conflict: /usr/
debug: file is a directory, not a conflict

presumably since "/bin/" is a symbolic link and not a "directory" per se.

For the moment, using "--force" will work, to install. I will file a bug for "pacman".

James

xordspar0 commented on 2014-06-30 04:54

Your old notes are still in ~/.config/Springseed/Notebooks/
The new notes aren't stored there. I haven't found them yet.

masnormen commented on 2014-06-29 22:58

The notes from the previous version seems to be disappeared (or worse, gone forever?). Is this normal? If not, then how to resolve this?

devrs0 commented on 2014-06-24 21:02

The issue with atom should be resolved.

Also, it appears that Springseed.zip provides its own libudev.so.0.

silenc3r commented on 2014-06-24 17:51

I'm getting an error when trying to launch app:
$ springseed
/usr/bin/springseed: line 3: /usr/share/springseed/atom: No such file or directory

devrs0 commented on 2014-06-24 15:46

Thanks @ThisIsMyPlace. I didn't have time to update yesterday after @pedrogabriel's comment.

Also, LICENSE is now included in Springseed.zip so it no longer needs to be pulled from git.

ThisIsMyPlace commented on 2014-06-24 15:32

PKGBUILD for 2.0

http://codepad.org/nrKOXNVr