Package Details: spriteilluminator 1.5.1-1

Git Clone URL: https://aur.archlinux.org/spriteilluminator.git (read-only)
Package Base: spriteilluminator
Description: Tool for creating Normal Maps, also known as Dot3 Bump Maps, which generate a 2.5D effect in different game engines including Cocos2D-X
Upstream URL: http://www.codeandweb.com/spriteilluminator
Keywords: bump crossplatform dot3 dynamic editor gamedev graphics light map normal normalmap sprite
Licenses: custom:spriteilluminator
Submitter: Rubonnek
Maintainer: Rubonnek
Last Packager: Rubonnek
Votes: 4
Popularity: 0.070884
First Submitted: 2016-01-06 00:54
Last Updated: 2018-09-27 23:32

Latest Comments

Rubonnek commented on 2018-03-15 18:54

Thanks for reporting this -- I didn't have time to test this package until now and I can confirm this issue.

It looks like the Qt library in the official repository is missing an object symbol that SpriteIlluminator is using.

For this reason we have to keep the bundled library instead of using the official one which accounts for the package bloat in size.

Poqudrof commented on 2018-03-15 17:14

Hello, I have a problem with QT when I want to run it.

I gues the QT version is not compatible, any idea ?

--- result: /usr/bin/../lib/spriteilluminator/SpriteIlluminator: relocation error:

/usr/bin/../lib/spriteilluminator/SpriteIlluminator: symbol

_ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE9_M_createERmm, version Qt_5 not defined in file libQt5Qml.so.5 with link time reference

EDIT: I have this version installed: libQt5Qml.so.5.10.1