Package Details: spyder-git 5.0.5.r360.gd829e6db6-1

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only, click to copy)
Package Base: spyder-git
Description: The Scientific Python Development Environment
Upstream URL: https://www.spyder-ide.org/
Licenses: MIT
Conflicts: spyder, spyder3-git
Provides: spyder
Replaces: spyder3-git
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 24
Popularity: 0.021726
First Submitted: 2015-02-24 08:52
Last Updated: 2021-07-10 14:42

Dependencies (47)

Required by (5)

Sources (1)

Pinned Comments

willemw commented on 2020-08-05 07:20

Note:

Some dependencies may need to be downgraded.

Alternatively, try to edit the requirements file ("requirements/conda.txt" in the source files or "requires.txt" in the installed files).

Latest Comments

1 2 3 4 5 6 ... Next › Last »

NiceMicro commented on 2021-07-13 16:07

@willemw Unfortunately, when installing python-spyder-kernels-git, spyder also didn't work, either with the community package, nor spyder3-git. I am honestly confused why doesn't it.

willemw commented on 2021-07-10 14:27

@NiceMicro: python-spyder-kernels-git is too new or you decided not to use it?

(Usually, you can install either python-spyder-kernels or python-spyder-kernels-git for spyder or spyder3-git.)

NiceMicro commented on 2021-07-10 13:58

@willemw yeah, that bug is what causes me to not use Spyder for 2 months now.

Luckily I saw in the bugreport a new comment, and figured that if I just build spyder-kernels based on the PKGBUILD for the community package, but with the newest version (replace version number and sha in the file and then makepkg -si), and then I install Spyder from the community repo, it works.

@davidovitch maybe this info might be useful for you.

davidovitch commented on 2021-07-04 21:25

Same here, neither the community package or in my pip-based virtual environments it was working at some point. What did work was creating a fresh new pip-based virtual environment and pip install spyder in there (no mini/anaconda). I didn't further dig into why it worked again, or what versions I had installed differently in the old vs the new virtual env.

willemw commented on 2021-07-04 17:43

@NiceMicro: for community/spyder there is a bug, still open: https://bugs.archlinux.org/task/70689. Consider installing Spyder the upstream recommended way (Anaconda)?

NiceMicro commented on 2021-07-04 17:30

@willemw: thank you for the reply.

I have not been able to run spyder from the community repo since May. The error I got was similar, but for different version of the spyder-kernels was required.

If I change the requires.txt so the spyder-kernels get accepted, then I get the same error for 'rtree>=0.9.7'. I tried the same method with the spyder in the community repo, there I get the error with 'decorator<5'. The dependencies seem to be borked. Am I the only one who got this issue?

willemw commented on 2021-07-04 14:13

@NiceMircro: have you tried any of the suggestions in my previous comment? Maybe use spyder from the community repo?

NiceMicro commented on 2021-07-04 13:53

Spyder doesn't work due to conflicts with the spyder-kernels version:

pkg_resources.DistributionNotFound: The 'spyder-kernels<2.1.0,>=2.0.4' distribution was not found and is required by spyder

It doesn't matter whether I install python-spyder-kernels from the official repos or if I build pythin-spyder-kernels-git from the AUR. I've seen some discussions about the issue on the bugs page for the official spyder package, but that bug is not going anywhere since May 4th. Can anyone point me in a direction to solve this? Thanks a lot.

willemw commented on 2020-08-05 07:20

Note:

Some dependencies may need to be downgraded.

Alternatively, try to edit the requirements file ("requirements/conda.txt" in the source files or "requires.txt" in the installed files).

willemw commented on 2020-04-25 17:16

@fisherjf: I don't think this is a Spyder package issue. Spyder does not install /usr/bin/keyring.

Which package owns it now (pacman -Qo /usr/bin/keyring)? Maybe you need to do a system upgrade.