Package Details: sqlectron-gui 1.37.1-1

Git Clone URL: https://aur.archlinux.org/sqlectron-gui.git (read-only, click to copy)
Package Base: sqlectron-gui
Description: A simple and lightweight SQL client with cross database and platform support
Upstream URL: https://sqlectron.github.io/
Keywords: admin phpmyadmin sql
Licenses: MIT
Submitter: arkhan
Maintainer: jingutech
Last Packager: jingutech
Votes: 9
Popularity: 0.075877
First Submitted: 2016-06-11 02:46
Last Updated: 2021-08-20 15:14

Latest Comments

1 2 Next › Last »

javmorin commented on 2021-01-24 19:17

1.33.0-1 Does not build due to checksum mismatches. Likely they changed something post release. Will need a checksum update.

AlexWayfer commented on 2020-12-25 14:17

@AlexWayfer, I can't guarantee a proper build if you are using nodejs not from the repository.

OK, nodenv global system helped, so fair enough.

But… I've installed and can't launch. :D Sorry. I'm not sure, is it a problem of package or maybe project at all (issues with "Unexpected token" not found):

> sqlectron-gui
Error launching app
Unable to parse /usr/lib/sqlectron-gui/app.asar/package.json

/usr/lib/sqlectron-gui/app.asar/package.json: Unexpected token

app.asar looks like a file at all:

> ls -lah /usr/lib/sqlectron-gui/app.asar
-rw-r--r-- 1 root root 947K Dec 25 17:12 /usr/lib/sqlectron-gui/app.asar

surefire commented on 2020-12-25 14:08

@AlexWayfer, I can't guarantee a proper build if you are using nodejs not from the repository.

AlexWayfer commented on 2020-12-25 13:32

Thank you for update. Now I have such error:

==> Starting prepare()...
==> Sources are ready.
==> Making package: sqlectron-gui 1.32.1-2 (Fri 25 Dec 2020 16:30:09 MSK)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
npm ERR! code 127
npm ERR! git dep preparation failed
npm ERR! command /home/alex/.nodenv/versions/15.1.0/bin/node /home/alex/.nodenv/versions/15.1.0/lib/node_modules/npm/bin/npm-cli.js install --only=dev --prod --ignore-prepublish --no-progress --no-save --cache=/home/alex/.npm/_cacache --prefer-offline=false --prefer-online=false --offline=false --before=
npm ERR! > react-tabs@0.8.0 prepublish
npm ERR! > npm run build
npm ERR! 
npm ERR! 
npm ERR! > react-tabs@0.8.0 build
npm ERR! > npm run clean && npm run build:commonjs
npm ERR! 
npm ERR! 
npm ERR! > react-tabs@0.8.0 clean
npm ERR! > rimraf lib
npm ERR! npm WARN invalid config before="" set in command line options
npm ERR! npm WARN invalid config Must be one of: null, valid Date string
npm ERR! sh: line 1: rimraf: command not found
npm ERR! npm ERR! code 127
npm ERR! npm ERR! path /home/alex/.npm/_cacache/tmp/git-clone-82558823
npm ERR! npm ERR! command failed
npm ERR! npm ERR! command sh -c rimraf lib
npm ERR! 
npm ERR! npm ERR! A complete log of this run can be found in:
npm ERR! npm ERR!     /home/alex/.npm/_cacache/_logs/2020-12-25T13_30_55_417Z-debug.log
npm ERR! npm ERR! code 127
npm ERR! npm ERR! path /home/alex/.npm/_cacache/tmp/git-clone-82558823
npm ERR! npm ERR! command failed
npm ERR! npm ERR! command sh -c npm run clean && npm run build:commonjs
npm ERR! 
npm ERR! npm ERR! A complete log of this run can be found in:
npm ERR! npm ERR!     /home/alex/.npm/_cacache/_logs/2020-12-25T13_30_56_005Z-debug.log
npm ERR! npm ERR! code 127
npm ERR! npm ERR! path /home/alex/.npm/_cacache/tmp/git-clone-82558823
npm ERR! npm ERR! command failed
npm ERR! npm ERR! command sh -c npm run build
npm ERR! 
npm ERR! npm ERR! A complete log of this run can be found in:
npm ERR! npm ERR!     /home/alex/.npm/_cacache/_logs/2020-12-25T13_30_56_240Z-debug.log

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/alex/.npm/_logs/2020-12-25T13_30_56_627Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...
error making: sqlectron-gui

I guess there is missing dependency?

AlexWayfer commented on 2020-12-24 23:25

==> Making package: sqlectron-gui 1.32.1-1 (Fri 25 Dec 2020 02:24:00 MSK)
==> Retrieving sources...
  -> Downloading v1.32.1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   132  100   132    0     0    408      0 --:--:-- --:--:-- --:--:--   408
100 2725k    0 2725k    0     0  2598k      0 --:--:--  0:00:01 --:--:-- 5976k
  -> Found sqlectron-gui.desktop
==> Validating source files with sha1sums...
    v1.32.1.tar.gz ... FAILED
    sqlectron-gui.desktop ... Passed
==> ERROR: One or more files did not pass the validity check!
error downloading sources: sqlectron-gui

surefire commented on 2020-01-24 05:04

@blidt, I do not understand what the point is, give me part of the log with error.

blidt commented on 2020-01-24 00:30

Please update the dependencies so it accepts asar-2.0.3-1 and not only asar-2.0.1-1 or any later version for that matter.

surefire commented on 2019-10-19 10:48

fixed

btd1337 commented on 2019-10-19 08:06

==> Starting build()...
/home/arch/.cache/yay/sqlectron-gui/src/bin/node: linha 6: /usr/lib/electron2/electron2: file or directory nonexistent
==> ERROR: Failed to build().
    Aborting...
Error making: sqlectron-gui

My electron 2 is in:

electron2: /usr/bin/electron2 /usr/lib/electron2

frol commented on 2019-02-08 11:32

The sha1sum for the node.sh file does not match on my end.

$ sha1sum ~/.cache/yay/sqlectron-gui/node.sh
f756fdbfbb244886f4cd907030715f46222207de  /home/frol/.cache/yay/sqlectron-gui/node.sh

$ cat ~/.cache/yay/sqlectron-gui/node.sh
#!/bin/sh

export ELECTRON_RUN_AS_NODE=1
export ELECTRON_NO_ASAR=1

exec /usr/lib/electron2/electron2 "$@"