Package Details: sqlmap-git 1.0.5.7183.263730f-1

Git Clone URL: https://aur.archlinux.org/sqlmap-git.git (read-only)
Package Base: sqlmap-git
Description: Automatic SQL injection and database takeover tool
Upstream URL: http://sqlmap.org
Licenses: GPL2
Conflicts: sqlmap
Provides: sqlmap
Submitter: fxbru
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 66
Popularity: 0.080391
First Submitted: 2012-07-24 17:27
Last Updated: 2016-05-05 19:51

Required by (0)

Sources (1)

Latest Comments

tux commented on 2016-02-02 19:23

@gcarq: The error can be fixed by changing line 9 in the PKGBUILD from "url=('http://sqlmap.org')" TO "url='http://sqlmap.org'". Just remove the parenthesis.

gcarq commented on 2016-02-01 14:37

ERROR: url should not be an arr

Fandekasp commented on 2015-03-21 01:23

Getting error: 'sqlmap-git-1.0dev.3328.g5b8d631-1*.pkg.tar.xz': could not find or read package

Any idea why ?

paraxor commented on 2013-10-16 19:37

I have adopted this package. Although there is no tag for it, the latest sqlmap
version is '1.0-dev'. I am going to change the version number to reflect that.

stativ commented on 2013-10-16 14:00

sqlmap merged into sqlmap-git as requested by the maintainer, because the upstream tarballs are outdated.

fxbru commented on 2013-05-11 17:38

@fr0z3d: Thanks for the hint, compliance should be fine now.

fr0z3d commented on 2013-05-08 14:10

You should edit the PKGBUILD to make it compliant with the VCS guidelines (see: https://wiki.archlinux.org/index.php/Arch_CVS_%26_SVN_PKGBUILD_guidelines)

fxbru commented on 2013-04-15 08:39

@1ace: thanks for your advices, package updated.

1ace commented on 2013-04-15 08:16

Shell arrays are space-separated, not comma-, you need to replace
conflicts=('sqlmap', 'sqlmap-svn')
with
conflicts=('sqlmap' 'sqlmap-svn')

Btw, package names must be valid identifiers, which means there's never any need for quotes when specifying package names.

AkaBkn commented on 2012-11-29 15:33

thanks for your kind information. just use sqlmap-git instead.

Anonymous comment on 2012-11-29 15:26

i cant instal it! I get error: " cant reach svn.sqlmap.org" please fix it!!!

Anonymous comment on 2012-11-29 15:23

thanks bro

roels commented on 2012-11-10 15:47

Out of date as it is recommended to use 'sqlmap-git'.

AkaBkn commented on 2012-05-01 13:58

thanks for your feedbacks m33b0 and mattoufoutu.

Anonymous comment on 2012-04-27 05:00

As "mattoufoutu" kindly suggested, add "options=('!strip')" to the PKGBUILD. It does not work without it.

AkaBkn commented on 2012-03-22 12:40

package builds on my pc without problems?!

Anonymous comment on 2012-03-07 12:30

The package fails to build because of the strip step, please add "options=('!strip')" to the PKGBUILD

corvolino commented on 2011-08-11 02:17

pkgdesc='is an automatic SQL injection tool developed in Python'

(:

Anonymous comment on 2011-06-16 22:56

This PKGBUILD fails on i686 architectures because strip does not know how to handle 64bit libs. Those libs need to be removed from pkgdir before strip is called. Fixed PKGBUILD: http://pastebin.com/tpaAJuvi

intgr commented on 2011-05-25 19:26

Also needs tweaking to use 'python2' instead of 'python'.
If you can't be bothered to update the package, please disown it so someone else can do it.

Anonymous comment on 2011-04-11 06:24

sqlmap 0.9 is out!