Package Details: srain 1:1.5.0-1

Git Clone URL: https://aur.archlinux.org/srain.git (read-only, click to copy)
Package Base: srain
Description: Modern IRC client written in GTK.
Upstream URL: https://srain.silverrainz.me
Keywords: Client GTK IRC
Licenses: GPL
Submitter: SilverRainZ
Maintainer: SilverRainZ (lilac)
Last Packager: lilac
Votes: 8
Popularity: 0.158859
First Submitted: 2016-04-07 12:56 (UTC)
Last Updated: 2022-10-02 21:00 (UTC)

Latest Comments

1 2 Next › Last »

dpirate commented on 2022-02-14 05:07 (UTC) (edited on 2022-02-14 05:09 (UTC) by dpirate)

Hello,

The generated package includes the following documentation build source files that should not be included:

${pkgdir}/usr/share/doc/srain/html

.buildinfo .nojekyll .doctrees/changelog.doctree .doctrees/commands.doctree .doctrees/config.doctree .doctrees/develop.doctree .doctrees/environment.pickle .doctrees/faq.doctree .doctrees/index.doctree .doctrees/install.doctree .doctrees/intro.doctree .doctrees/misc.doctree .doctrees/prefs.doctree .doctrees/start.doctree

This should be fixed in Srain's meson files. But in the meantime, you could add the following commands after the make install step.

rm -rf "${pkgdir}/usr/share/doc/srain/html/.doctrees/"
rm -f "${pkgdir}/usr/share/doc/srain/html/.buildinfo"
rm -f "${pkgdir}/usr/share/doc/srain/html/.nojekyll"

txtsd commented on 2021-04-18 14:12 (UTC)

There is no 1.2.2 on github. Where are you getting this info from?

solonovamax commented on 2021-04-15 15:55 (UTC)

The link still 404's and the buiild fails.

SilverRainZ commented on 2021-04-12 04:08 (UTC)

Tag 1.2.2 is deleted by mistake, now I add it back.

solonovamax commented on 2021-04-11 18:26 (UTC)

Attempting to install/update srain fails:

==> Making package: srain 1.2.2-1 (Sun 11 Apr 2021 02:26:15 PM EDT)
==> Retrieving sources...
  -> Downloading 1.2.2.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   121  100   121    0     0    448      0 --:--:-- --:--:-- --:--:--   448
  0    14    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading https://github.com/SrainApp/srain/archive/1.2.2.tar.gz
    Aborting...

solonovamax commented on 2021-04-11 18:26 (UTC)

Attempting to install/update srain fails:

==> Making package: srain 1.2.2-1 (Sun 11 Apr 2021 02:26:15 PM EDT)
==> Retrieving sources...
  -> Downloading 1.2.2.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   121  100   121    0     0    448      0 --:--:-- --:--:-- --:--:--   448
  0    14    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading https://github.com/SrainApp/srain/archive/1.2.2.tar.gz
    Aborting...

SilverRainZ commented on 2020-03-24 01:08 (UTC)

@Lihis @yochananmarqos should be fixed (again) ;-)

Lihis commented on 2020-03-21 05:26 (UTC)

gcc, makeand gettext are part of base-devel thus are not required to be listed in makedepends.