Package Details: srandrd 0.6.0-2

Git Clone URL: https://aur.archlinux.org/srandrd.git (read-only, click to copy)
Package Base: srandrd
Description: Simple randr daemon that reacts to monitor hotplug events
Upstream URL: https://github.com/jceb/srandrd/
Licenses: custom:MIT/X
Provides: srandrd
Submitter: pigmonkey
Maintainer: pigmonkey
Last Packager: pigmonkey
Votes: 15
Popularity: 0.000140
First Submitted: 2015-10-18 23:40 (UTC)
Last Updated: 2021-05-25 15:22 (UTC)

Latest Comments

bidulock commented on 2021-05-25 12:20 (UTC)

Please add libxinerama to depends.

squalou commented on 2018-11-05 21:11 (UTC) (edited on 2018-11-05 21:11 (UTC) by squalou)

just to mention that upstream did publish a newer version, that changes the variables set when xrandr events are detected.

When it will be updated in aur, scripts using it may fail. A quick fix will be to add somehting like this :

if [ -z "${SRANDRD_ACTION}" ];then

SRANDRD_ACTION="${SRANDRD_OUTPUT} ${SRANDRD_EVENT}"

fi

Vrakfall commented on 2018-08-15 12:24 (UTC)

@breitj: That looks rather legitimate. The package is often installed by dependency of other common packages, hence probably why it was missing. :P

breitj commented on 2018-08-15 09:51 (UTC)

Hi, I think 'libxinerama' should be added as a dependency. Without it, the package fails to build on my system.

Vrakfall commented on 2016-11-21 07:34 (UTC)

There's actually someone who updated this here: https://github.com/jceb/srandrd