Package Details: sshexport 2.2-1

Git Clone URL: https://aur.archlinux.org/sshexport.git (read-only)
Package Base: sshexport
Description: Install your ssh keys on remote sites
Upstream URL: http://www.catb.org/~esr/sshexport
Licenses: BSD
Replaces: ssh-installkeys
Submitter: Dragonlord
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 11
Popularity: 0.000000
First Submitted: 2016-02-12 11:48
Last Updated: 2016-02-12 11:49

Latest Comments

Dragonlord commented on 2016-02-12 11:47

Starting version 2, this project has been renamed to sshexport.

2.0: 2016-01-18
Name change from ssh-installkeys to sshexport.
New -r option allows rotating keys on all sites in the saved configuration.
Passwords and non-default ports are remembered in the saved configuration.
Saved configuration file, if present, is checked for dangerous permissions.
Command now accepts multiple hostnames to update.
Makes ed25519 and RSA keys; DSA has been dropped.
Plays nicely with SELINUX on remote systems, restoring security context.

Chrissss commented on 2014-06-05 08:16

Besides being outdated, I get the following error message when I install the program...

==> Beginne build()...
xmlto man ssh-installkeys.xml
xmlto: /tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/ssh-installkeys.xml does not validate (status 3)
xmlto: Fix document syntax or use --skip-validation option
/tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/ssh-installkeys.xml:3: warning: failed to load external entity "/tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/docbook/docbookx.dtd"
"docbook/docbookx.dtd">
^
/tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/ssh-installkeys.xml:45: parser error : Entity 'mdash' not defined
<para>Note: this script does not parse your ssh configuration &mdash;
^
warning: failed to load external entity "/tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/docbook/docbookx.dtd"
validity error : Could not load the external subset "docbook/docbookx.dtd"
Document /tmp/yaourt-tmp-test/aur-ssh-installkeys/src/ssh-installkeys-1.8/ssh-installkeys.xml does not validate
Makefile:20: recipe for target 'ssh-installkeys.1' failed
make: *** [ssh-installkeys.1] Error 13

manveru commented on 2013-04-15 08:25

I've updated the PKGBUILD to 1.7: https://gist.github.com/manveru/5386685

Anonymous comment on 2010-11-04 19:32

upstream released 1.5.0