Package Details: steadyflow 0.2.0-4

Git Clone URL: https://aur.archlinux.org/steadyflow.git (read-only)
Package Base: steadyflow
Description: A download manager that aims for minimalism, ease of use, and a clean, malleable codebase
Upstream URL: https://launchpad.net/steadyflow
Licenses: GPL3
Conflicts: steadyflow-bzr
Submitter: zbito
Maintainer: M0Rf30
Last Packager: M0Rf30
Votes: 12
Popularity: 0.000643
First Submitted: 2010-09-18 15:22
Last Updated: 2015-06-17 14:32

Latest Comments

moridori commented on 2016-05-17 09:06

0.18: error: `ListStore' is an ambiguous reference between `GLib.ListStore' and `Gtk.ListStore'
private ListStore model;
^^^^^^^^^
Compilation failed: 1 error(s), 4 warning(s)
CMakeFiles/steadyflow.dir/build.make:86: recipe for target 'Steadyflow.Core/DownloadService.c' failed
make[2]: *** [Steadyflow.Core/DownloadService.c] Error 1
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/steadyflow.dir/all' failed
make[1]: *** [CMakeFiles/steadyflow.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2

cleocir commented on 2014-05-19 13:50

/tmp/yaourt-tmp-root/aur-steadyflow/src/steadyflow-0.2.0/Steadyflow/Services.vala:64.3-64.6: error: `exit' is an ambiguous reference between `GLib.Process.exit' and `Gtk.exit'
exit(1);
^^^^

cleocir commented on 2014-05-19 13:46

Compilation failed: 1 error(s), 20 warning(s)
CMakeFiles/steadyflow.dir/build.make:81: recipe for target 'Steadyflow.Core/DownloadService.c' failed
make[2]: *** [Steadyflow.Core/DownloadService.c] Error 1
CMakeFiles/Makefile2:63: recipe for target 'CMakeFiles/steadyflow.dir/all' failed
make[1]: *** [CMakeFiles/steadyflow.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2

k0Do commented on 2013-05-30 14:48

CMake Error at cmake/FindExtraDeps.cmake:11 (message):
libgee not found
Call Stack (most recent call first):
CMakeLists.txt:25 (find_package)

k0Do commented on 2013-05-30 14:46

libgee is missing in PKGBUILD as a required dependency

Barthalion commented on 2012-07-14 08:20

Of course you're right - fixed.

Jristz commented on 2012-07-09 17:07

sure that you need liunique and not libunique3 for wild a gtk3 package?

archtux commented on 2012-07-06 12:03

Proceed with installation? [Y/n] y
(1/1) checking package integrity [####################################################################] 100%
(1/1) loading package files [####################################################################] 100%
(1/1) checking for file conflicts [####################################################################] 100%
(1/1) upgrading steadyflow [####################################################################] 100%
usr/share/glib-2.0/schemas/net.launchpad.steadyflow.gschema.xml: Error on line 4 char 1: <enum id='finish-action'> already specified. This entire file has been ignored.

glib schemas not installed!

Anonymous comment on 2012-02-16 14:59

@dserban
There's a simple workaround: change all occurrences of ActionEntry into Gtk.ActionEntry in IndicatorController.vala

dserban commented on 2012-02-10 07:02

@ulke, please report this bug on Launchpad or directly to Maia Kozheva (logged into AUR as lucidfox, see her contact details below).

ulke commented on 2012-02-10 04:56

Does not build for me.

/tmp/yaourt-tmp-uli/aur-steadyflow/src/steadyflow-0.1.7/Steadyflow/IndicatorController.vala:60.10-60.20: error: `ActionEntry' is an ambiguous reference between `GLib.ActionEntry' and `Gtk.ActionEntry'
private ActionEntry[] actions = {
^^^^^^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
make[2]: *** [Steadyflow.Core/DownloadService.c] Error 1
make[1]: *** [CMakeFiles/steadyflow.dir/all] Error 2
make: *** [all] Error 2

dserban commented on 2011-07-22 18:46

OK. I'll add dconf to the "depends" array the next time around.

sonny commented on 2011-07-22 18:06

Dunno why but dconf is needed to save steadyflow settings.

sonny commented on 2011-05-09 14:04

Could you add libunique and cmake as dependencies?

dserban commented on 2011-05-08 10:12

Has anyone managed to get this to work without the libappindicator dependency?

Anonymous comment on 2011-05-06 10:25

Upstream here. The schema error is generated because it needs to run a command to regenerate glib schemas on install. Usually this is done automatically by the installer if you install directly to /usr, but if you're, say, building a binary package into a DESTDIR, you need to pass -DCOMPILE_GSETTINGS_ON_INSTALL=NO to cmake and then add a hook to call glib-compile-schemas /usr/share/glib-2.0/schemas on installation.

dej commented on 2011-03-13 16:39

needs cmake in make dependencies

Anonymous comment on 2011-02-08 07:04

Sucessfully installed but got error while trying to run.

GLib-GIO-ERROR **: Settings schema 'net.launchpad.steadyflow' is not installed

aborting...
Aborted

mar04 commented on 2010-12-14 18:35

It needs cmake and vala, not vala-devel.