Package Details: stem 1.4.1-2

Git Clone URL: https://aur.archlinux.org/stem.git (read-only)
Package Base: stem
Description: Python controller library for Tor
Upstream URL: https://stem.torproject.org/
Licenses: LGPL3
Submitter: Spider.007
Maintainer: Spider.007
Last Packager: Spider.007
Votes: 1
Popularity: 0.000048
First Submitted: 2013-03-28 17:26
Last Updated: 2015-09-30 08:17

Dependencies (2)

Required by (2)

Sources (1)

Latest Comments

thelinuxguy commented on 2016-01-04 09:58

oh, I just found out this is python3. Could you please make this a split package and rename it to python{-stem,2-stem}

thelinuxguy commented on 2016-01-04 09:49

The package should be renamed to python2-stem

mutantmonkey commented on 2015-09-23 04:29

This package is also missing a dependency on python, in addition to the other issues duelle and I have noted below.

duelle commented on 2015-09-13 20:47

The source (stem-1.4.1.tar.bz2) seems to be not available anymore under the given URL.
The correct one seems to be the following:
https://pypi.python.org/packages/source/s/stem/stem-1.4.1b.tar.bz2

mutantmonkey commented on 2015-06-08 01:40

Thanks for the package. Could you please consider adding PGP signature verification? It's as simple as adding the following two lines and updating the checksums.

source=("https://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.bz2"{,.asc})
validpgpkeys=('68278CC5DD2D1E85C4E45AD90445B7AB9ABBEEC6')

You'll need to import Damian's key before building, like so:
gpg2 --recv-key 68278CC5DD2D1E85C4E45AD90445B7AB9ABBEEC6

I would also suggest using a stronger hash algorithm than md5, like sha256 or sha512, as md5 is considered broken.

TrialnError commented on 2014-09-30 09:33

This PKGBuild isn't following the latest VCS-PKGBuild Guidelines
https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

And if there is no build process the build function should be renamed to package()