Package Details: step-cli-bin 0.13.3-1

Git Clone URL: https://aur.archlinux.org/step-cli-bin.git (read-only, click to copy)
Package Base: step-cli-bin
Description: A zero trust swiss army knife for working with X509, OAuth, JWT, OATH OTP, etc.
Upstream URL: https://smallstep.com/cli
Keywords: ca certificate-authority certificates go pki security security-tools tls x509
Licenses: Apache
Submitter: nazar554
Maintainer: dopey (nazar554, sourishkrout, maraino)
Last Packager: dopey
Votes: 2
Popularity: 0.002267
First Submitted: 2018-12-12 14:54
Last Updated: 2019-09-30 19:06

Latest Comments

dopey commented on 2019-09-21 08:09

sweet! sorry about that.

brbsix commented on 2019-09-21 07:15

@dopey That resolved it, thank you.

dopey commented on 2019-09-21 01:38

@brbsix still having issues with 0.13.2?

brbsix commented on 2019-09-20 00:27

I'm having issues updating version 0.13.1-2 of this package. I believe you need to update pkgrel=1 to pkgrel=2 in the PKGBUILD.

godeater commented on 2019-09-16 07:48

I'm getting a validity check failure on the step_0.13.0_linux_amd64.tar.gz file as of this morning.

The sha256sum I get for it is : e4a0f249de897fcd6ce6ea38d11e6d0af7c8bc9326f132aec4379f98e585fa83

and not : 0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5

as in the PKGBUILD.

nazar554 commented on 2018-12-17 16:26

@Azertyfun I will rename the step binary to step-cli, like upstream did in Debian package

Azertyfun commented on 2018-12-17 15:57

Hi! This package conflicts with step, a physics simulation software bundled with kde-applications-meta: https://www.archlinux.org/packages/extra/x86_64/step/

The workaround is simply to remove step (sudo pacman -R step kde-applications-meta kdeedu-meta). However, it would be nice if bin/step was bin/smallstep or something similar.

Cheers!