Package Details: stig 0.11.2a0-5

Git Clone URL: https://aur.archlinux.org/stig.git (read-only, click to copy)
Package Base: stig
Description: TUI and CLI client for the Transmission daemon
Upstream URL: https://github.com/rndusr/stig
Keywords: bittorrent terminal torrent transmission tui
Licenses: GPL
Submitter: kazuo
Maintainer: christian97
Last Packager: christian97
Votes: 9
Popularity: 0.54
First Submitted: 2017-01-26 01:03
Last Updated: 2020-08-06 12:12

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

BachoSeven commented on 2020-08-06 14:29

Thanks, I just noticed the updates.

christian97 commented on 2020-08-06 13:19

The maintainers of urwidtrees forgot to add the "python-mock" dependency on the latest update. They have just fixed it, so you probably need to wait for your mirror to sync the newest release of "python-urwidtrees". In the meanwhile, to solve the problem, you could just install "python-mock".

BachoSeven commented on 2020-08-06 13:03

Cannot launch last release:

Traceback (most recent call last): File "/usr/lib/python3.8/site-packages/stig/tui/main.py", line 60, in run tuiobjects.urwidloop.run() File "/usr/lib/python3.8/site-packages/urwid/main_loop.py", line 287, in run self._run() File "/usr/lib/python3.8/site-packages/urwid/main_loop.py", line 385, in _run self.event_loop.run() File "/usr/lib/python3.8/site-packages/stig/tui/urwidpatches.py", line 175, in run raise self._exc_info File "/usr/lib/python3.8/asyncio/events.py", line 81, in _run self._context.run(self._callback, self._args) File "/usr/lib/python3.8/site-packages/stig/client/poll.py", line 78, in reraise task.result() File "/usr/lib/python3.8/site-packages/stig/client/poll.py", line 89, in _poll_loop await self._poll_task File "/usr/lib/python3.8/site-packages/stig/client/poll.py", line 117, in _do_poll response = await self._request() File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/api_torrent.py", line 387, in torrents return await self._get_torrents_by_filter(keys, tfilter=torrents, File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/api_torrent.py", line 343, in _get_torrents_by_filter response = await self._get_torrents_by_ids(keys=tfilter.needed_keys, File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/api_torrent.py", line 316, in _get_torrents_by_ids response = await self._request_torrents(fields, ids) File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/api_torrent.py", line 235, in _request_torrents raw_tlist = await self.rpc.torrent_get(fields=fields) File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/rpc.py", line 457, in request await self.connect() File "/usr/lib/python3.8/site-packages/stig/client/aiotransmission/rpc.py", line 323, in connect import aiohttp File "/usr/lib/python3.8/site-packages/aiohttp/init.py", line 223, in <module> from .worker import GunicornWebWorker, GunicornUVLoopWebWorker # noqa File "/usr/lib/python3.8/site-packages/aiohttp/worker.py", line 11, in <module> from gunicorn.config import AccessLogFormat as GunicornAccessLogFormat File "/usr/lib/python3.8/site-packages/gunicorn/config.py", line 20, in <module> from gunicorn import version, util File "/usr/lib/python3.8/site-packages/gunicorn/util.py", line 26, in <module> import pkg_resources File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3257, in <module> def _initialize_master_working_set(): File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3240, in _call_aside f(args, **kwargs) File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3269, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 582, in _build_master ws.require(requires) File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 899, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 785, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'mock' distribution was not found and is required by urwidtrees

pepper_chico commented on 2020-07-06 19:26

@chirstian97, it worked, thx.

christian97 commented on 2020-07-06 17:22

Thank you for reporting the problem, it should now be solved. Let me know if it works.

pepper_chico commented on 2020-07-06 13:40

Latest sources have an issue that it comes with a .python-version pyenv leftover file. It won't build if you have pyenv installed but don't have the python version listed in there installed in pyenv.

The package should not invoke pyenv if it's present.

pepper_chico commented on 2018-02-26 20:46

Thanks @kazuo

kazuo commented on 2018-02-26 19:48

An interim solution that could be done on this package, is to patch it to allow the use of versions >=1.0.2. The reason stig upstream bumped the version to 1.0.3dev0 only affects pip installs [1], if I understand correctly.

I just did this with -2 version of this packages, now either community/python-urwidtrees or aur/python-urwidtrees works. I tested it and seems to work ok with any version.

I hope this solution is acceptable until a new release of urwidtrees is tagged upsteam.

1: https://github.com/rndusr/stig/pull/7#issuecomment-275389365

kazuo commented on 2018-02-26 18:56

The current status of the python-urwidtrees is a little messy [1]. The aur version is updated to the pypi version 1.3.0.dev0 [2], this is not a upstream tagged release, this is the one used by stig.

You could use either aur/python-urwidtrees or aur/python-urwidtrees-git. I can change the dep of stig to the git version, but would be better if this is fixed either on the community/python-urwidtrees or, much better, if a new tagged 1.3.0 can be pushed upstream.

Again, I don't think that here is the best place to fix this.

1: https://github.com/pazz/urwidtrees/issues/37

2: https://aur.archlinux.org/packages/python-urwidtrees/

pepper_chico commented on 2018-02-26 17:15

current install got broken again because python-urwidtrees is now picked from community with a version prior to the required one by stig when running it.