Package Details: stopmotion 0.8.5-1

Git Clone URL: https://aur.archlinux.org/stopmotion.git (read-only, click to copy)
Package Base: stopmotion
Description: Stop motion animation creation program
Upstream URL: http://linuxstopmotion.org/
Licenses: GPL2
Submitter: mgrimes
Maintainer: FabioLolix
Last Packager: City-busz
Votes: 13
Popularity: 0.000608
First Submitted: 2007-05-31 03:54
Last Updated: 2020-06-16 14:34

Latest Comments

« First ‹ Previous 1 2

tgirod commented on 2012-10-17 08:20

missing build dependency : libtar

mgrimes commented on 2012-09-04 13:09

I just uploaded a new version with a patch that addresses the problem. Seems newer gcc removed some includes from the standard library headers. The patch adds includes for unistd.h. A similar problem was discussed here:

https://bbs.archlinux.org/viewtopic.php?id=139630

And the debian folks addressed it here:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667383

I was also able to remove a couple of (I believe) unnecessary dependancies. Please let me know if anyone notice a problem.

wasperen commented on 2012-09-03 18:30

Fails for me too:

src/presentation/frontends/qtfrontend/mainwindowgui.cpp: In member function ‘void MainWindowGUI::updateMostRecentMenu()’:
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1117:21: error: ‘R_OK’ was not declared in this scope
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1117:25: error: ‘access’ was not declared in this scope
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1129:22: error: ‘R_OK’ was not declared in this scope
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1129:26: error: ‘access’ was not declared in this scope
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1141:21: error: ‘R_OK’ was not declared in this scope
src/presentation/frontends/qtfrontend/mainwindowgui.cpp:1141:25: error: ‘access’ was not declared in this scope
make: *** [mainwindowgui.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...

on X86_64, pretty much up to date with latest package releases

Anonymous comment on 2012-04-15 14:54

It fails for me, on x686_32 with:
make: *** [mainwindowgui.o] Error 1
==> ERROR: A failure occurred in build().

mgrimes commented on 2012-01-04 16:43

Thanks for the comments. I just got the out-of-date notice, I hadn't seen them before. I am updating the PKGBUILD to conform to the $srcdir and $pkgver style, etc. I've also included a patch to add the X11 lib. It compiles fine for me now.

tlvince commented on 2012-01-04 00:11

This fails to build with the following error:

/usr/bin/ld: frameview.o: undefined reference to symbol 'XSync'

There is a corresponding [debian bug report][1] that mentions a patch, which I tried to no avail.

I have however updated the style of the PKGBUILD. [Here's a diff][2].

[1]: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=606721
[2]: https://gist.github.com/1557697

fukawi2 commented on 2010-10-25 08:41

a) I can confirm this working on x86_64 - please add to the arch array
b) You should change $startdir vars to $srcdir and $pkgver
c) make can't handle running parallel jobs to build this package. You need to pass -j1 to the make commands to make sure it only does 1 job at a time :)