Package Details: strongswan-pkcs11 5.6.3-2

Git Clone URL: https://aur.archlinux.org/strongswan-pkcs11.git (read-only)
Package Base: strongswan-pkcs11
Description: The best OpenSource IPsec implementation with PKCS11 support
Upstream URL: http://www.strongswan.org
Licenses: GPL
Conflicts: openswan, strongswan
Provides: strongswan=5.6.3-2
Submitter: phsm
Maintainer: phsm
Last Packager: phsm
Votes: 2
Popularity: 0.490320
First Submitted: 2016-06-21 17:05
Last Updated: 2018-09-18 08:17

Latest Comments

phsm commented on 2018-09-18 08:22

Hi, -fixed typo in conflicts section -also bumped to version 5.6.3.

Could you check if it builds?

lordchaos commented on 2018-09-17 15:20

There seems to be a typo in the PKGBUILD:

conflicts=('openswan', "${pkgname/-pkcs11}") <-- the comma should be removed

Also, the package doesn't seem to build:

utils/utils/memory.h: In function ‘memwipe_inline’: utils/utils/memory.h:99:15: error: ‘uintptr_t’ undeclared (first use in this function); did you mean ‘uint64_t’? for (i = 0; (uintptr_t)&c[i] % sizeof(long) && i < n; i++)

phsm commented on 2016-09-22 09:30

Fixed, thanks!

bidulock commented on 2016-09-22 08:05

strongswan-pkcs11 E: Dependency pam detected and not included (libraries ['usr/lib/libpam.so.0'] needed in files ['usr/lib/ipsec/plugins/libstrongswan-xauth-pam.so'])

Please add 'pam' to depends=()