Package Details: sublime-text-dev 4.4122-1

Git Clone URL: https://aur.archlinux.org/sublime-text-dev.git (read-only, click to copy)
Package Base: sublime-text-dev
Description: Sophisticated text editor for code, html and prose - dev build
Upstream URL: https://www.sublimetext.com/dev
Licenses: custom
Conflicts: sublime-text
Provides: sublime-text
Submitter: realitygaps
Maintainer: SunRed (edub4rt)
Last Packager: SunRed
Votes: 527
Popularity: 0.136013
First Submitted: 2011-11-10 18:32
Last Updated: 2021-11-03 15:22

Pinned Comments

SunRed commented on 2021-05-21 13:04

To cut down the amount of packages to be maintained and to decrease confusion, this package is now used for the 'dev' branch of Sublime Text that is kept up to date with the most recent version. Users who want to stay on the latest legacy versions or the most recent stable release should stick to the respective stable release packages (sublime-text-3, sublime-text-4) or use the official repos provided by Sublime Text.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

thamaraiselvam commented on 2018-05-22 06:19

nasr18 I got the same problem too. shows 3143 build always

nasr18 commented on 2018-05-22 06:18

whenever i try to update my sublime text editor, it's showing me 3143 build. I need latest build. what i have to do?

friday13 commented on 2018-05-08 06:06

Version: Build 3170

thamaraiselvam commented on 2018-05-08 05:47

Latest version 3170 Please? 7 May 2018

Plexcon commented on 2018-05-07 13:08

Update Version: Build 3170, please

sender commented on 2017-11-09 14:25

Corrected. Package has been downgraded to build 3143. Excusez, error on my side.

Triodes commented on 2017-11-09 09:26

As with the upgrade to 3144, the current version 3153 is also not usable without a license key.

TomaszGasior commented on 2017-11-08 19:54

Will this package contain stable sublime text 3 (as before) or sublime text 3 dev (as is suggested by package name)?

sender commented on 2017-09-19 09:03

@nesadi Correct. I've overlooked this before. Package has been downgraded to build 3143.

nesadi commented on 2017-09-19 07:03

The package shouldn't have been updated to 3144, it's currently only for licensed users (see http://www.sublimetext.com/3dev vs http://www.sublimetext.com/3 which is 3143 instead). So now this package is directly asking for a license key and doesn't allow usage without it, which shouldn't happen.

For anybody trying to install sublime-text-dev at the moment, you're going to have to change the PKGBUILD before doing so.

Go to line 5, change 3144 to 3143.
You'll also have to change the sha256 checksums at lines 22 or 23, depending on whether you're installing the x32 or x64 packages
x32: b1ecc4b70d66b9236b876f1913c4094b6dd51436e45c74883ba70a1939e9f735
x64: 9ce120c4f28b239d3b3860ee672d9d87e1397a4c08ee6c4e62fd6e261a296519

I just did this myself and it works fine. You can verify the checksums by downloading the package(s) from https://www.sublimetext.com/3 and running sha256sum on it.