Package Details: sublime-text-dev 3.3114-1

Git Clone URL: https://aur.archlinux.org/sublime-text-dev.git (read-only)
Package Base: sublime-text-dev
Description: Sophisticated text editor for code, html and prose - dev build
Upstream URL: http://www.sublimetext.com/3
Licenses: custom
Conflicts: sublime-text-nightly
Provides: sublime-text-nightly
Submitter: realitygaps
Maintainer: sender
Last Packager: sender
Votes: 373
Popularity: 9.431796
First Submitted: 2011-11-10 18:32
Last Updated: 2016-05-13 09:34

Pinned Comments

sender commented on 2016-02-17 08:37

There seems to be a lot of confusion about the ST packages. This is because the author switched names for branches. Packages:

Sublime Text 3 Beta
- package: sublime-text-dev
- Upstream: www.sublimetext.com/3

Sublime Text 3 Dev (used to be called nightly)
- package: sublime-text-nightly
- upstream: www.sublimetext.com/3dev
- NOTE: for registered users only

If you want the absolute latest get *sublime-text-nightly*. Note that you have to be licensed to use this!

Latest Comments

sender commented on 2016-05-24 10:09

@killua99 Please read the pinned comment at the top.

killua99 commented on 2016-05-24 09:09

How can I build the latest version?

matmunn14 commented on 2016-05-13 07:20

A new version has been released (build 3114).

sender commented on 2016-05-01 11:03

@Light2Yellow Please use this board for matters concerning the AUR package. Use https://forum.sublimetext.com/ for questions about plugins or the software itself. BTW you are probably looking for https://packagecontrol.io/packages/PKGBUILD

Light2Yellow commented on 2016-04-29 16:35

Are there any plugins to support pkgbuild syntax highlighting?

sender commented on 2016-04-18 22:15

@Rodori I agree with what @Marcel_K wrote. This package is meant to be installed side-by-side with ST2. You can fix your situation permanently in several ways on your own system.

Marcel_K commented on 2016-04-18 16:29

Technically, that's possible, but you shouldn't install files during post_install, as those are not tracked by pacman. What's more difficult, is that it is allowed to install ST2 after you installed ST3, which either isn't possible then, because of the symlink, or it will simply overwrite the symlink, which is not what you want: when uninstalling ST3, post_remove will delete `subl`, assuming it still is the symlink created during post_install. This seems like an edge case, but it really is undesired behaviour.

Rodori commented on 2016-04-18 13:56

Please, could you include a function to check whether you have Sublime Text 2 installed or not and create a symlink from `subl` to `subl3` if possible?

It's because I always have to do it manually, and I have aliases pointing to "subl" instead of "subl3". I don't know if there's any way to specify that during the `makepkg` process though.

Thank you in advance.

sender commented on 2016-04-17 12:26

@nmstoker It's a very unfortunate situation. No idea on the timing. You can raise this issue upstream. BTW nothing wrong with moving to the -nightly ;)

nmstoker commented on 2016-04-16 20:41

Hi @sender - any idea on the timing that Beta might move to build 3109 (or above)? The SSL error is causing me a few issues, but I suspect I probably shouldn't just switch to Dev (-nightly) especially if it's coming any time soon.

gadicc commented on 2016-03-30 16:36

thanks @sender! and for your ongoing maintenance of this package.

sender commented on 2016-03-30 15:35

@gadicc and others: the ssl-linux issue has been resolved in ST3 build 3109 (available via the nightly channel: https://aur.archlinux.org/packages/sublime-text-nightly). Thanks Esgariot.

gadicc commented on 2016-03-12 07:11

For me, some plugins (that depend on SSL) stopped working on updating from openssl 1.0.2.f-1 -> 1.0.2.g-3.

No error messages outside the console, but there I found messages about being unable to import _ssl, and upon manually adding the "Linux SSL" package (in sublime), errors about OPENSSL_1.0.0 not being defined in libssl1.0.0.

The quick fix was to downgrade with `pacman -U /var/cache/pacman/pkg/openssl-1.0.2.f-1-x86_64.pkg.tar.xz`, reload sublime, and everything worked again. Since this was a minor update, I imagine existing libraries should still work? Maybe someone who understands OpenSSL better can open an appropriate bug report, if relevant.

sender commented on 2016-02-17 08:37

There seems to be a lot of confusion about the ST packages. This is because the author switched names for branches. Packages:

Sublime Text 3 Beta
- package: sublime-text-dev
- Upstream: www.sublimetext.com/3

Sublime Text 3 Dev (used to be called nightly)
- package: sublime-text-nightly
- upstream: www.sublimetext.com/3dev
- NOTE: for registered users only

If you want the absolute latest get *sublime-text-nightly*. Note that you have to be licensed to use this!

sender commented on 2016-02-09 09:12

Updated to 3103! First movement in the (original) dev branch since March 2015. For intermediate updates see package https://aur.archlinux.org/packages/sublime-text-nightly. Note that this version is only available to licensed users only.

GomZik commented on 2016-02-09 08:27

Hi, here is my patch for new build

http://pastebin.com/PmN1ZU2B

lukasw commented on 2016-02-09 03:44

Build 3103 has just been released, see https://www.sublimetext.com/blog/articles/sublime-text-3-build-3103

zerophase commented on 2016-01-23 06:05

I think it's that the provides and conflicts are mixed up for the two sublime-text-nightly and dev.

sublime-text-nightly:
Conflicts: sublime-text-dev
Provides: sublime-text-dev

sublime-text-dev:
Conflicts: sublime-text-nightly
Provides: sublime-text-nightly

Marcel_K commented on 2016-01-08 10:30

That's a problem with yaourt. I can't see how that is related to this package. Please file a bug at yaourt's page.

zerophase commented on 2016-01-08 05:50

If I try to download sublime-text-nightly, with yaourt -S --noconfirm this package gets downloaded instead.

sender commented on 2015-12-16 13:09

@Marcel_K Thanks!

Marcel_K commented on 2015-12-14 00:29

Done: http://www.sublimetext.com/forum/viewtopic.php?f=3&t=22393

sender commented on 2015-12-13 22:52

@Marcel_K Personally I have no affinity with this layer of tech or any authority in the development process of ST. If you feel you can escalate this in the right way to the developer, you have my support ;) The post says that the old ABI will still be available, so in the meantime we are probably fine.

Marcel_K commented on 2015-12-12 20:14

According to the script in [1], the binaries should be recompiled. However, this package relies on pre-compiled binaries. Should this be escalated to the developer?

[1] https://lists.archlinux.org/pipermail/arch-dev-public/2015-December/027597.html

morion commented on 2015-12-07 03:50

Thank you for this package!

sender commented on 2015-11-07 14:00

@horosgrisa are you sure you are running the sublime-text-dev package, and the latest version? I don't get how you could get `WM_CLASS(STRING) = "sublime_text", "Sublime_text"`. Anyway, it doesn't seem to be possible to specify multiple values for `StartupWMClass`.

horosgrisa commented on 2015-11-05 06:44

@sender Now in KDE 5 ST window shows in another icon. `xprop WM_CLASS` returns `WM_CLASS(STRING) = "sublime_text", "Sublime_text"`. I changed `StartupWMClass=subl3` to `StartupWMClass=sublime_text` and now all work normal.

Bradan commented on 2015-11-01 16:06

Icon files are conflicting here, too. The package "sublime-text" owns the icons with "-", too.

NoMore66201 commented on 2015-09-26 08:28

@sender now is ok! I don't now why but I needed to do the same thing for the android studio .desktop file

sender commented on 2015-09-25 15:52

@NoMore66201 I checked using `xprop WM_CLASS`, but this already returns `WM_CLASS(STRING) = "subl3", "Subl3"`. I implemented your suggestion anyway, can you test?

sender commented on 2015-09-25 15:52

@NoMore66201 I checked using `xprop WM_CLASS`, but this already returns `WM_CLASS(STRING) = "subl3", "Subl3"`. I implemented your suggestion anyway, can you test?

NoMore66201 commented on 2015-09-25 10:12

In gnome 3.16 open ST window shows in another icon, you should add StartupWMClass=subl3 to the .desktop file :)

sender commented on 2015-09-01 16:57

@spelufo: Check the sublime-text-nightly package for build 3095 (for registered users only).
@Marcel_K thanks!

Marcel_K commented on 2015-09-01 15:43

The .SRCINFO file is only read by aurweb, so no need to update that one. You probably entered "sublime_text_3.desktop,fix_umask.so,subl3" in one line this way, so makepkg thinks that line represents one file, not three separate ones. Put every file on a separate line and you'll be fine.

BTW, the bug is fixed in build 3088.

spelufo commented on 2015-09-01 14:28

There is a terrible bug in thes version of sublime that sets the umask to 0, so all files you create from sublime are world writable: https://github.com/SublimeTextIssues/Core/issues/239

I used this (https://gist.github.com/stbuehler/8540197) workaround (not by me) to fix it. I think this package should apply it. I'm trying to add the files, but it tells me:

==> Retrieving sources...
==> ERROR: sublime_text_3.desktop,fix_umask.so,subl3 was not found in the build directory and is not a URL.

I've run mksrcinfo, which updates the .SRCINFO file but makepkg still complains.

prash commented on 2015-06-05 11:51

I was browsing Sublime Text's forums yesterday and came across their dev build, 3092. I marked AUR package out of date, though I later realized I shouldn't have. Only paid customers have access to the dev builds. I made this mistake because the AUR package is called "-dev". Please note that their dev builds (https://www.sublimetext.com/3dev) are quite different from their beta builds (https://www.sublimetext.com/3).

To prevent confusion, this package should be renamed to sublime-text-beta.

Marcel_K commented on 2015-05-18 08:59

Not in my case:

sublime-text /usr/share/icons/hicolor/128x128/apps/sublime_text.png
[etc.]

sublime-text-dev /usr/share/icons/hicolor/128x128/apps/sublime-text.png
[etc.]

tsouzar commented on 2015-05-18 05:39

Icons from this package conflicts with the ones provided by sublime-text (v2).

tsouzar commented on 2015-05-18 05:08

Right upstream URL is http://www.sublimetext.com/3dev.

Marcel_K commented on 2015-04-27 18:18

It would be helpful if you use the English version of makepkg. And as far as I can see, there's no PGP signature provided, so there's no need to read a remote key.

Whoever flagged this out-of-date: it's not.

man1gold commented on 2015-04-27 18:01

(1/1) verificando chaves no chaveiro [###############################################################] 100%
baixando chaves necessárias...
erro: key "4D09DB8DE73F68F6" could not be looked up remotely
erro: faltando chave necessária no chaveiro
erro: falha em submeter a transação (erro inesperado)

What can be? My watch is ok ...

Marcel_K commented on 2015-04-01 22:06

Please run

pacman -Qo /usr/share/icons/hicolor/16x16/apps/sublime-text.png

to see which package owns that file. In my case, it's this package. FYI, sublime-text creates the same file with an underscore instead of a hyphen.

lucacerone commented on 2015-04-01 21:24

I had one issue, the installation was failing because PKGBUILD
was trying to create a link /usr/share/icons/hicolor/16x16/apps/sublime-text.png
which already existed.

I changed the ln command to /usr/share/icons/hicolor/16x16/apps/sublime-text-dev.png and the installation worked flawlessly.

I have both sublime-text and sublime-text-dev and they seem to work just fine.

sender commented on 2015-03-29 18:23

@Marcel_K Done. Actually you are right, I did this back when I still ran both versions alongside eachother. Thanks.

Marcel_K commented on 2015-03-29 09:51

Indeed, and I tested this (I currently have installed 2 and 3 alongside eachother, without problems). I thought you (or a previous maintainer) deliberately made all file names and pathes different from sublime-text. Just compare them: http://pastebin.com/PykXT2hy

sender commented on 2015-03-28 15:29

@Marcel_K So you say there is no need for the conflict/provide clauses with package sublime-text, and you have tested this? If no objections (anyone?) I will make the change. Thanks for looking into this.

Marcel_K commented on 2015-03-26 14:56

That's probably a problem upstream. Head over to the forum to ask for help: http://www.sublimetext.com/forum/

@Sander: why does this package still conflict with sublime-text?

Xenock commented on 2015-03-26 14:04

Hi!
I have problems with the last Build, "sublime-text-dev 3.3083-1".
When sublime is started, two processes goes more than 90% of my cpu.
My system is a x64.

Thanks in advance.

ali commented on 2015-03-26 09:50

Build 3083 out
Release Date: 26 March 2015

toddpi314 commented on 2015-03-24 13:40

Confirmed success install of 3080 on arch 2015.03.01

Marcel_K commented on 2015-03-24 10:44

About the conflict: why? I've already installed 2 and 3 alongside eachother without issues at all. Moreover, all filenames are different, like using hyphens vs. underscores. E.g.:

usr/share/icons/hicolor/128x128/apps/sublime_text.png (2)
usr/share/icons/hicolor/128x128/apps/sublime-text.png (3)

If we replace 2 by 3, we can ignore those things and even rename script subl3 to subl. But I slightly prefer to have packages that can be installed without conflict alongside eachother.

vohof commented on 2015-03-24 06:12

Build 3080 is out! :D

sender commented on 2015-03-23 12:29

@goetzc valid point, added to 'conflicts' & 'provides'.

goetzc commented on 2015-03-21 17:56

Hi, this PKGBUILD should conflict with sublime-text or install the icons in another location:

error: failed to commit transaction (conflicting files)
sublime-text-dev: /usr/share/icons/hicolor/128x128/apps/sublime-text.png exists in filesystem
...

Manouchehri commented on 2015-03-11 21:10

Sorry, I marked it as out of date before I saw your comment. Please ignore it.

sender commented on 2015-03-06 12:26

@Manouchehri this is the nightly build, and available to registered users only. Package: https://aur.archlinux.org/packages/sublime-text-nightly/

Manouchehri commented on 2015-03-06 11:38

md5sum
4e5859214df6e64472448fb8c3a1e9b8 sublime_text_3_build_3074_x64.tar.bz2

sha512sum
6ce128ffa7297286267572b16a57318aeaaf29ba56102e7d4705900c82ece79d5524b717928f67bded8c5195d3e9da28073c275fd5b0b341d130c764bab314fc sublime_text_3_build_3074_x64.tar.bz2

Marcel_K commented on 2015-02-19 16:22

That is a development build and already available at https://aur.archlinux.org/packages/sublime-text-nightly/

barton commented on 2015-02-19 08:22

3.3070 is now available!!! Great to see some action over ther at ST!
http://c758482.r82.cf2.rackcdn.com/sublime_text_3_build_3070_x64.tar.bz2

Firef0x commented on 2015-02-17 17:13

Hello, @knight_corvi !

Would you please test whether it solved by adding the following line:

https://github.com/archlinuxcn/repo/blob/master/sublime-text-dev-imfix/sublime_text_3.sh#L11

Yours sincerely.

Firef0x commented on 2015-02-17 17:06

Hello, @knight_corvi !

I'm interesting in your issue and want to fix it in https://aur.archlinux.org/pkgbase/sublime-text-dev-imfix/. But it is

WM_CLASS(STRING) = "sublime_text", "sublime-text"

in my environment with latest package 'sublime-text-dev'. Are you sure your solution is general available?

Yours sincerely.

Marcel_K commented on 2015-02-08 22:47

Please stop commenting on new builds this package isn't adressing.

sender commented on 2015-02-07 15:32

Nightly 3.3069-1 is available: https://aur.archlinux.org/packages/sublime-text-nightly (license required).

adonisk commented on 2015-02-07 14:56

Build 3069 is out

zegAnjer commented on 2015-02-06 12:13

@sender
There is a button to flag packages out off date. This way you don't flood inboxes..

sender commented on 2015-02-04 10:16

Nightly 3.3069-1 is available: https://aur.archlinux.org/packages/sublime-text-nightly (license required).

sender commented on 2015-02-03 09:11

Nightly 3.3068-1 is available: https://aur.archlinux.org/packages/sublime-text-nightly (license required).

sender commented on 2015-01-31 23:50

Again, see https://aur.archlinux.org/packages/sublime-text-nightly for the latest nightly build (3067 as of now).

diggit commented on 2015-01-31 23:24

new version available: 3.3067, md5sum f79ce095e1fec61d83e4b9e173077259
WARNING: license key is required!!!

diggit commented on 2015-01-31 23:20

new version available: 3.3067, md5sum f79ce095e1fec61d83e4b9e173077259

diggit commented on 2015-01-31 23:19

last version is 3.3067, md5sum f79ce095e1fec61d83e4b9e173077259

knight_corvi commented on 2015-01-27 23:42

I used to had the following problem in GNOME 3,
https://bbs.archlinux.org/viewtopic.php?pid=1497150

to solve it I modified the .desktop file to include:

StartupWMClass=subl3

under the Desktop Entry tag.

klingt.net commented on 2014-12-23 19:05

The downtime seems to be over, links are working again.

klingt.net commented on 2014-12-22 16:26

It seems that all links to the normal builds on http://www.sublimetext.com/3 are broken. Luckily the dev-builds seem to be still online http://www.sublimetext.com/3dev.

sender commented on 2014-12-12 08:50

@vohof What makes you think that? ST is provided "as is", no changes.

vohof commented on 2014-12-12 05:03

Why is multiple selection missing in this build?

sender commented on 2014-07-14 19:05

@Kuci please see https://aur.archlinux.org/packages/sublime-text-nightly. And you DO need a license to run this build.

Kuci commented on 2014-07-14 19:01

The latest publicly available dev build is 3062: http://c758482.r82.cf2.rackcdn.com/sublime_text_3_build_3062_x64.tar.bz2

sender commented on 2014-07-11 16:48

@Se7enTime: you probably need to end the previous line with a comma.

Se7enTime commented on 2014-07-10 16:52

Error trying to parse settings: Unexpected character, expected a comma or closing bracket in Packages/User/Preferences.sublime-settings:4:2

error when add

"update_check": false

sender commented on 2014-06-20 19:52

@01walid Are you sure? The most recent build on http://www.sublimetext.com/3 is than 3059. Build 3062 is for registered users only (and packaged in https://aur.archlinux.org/packages/sublime-text-nightly).

01walid commented on 2014-06-20 18:39

There's new public beta version available, an update would be much appreciated :)

Firef0x commented on 2014-05-19 14:31

Off-topic Help

The following is about the package sublime-text-dev-imfix. I'm very sorry to bother you.
https://aur.archlinux.org/packages/sublime-text-dev-imfix/

Recently I found that someone has fixed the input method bug(unofficially), here is the detail:
http://whitequark.org/blog/2014/04/14/xcompose-support-in-sublime-text/

Unfortunately, I don't understand it~~

I've uploaded the PKGBUILD in GitHub. Could any geek buddy give me a pull request about your new solution? Many thx !!!!!!

Here is:
https://github.com/Firef0x/AUR-Firef0x/tree/master/sublime-text-dev-imfix

Firef0x commented on 2014-05-19 14:27

Off-topic Help

Recently I found that someone has fixed the input method bug(unofficially), here is the detail:
http://whitequark.org/blog/2014/04/14/xcompose-support-in-sublime-text/

Unfortunately, I don't understand it~~

I've uploaded the PKGBUILD in GitHub. Could any geek buddy give me a pull request about your new solution? Many thx !!!!!!

Here is:
https://github.com/Firef0x/AUR-Firef0x/tree/master/sublime-text-dev-imfix

Firef0x commented on 2014-05-18 18:30

Off-topic Help

Recently I found that someone has fixed the input method bug(unofficially), here is the detail:
http://whitequark.org/blog/2014/04/14/xcompose-support-in-sublime-text/

Unfortunately, I don't understand it~~ Could any volunteer post your new solution in comments of https://aur.archlinux.org/packages/sublime-text-dev-imfix/ ?

AlexandrePTJ commented on 2014-05-12 19:01

Ok sorry for the confusion. Thanks.

sender commented on 2014-05-09 16:17

@Alex2101 The version you link to is _available to registered users only_ and the AUR package can be found here: https://aur.archlinux.org/packages/sublime-text-nightly

This packages follows another ST3 channel (http://www.sublimetext.com/3) and is uptodate.

AlexandrePTJ commented on 2014-05-09 16:13

New revision is now 3062.
Updated PKGBUILD is here : http://pastebin.com/egcbM4DX

sender commented on 2014-03-21 08:54

Looking for a more recent build? Check: https://aur.archlinux.org/packages/sublime-text-nightly/

krisanalfa commented on 2013-12-18 06:36

New revision was here

[x64] http://c758482.r82.cf2.rackcdn.com/sublime_text_3_build_3059_x64.tar.bz2
[x32] http://c758482.r82.cf2.rackcdn.com/sublime_text_3_build_3059_x32.tar.bz2

MD5SUM
[x64] 9fd1828ef4bc71f375b872eb139e9eba
[x32] 8d9f21fedb4a7b73137e9f58bc817b98

Please update, thanks ;)

r-b commented on 2013-11-07 19:18

@orschiro it was exactly this one https://github.com/wbond/sublime_package_control/issues/532
but setting LANG=en_US.UTF-8 in /etc/locale.conf solved it ;)

orschiro commented on 2013-11-06 13:45

@r-b

Where do you get that error and what is the exact message?

r-b commented on 2013-11-06 13:44

If anyone gets LANG=en_US.UTF-8 error, check if LANG environment variable is properly set up

sender commented on 2013-11-04 14:54

Looking for a more recent build? Check: https://aur.archlinux.org/packages/sublime-text-nightly/

husam212 commented on 2013-10-18 00:07

So I took a look at PKGBUILD to know if this is a duplicate of beta/dev, I found that it does some hex editing on a binary file "sublime_text" to make it accept fake license, dunno if this patch is legal to be included.

Firef0x commented on 2013-10-16 11:11

To anyone who encounters fcitx crash problem, pls feel free to try the following package:
遇到fcitx闪退问题的同志,请试一下以下包:
https://aur.archlinux.org/packages/sublime-text-dev-imfix/

Binary build is available in :
打好的包在:
http://pan.baidu.com/s/1ghBA6

neng commented on 2013-09-29 23:46

After investigation, it seems the problem is related to virtualbox-guest-modules:. The folder problem in the side bar only occurred in my virtualboxed Archlinux. In a real Archlinux installaion on a physical machine, sublime text is running fine. Sorry for the confusion.

neng commented on 2013-09-29 19:30

I've tried on linux-3.11.2-1, after rebuilding sublime. Still the same. I've again have to downgrade to linux-3.10.10-1.

Only me got this kind of problem?

sender commented on 2013-09-20 07:09

@neng I'll run a test myself, but please report this also at http://www.sublimetext.com/forum/

neng commented on 2013-09-20 07:07

After Linux upgrade to 3.11.1-1, Sublime failed to load folders in the side bar. I have to downgrade Linux back to 3.10.10-1. Could you please check? Thanks.

skarphace commented on 2013-09-04 14:47

Anyone seeing problems with LANG=en_US.UTF-8 not working properly?

sender commented on 2013-08-14 12:04

@simon04 AFAICS this is a duplicate of https://aur.archlinux.org/packages/sublime-text-dev.

@taylorchu What's the plan? :)

sender commented on 2013-07-04 08:43

@orschiro No. You will have to install the ST3 version of the plugins you are using, if available. You can find a list of ST3 ready plugins here: https://github.com/wbond/sublime_package_control/wiki/Sublime-Text-3-Compatible-Packages

orschiro commented on 2013-07-04 08:24

@sender

Can I switch from ST2 to ST3 without losing my plugins and configuration?

simon04 commented on 2013-06-28 19:44

How does this package relate to sublime-text-dev or sublime-text-nightly? If it is a duplicate, please file a deletion request via aur-general@archlinux.org

sender commented on 2013-06-28 17:26

To anyone who is still looking for ST2, please use: https://aur.archlinux.org/packages/sublime-text

sender commented on 2013-06-28 17:25

Starting today this package will follow the http://www.sublimetext.com/3/ channel, which provides dev versions of the upcoming ST3.

The sublime-text-nightly package will keep following the http://www.sublimetext.com/3dev/ channel which provides dev versions available to registered users only.

sender commented on 2013-06-28 12:39

@tang0th67 Thanks for the notice. I've updated the ST3 nightly package to 3047, see: https://aur.archlinux.org/packages/sublime-text-nightly/
Makes sense to update this package in the future according to the ST3 dev channel for non-paying users. Shouldn't be too long before I can do this.

tang0th67 commented on 2013-06-28 12:26

Sublime Text 3 beta (as of build 3047) is now available to the public (i.e non paying users), should it be updated here or in another package?

sender commented on 2013-06-28 11:48

See https://aur.archlinux.org/packages/sublime-text-nightly/ for the Sublime Text 3 Nightly version (http://www.sublimetext.com/3dev).

sender commented on 2012-11-26 20:38

@gamezelda I've incorporated your input. Thanks!

gamezelda commented on 2012-11-24 14:55

For some reason, if I open a file from my file manager (PCManFM) with this package, Sublime Text opens but with an empty file. I found a solution/workaround by using %F instead of %U in the Exec= line of the .desktop file. Otherwise, this package works file, thanks.

temoto commented on 2012-07-05 20:19

2.0 is out

Hspak commented on 2012-04-24 00:38

I found out there is a preferences file in the Vintage package where you can configure this.

sender commented on 2012-04-23 20:00

@Hspasta see the forum for support on Sublime Text itself: http://www.sublimetext.com/forum/

Hspak commented on 2012-04-23 19:32

In the changelog for build 2915, it says that Ctrl+D and Ctrl+U were added. Ctrl+U is still undo and Ctrl+D is still select word. Is this the expected behavior? I would like my half jumps.

sender commented on 2012-03-21 07:48

NOTE on nightly, dev and stable build numbers: nightly builds always have the latest changes even though the build number on a dev or stable build can be larger. Note from the author of Sublime Text:

"The contents of 2188 and 2190 are the same, there aren't any new changes in the dev build that aren't in the nightly build.

This is the same as what happens when a stable build is released: it'll have a larger number, as it's the most recently created build, but it won't have any new changes beyond what's in the latest dev build."

If you want the latest and you have a license, install the nightly build (https://aur.archlinux.org/packages.php?ID=57360).
If you want the latest and you don't have license, install the dev build. Or obtain a license from the Sublime Text site.

sender commented on 2012-03-21 07:47

NOTE on nightly, dev and stable build numbers: nightly builds always have the latest changes even though the build number on a dev or stable build can be larger. Note from the author of Sublime Text:

"The contents of 2188 and 2190 are the same, there aren't any new changes in the dev build that aren't in the nightly build.

This is the same as what happens when a stable build is released: it'll have a larger number, as it's the most recently created build, but it won't have any new changes beyond what's in the latest dev build."

If you want the latest and you have a license, install the nightly build (https://aur.archlinux.org/packages.php?ID=57360).
If you want the latest and you don't have license, install the dev build. Or obtain a license here: http://www.sublimetext.com/buy

Anonymous comment on 2012-02-22 15:02

Is it possible to make a AUR package that gets the latest version of Sublime, no matter what it is? I know it's closed source, but still, is there a way? Thanks.

Anonymous comment on 2012-02-22 14:33

Is it possible to make a AUR package that gets the latest version of Sublime, no matter what it is? I know it's closed source, but still, is there a way? Thanks.

silverwind commented on 2012-02-19 06:16

anyone else seeing this in yaourt?

==> Downloading sublime-text-dev PKGBUILD from AUR...
==> ERROR: sublime-text-dev not found in AUR.
==> ERROR: unable to update

sender commented on 2012-02-18 22:20

@nagisa looks good. I'll do some tests and add it to the next pkgrel. If you know about any unwanted consequences (on other DE's), let me know. Thanks.

nagisa commented on 2012-02-18 21:48

@sender,
It sets window wmclass to some specific value.
WMClass helps Gnome, Xfce and bunch of window managers group and identify applications. For example it helps Gnome Shell to group apps with their respective .desktop files and behave as expected.
Here's some screenshots with current behaviour: http://api2.ge.tt/0/8oMcPoD/0/blob/ and http://api2.ge.tt/0/8oMcPoD/3/blob/
Here how it looks with --class flag applied (also it is expected behaviour): http://api2.ge.tt/0/8oMcPoD/2/blob/ and http://api2.ge.tt/0/8oMcPoD/1/blob/

Sadly, I cannot find any documentation regarding this switch.

P.S. That strange icon is my custom icon for sublime text.

nagisa commented on 2012-02-18 21:47

@sender,
It sets window wmclass to some specific value.
WMClass helps Gnome, Xfce and bunch of window managers group and identify applications. For example it helps Gnome Shell to group apps with their respective .desktop files and behave as expected.
Here's some screenshots with current behaviour: http://api2.ge.tt/0/8oMcPoD/0/blob/ and http://api2.ge.tt/0/8oMcPoD/3/blob/
Here how it looks with --class flag applied (also it is expected behaviour): http://api2.ge.tt/0/8oMcPoD/2/blob/ and http://api2.ge.tt/0/8oMcPoD/1/blob/

Sadly, I cannot find any documentation regarding this switch.

sender commented on 2012-02-18 21:18

The new icons are placed in /usr/share/icons/hicolor/<size>/apps.

Remember that regenerating the icon cache for GNOME can be done with: gtk-update-icon-cache -f '/usr/share/icons/hicolor'

@nagisa: can you explain or point to some docs on this switch?

nagisa commented on 2012-02-16 14:35

To integrate Sublime Text with Gnome better you should change

${BIN} "${@}" &
to
${BIN} --class=sublime-text-dev "${@}" &

nagisa commented on 2012-02-16 14:34

To better integrate Sublime Text with Gnome you should change

${BIN} "${@}" &
to
${BIN} --class=sublime-text-dev "${@}" &

Bkmz commented on 2012-01-30 13:32

https://gist.github.com/1704400
I modified it to update with 2 executions of makepkg. And its work =) no needs to calculate md5 and others =)

Anonymous comment on 2012-01-20 08:11

Sublime Text is really awesome.Thank you for keeping this package updated.

sender commented on 2012-01-19 08:12

@stefanwilkens: fair point, but this assumes sublime-text and sublime-text-dev are not running side-by-side. What happens in this case when we implement your suggestion and pacman -Syu is run for example?

Please discuss.

sender commented on 2012-01-19 08:03

The next submission will feature suggestions by @drizz and @tiger2wander. Suggestion:

BIN=/opt/sublime-text/sublime_text

${BIN} "${@}" &

stefanwilkens commented on 2012-01-10 09:23

Hi, I'm building pluging packages for sublime for the AUR and I had a suggestion.

can I suggest adding:
provides=(sublime-text)

and installing to /opt/sublime-text/ rather than /opt/sublime-text-dev/ ?

This would make it possible to make a set of PKGBUILDS for the public plugins repositories for sublime that would work for both sublime-text and sublime-text-dev. If not, 2 PKGBUILDS would have to exist for every plugin package, which seems silly.

Anonymous comment on 2012-01-10 06:59

Should add quote for ARGS in /usr/bin/subl for file open with Nautilus contain white spaces.

I was modified it like below:

#!/bin/sh

# Please note that Sublime Text 2 for some reason opens an empty instance
# if the project you're trying to open is already open in another instance,
# instead of just giving it focus.

BIN=/opt/sublime-text-dev/sublime_text

PID=$(pidof -o %PPID ${BIN})
ARGS="${@}"

if [[ ${1:(-16)} == ".sublime-project" ]]; then
ARGS="--project ${ARGS}"
fi

if [[ -n ${PID} ]]; then
${BIN} "${ARGS}"
else
${BIN} "${ARGS}" &
fi

Thanks!

drizz commented on 2012-01-06 14:42

Is it still deemed necessary to control whether or not `sublime_text` processes should start in the background?

Build 2144 introduced .sublime-project handling and the current `subl` script doesn't always start it in the background like it should.

My new proposal is https://gist.github.com/1307801

nagisa commented on 2011-12-30 12:39

2156 is released.

kirrmann commented on 2011-11-10 23:41

there is already 2142 because 2141 is segfaulting