Package Details: sublime-text 2.0.2-4

Git Clone URL: https://aur.archlinux.org/sublime-text.git (read-only)
Package Base: sublime-text
Description: Sophisticated text editor for code, html and prose
Upstream URL: http://www.sublimetext.com/2
Licenses: custom
Submitter: jiggak
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 543
Popularity: 5.481396
First Submitted: 2011-09-28 17:40
Last Updated: 2015-07-08 03:29

Latest Comments

bijanbina commented on 2016-07-12 19:31

the following libpng and libpng-apng links were broken
http://downloads.sourceforge.net/libpng/libpng-1.6.2.tar.xz

flisboac commented on 2016-03-13 06:23

I want to bring your attention to this issue regarding Sublime Text 2 and Package Control: https://github.com/wbond/package_control/issues/874#issuecomment-195887034

It seems the usage of the Python 2.7 library instead of Python 2.6 may be the cause of some incompatibilities with some packages. I suggest extracting /opt/sublime-text/lib/python26.zip to /opt/sublime-text/lib/python2.6 instead of symlinking /usr/lib/python2.7 to /opt/sublime-text/lib/python2.6.

ventosus commented on 2016-01-26 08:40

The check in sublime-text.sh to run in foreground vs background seems to be wrong and even unnecessary.

---
if [[ -n ${PID} ]]; then
LD_LIBRARY_PATH=/opt/sublime-text/lib ${BIN} ${ARGS} "$@"
else
LD_LIBRARY_PATH=/opt/sublime-text/lib ${BIN} ${ARGS} "$@" &
fi
---

Please remove the whole check or at least change the checking mode to the correct one (-z instead of -n)

puya commented on 2016-01-20 22:14

Please update "sublime-text.desktop"

Add this line:
StartupWMClass=sublime_text

it is fix double icons in the plank dock.
thanks.

morion commented on 2015-12-07 03:49

Thank you for this package!

zencefil commented on 2015-10-22 20:35

it worked now, only difference was that this time, i executed makepkg and pacman in 2 serperate commands instead of "makepkg -sri".

zencefil commented on 2015-10-20 14:16

hello,
concerning libpng and libpng-apng:
at the moment neither the links in the PKGBUILD nor the links specified by @carstene1ns (post from 2015-02-10) seem to be working, at least i got checksum fails for both.
any alternatives? (i'm new to arch)

evilgnome commented on 2015-08-12 20:51

Can you please add
StartupWMClass=sublime_text
to the .desktop file?

@gabriwinter I'm able to dock in Plank without your change, but I did need to add "StartupWMClass=sublime_text" in order for Plank to correctly match to the launcher.

gabriwinter commented on 2015-07-18 19:54

Had to modify /usr/share/applications/sublime-text.desktop to be able to dock in Plank.

Exec=/opt/sublime-text/sublime_text %F
instad of
Exec=subl %F

carstene1ns commented on 2015-07-17 12:26

@ takeshibaconsuzu: SourceForge is in recovery mode again[1], so the download server redirects are wrong.
Please see my comment from 2015-02-10 for another mirror (mine).
I am not going to change the PKGBUILD as this will hopefully be fixed soon.

[1]: https://twitter.com/sfnet_ops/status/621859945487581184

takeshibaconsuzu commented on 2015-07-16 22:53

libpng and libpng-apng links were broken for me, replaced them in the PKGBUILD with http://ufpr.dl.sourceforge.net/project/libpng/libpng16/older-releases/1.6.2/libpng-1.6.2.tar.xz and http://ufpr.dl.sourceforge.net/project/libpng-apng/libpng16/1.6.2/libpng-1.6.2-apng.patch.gz respectively.

carstene1ns commented on 2015-05-15 13:27

@arun: No problem, unflagged.

arun commented on 2015-05-15 07:42

Sorry, Flag out of date (2015-05-15) was click error when I voted for it. Someone should really add a confirmation before flagging out of date.

carstene1ns commented on 2015-04-25 21:41

tilx: Do you have sublime-text-dev or sublime-text-nightly installed? They both put the icon in the same place.

tilx commented on 2015-04-25 11:26

Had to manually remove the icon symlinks:

/usr/share/icons/hicolor/{256x256,128x128,48x48,32x32,16x16}/apps/sublime-text.png

to be able to update.

nsmathew commented on 2015-03-27 13:28

Yea, needs update of the sha256sum for the eula.

ripp commented on 2015-03-25 19:44

xilient: I checked the eula on the website, looks like it was updated yesterday which would cause the check to fail.
I just edited PKGBUILD when promoted and updated the sha256sum for it
If you are curious the sum seems to be 6660f16189ef296659a06b1054922ad4819667b5bc201e3bce022d833baf0a42

xilient commented on 2015-03-25 17:05

It seems the EULA is failing the validity check for me.

==> Validating source files with sha256sums...
sublime-text-eula.html ... FAILED
...
==> ERROR One or more files did not pass the validity check!
==> ERROR Makepkg was unable to build sublime-text.

gunzy83 commented on 2015-03-15 12:13

carstene1ns: Sorry, did not think this would be an old issue so did not expand the comments. It is odd because on my systems (laptop and desktop) this affects Plasma 5, Gnome, Cinnamon, Docky and Plank. Adding the hyphen back fixes it on all of them.

I would of course like others to confirm the issue before I request it be reverted (it is easy enough for me to fix myself). What version of the package did the change come in? I have 2.0.2-1 and 2.0.2-4 in my package cache so not sure about in between versions.

carstene1ns commented on 2015-03-15 10:46

gunzy83: This makes sense, however note the comments from August 2013 which lead to that change for this package. I would be happy to revert it, however I cannot confirm it is working, as it makes no difference with my desktop environment.

gunzy83 commented on 2015-03-15 09:07

In sublime-text.sh, ARGS="--class=sublime_text" should be ARGS="--class=sublime-text" so that the windows match the launcher. Note the underscore and the hyphen. When starting Sublime with --class=sublime_text it would create a new icon for the window with the default icon even if there was a launcher on the taskbar.

benjiprod commented on 2015-02-22 11:56

You forgot the last dependencie :
- python-html2text

/tmp/pacaurtmp-username/sublime-text/PKGBUILD: ligne 40: html2text : command not found

clamy commented on 2015-02-13 07:25

Got the following error message when installing: "ImportError: No module named 'pkg_resources'"

Need to install python-setuptools before installing this package.

ejstacey commented on 2015-02-10 20:47

Those temporary sources don't seem to match sha256sum for them.
libpng-1.6.2.tar.xz ... FAILED
libpng-1.6.2-apng.patch.gz ... FAILED

carstene1ns commented on 2015-02-10 19:29

You can substitute the libpng urls with these for the time being:
http://arch.carsten-teibes.de/aur-stuff/libpng-1.6.2-apng.patch.gz
http://arch.carsten-teibes.de/aur-stuff/libpng-1.6.2.tar.xz

carstene1ns commented on 2015-02-10 19:12

It seems sf.net is currently going wild with download redirects.

>> We're sorry -- the Sourceforge site is currently in Disaster Recovery mode...

donny commented on 2015-02-10 18:39

==> Validating source files with sha256sums...
...
libpng-1.6.2.tar.xz ... FAILED
libpng-1.6.2-apng.patch.gz ... FAILED
...
==> ERROR: One or more files did not pass the validity check!

carstene1ns commented on 2015-02-10 03:57

@Magbed: 'python-html2text' is in the makedepends array, so it should be installed automatically.

Magbed commented on 2015-02-09 23:12

Had to install python-html2text before i could install this package. Otherwise it just said html2text command not found.

Magbed commented on 2015-02-09 23:08

Not working for me

It says

:: failed to verify sublime-text integrity

carstene1ns commented on 2015-02-09 18:19

This package now builds its own libpng 1.6.2 (with the same features as the libpng package in the official repositories mid-2013 had). Additionally the license is also included now.

As usual i am open to suggestions (and pull requests).

frederik commented on 2015-02-09 16:10

Great! Thank you very much. If you need support do not hesitate to contact me.

carstene1ns commented on 2015-02-09 16:03

@frederik: That is my plan, expect an update later. It has been a while since i built that libpng library, so maybe we also need an older zlib now.

frederik commented on 2015-02-09 14:57

Thanks @jiggak for disowning.

@carstene1ns thanks for owning. I am shure you will change the PKGBUILD. Please make the compiling of libpng 1.6.2-3 transparent. E.g. do not just include the binaries, but instructions in the PKGBUILD so that the libraries are compiled by makepkg.

Thanks
frederik

jiggak commented on 2015-02-09 03:57

@frederik I've been using sublime-text 3 for a while now so I'm not the right person to maintain this package any longer. I've disowned the package so someone is free to pickup maintenance.

Sorry to all for taking so long to do so.

frederik commented on 2015-02-08 01:53

@jiggak Could you please update the PKGBUILD to carstene1ns proposal?

november-eleven commented on 2015-01-05 21:31

Doesn't work if you update libpng...

$ pacman -Qi libpng
Name : libpng
Version : 1.6.16-1

3.17.6-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux

Fix: Use LD_PRELOAD Hack describe in comment.

barton commented on 2014-12-21 09:08

$ pacman -Qi libpng
Name : libpng
Version : 1.6.15-1

No issues here:
3.17.4-1-ARCH #1 SMP PREEMPT Fri Nov 21 21:14:42 CET 2014 x86_64 GNU/Linux

Let's hope that work resumes on this beautiful piece of software.

0mark commented on 2014-11-03 12:53

Does not work for me. I tried to compile libpng myself and the package from carstene1ns. Both do not help. Any more ideas?

kula85 commented on 2014-10-28 23:42

This is what works for me.

1. build libpng 1.6.2 from source
2. move the actual .so file libpng16.so.16.2.0 as libpng16.so.16 into /opt/sublime-text/lib
3. prepend "LD_PRELOAD=/opt/sublime-text/lib/libpng16.so.16" before "${BIN} ${ARGS} "$@"" and "${BIN} ${ARGS} "$@" &" in /usr/bin/subl

rohansftw commented on 2014-10-01 09:09

@carstene1ns
thanks mate , it works brilliantly :)

koven commented on 2014-09-11 17:04

Right now i'm not able to download the tar.bz file it remains waiting forever to download it.

jiggak commented on 2014-04-25 19:59

@neard correct. Not sure why but people love to mark packages out of date even though they are not in fact out of date.

neard commented on 2014-04-25 19:54

This would appear to be flagged out-of-date incorrectly. According to the website, the current version is still 2.0.2.

th0th commented on 2014-03-11 22:40

Thanks a lot @carstene1ns!

darioshanghai commented on 2014-02-03 21:07

Mistaken click from tablet - too close to download tarball and no undo, sorry.

jiggak commented on 2014-02-03 20:32

@Centzilius it was @darioshanghai. No reason given. I've unflagged it.

Centzilius commented on 2014-02-03 20:27

Who marked this package as out of date when it's not?

Centzilius commented on 2014-02-03 20:27

Who marked this package as out of date when it's not.

carstene1ns commented on 2014-01-24 05:24

Okay, I downloaded and built libpng 1.6.2-3 from source for x86_64 and i686 and packaged it's shared objects like hellerbarde did.
I also applied the change spleach mentioned. With this the icons are shown.
Source package here, hosted by me: http://p.f4ke.de/sublime-text-2.0.2-3.src.tar.gz
-> download, unpack, makepkg -sic, ???, profit! =)

masolit commented on 2013-12-12 20:41

@hellerbarde
link broken :(

th0th commented on 2013-12-02 19:34

@hellerbarde's link looks like broken :( Can someone who already downloaded it re-upload it?

sg0 commented on 2013-11-20 15:15

@hellerbarde Thanks a bunch! Works like a charm! (:

graydsl commented on 2013-11-07 14:06

@hellerbarde Thank you, Sir! :)

hongster commented on 2013-10-09 01:54

@zancarius Thanks for the suggestion. It works for me, on XFCE.

hellerbarde commented on 2013-09-26 01:43

I packaged this with both 64 bit and 32 bit libraries included plus zancarius' fix already applied:

http://phil.vsos.ethz.ch/tmp/sublime-text-2.0.2-2.src.tar.gz

@jiggak: feel free to use this to update this AUR package, if you want.

zancarius commented on 2013-08-30 04:54

@goodwill The solution I finally resorted to (fixes both the icon and the dialog icons in KDE) is to extract libpng 1.6.2's *.so files (from usr/lib in the package) to /opt/sublime-text/lib and prepend:

LD_PRELOAD=/opt/sublime-text/lib/libpng.so

to the statements that run ST2 from /usr/bin/subl. Thus, it'll look something like:

LD_PRELOAD=/opt/sublime-text/lib/libpng.so ${BIN} ${ARGS} "$@"

It's not ideal, but being as I don't personally want to downgrade libpng (although some have suggested it works fine, partial (up|down)grades are unsupported), forcing the dynamic linker to use the older version appears to provide the expected results. It might be worth trying in XFCE. As I suspect this is a problem with ST2, there's probably nothing the PKGBUILD maintainer can do.

You can download libpng either from my link or grab the older PKGBUILD using Subversion ( https://www.archlinux.org/svn/ )--r184329 should have it in trunk/; just make sure to read the instructions and don't attempt to checkout the entire tree. :)

Anonymous comment on 2013-08-30 03:29

FWIW,

Removing --class=sublime-text or modifying it to --class=sublime_text does not work for me on XFCE.

Anonymous comment on 2013-08-30 03:26

FWIW,

Removing --class=sublime-text or modifying it to --class=sublime_text does not work for me on XFCE.

felixonmars commented on 2013-08-29 17:42

@spleach
Thanks a lot, editing `/usr/bin/subl` and replacing `--class=sublime-text` with `--class=sublime_text` also works for me!

spleach commented on 2013-08-29 17:10

Looks like a few others have also been experiencing the X11 icon showing in kwin's taskbar, instead of the ST2 logo.. I've been annoyed by it for weeks now, but am delighted to have just fixed it (even if it's not the reason it broke in the first place; looks like libpng from the below comments).

Editing `/usr/bin/subl` and replacing `--class=sublime-text` with `--class=sublime_text` works for me... Deleting `--class=sublime-text` from ARGS, or even running `/opt/sublime-text/sublime_text` directly also seems to give the correct icon..

zancarius commented on 2013-08-28 23:56

Interesting. I should note that I didn't check to see if the other dialogues show the correct icons; it turns out that (under KDE at least), none of the Oxygen theme icons show up and ST2 complains with this error:

(sublime_text:5788): Gtk-WARNING **: Error loading icon: Failed to load image '/usr/share/icons/oxygen/16x16/places/folder.png': Fatal error in PNG image file: bad parameters to zlib

So, there's something about libpng-1.6.3 that ST2 doesn't like. Pending that, I'll host an x64 version of libpng-1.6.2 that I haven't yet deleted from my package cache:

http://aries.destrealm.org/bshelton/libpng-1.6.2-3-x86_64.pkg.tar.xz

Marcel_K commented on 2013-08-22 11:23

@zancarius: I cannot second that. If I launch /opt/sublime-text/sublime_text directly, I still see the default icons, not Sublime's.

zancarius commented on 2013-08-21 19:12

Launching /opt/sublime-text/sublime_text directly doesn't present the icon issue, either (no need to fiddle with libpng). It's only when launching from the subl script that ships with this PKGBUILD that the problem occurs. sublime-text-nightly doesn't have this issue because the package's /usr/bin/subl3 is a symlink to the Sublime Text 3 bin in /opt. I'd imagine the same goes for other ST3 packages.

I'm using KDE as well and running other applications (like Opera) that are launched via a shell script don't exhibit the missing icon problem that subl does when run.

I have no idea if this is related at all to those of you running other WMs or DEs...

zancarius commented on 2013-08-21 19:09

Launching /opt/sublime-text/sublime_text directly doesn't present the icon issue, either (no need to fiddle with libpng). It's only when launching from the subl script that ships with this PKGBUILD that the problem occurs. sublime-text-nightly doesn't have this issue because the package's /usr/bin/subl3 is a symlink to the Sublime Text 3 bin in /opt. I'd imagine the same goes for other ST3 packages.

I'm using KDE as well and running other applications (like Opera) that are launched via a shell script doesn't exhibit the missing icon problem that subl does when run.

hobarrera commented on 2013-08-20 04:24

@Marcel_K Try the ABS. Also, sublime-text-nightly or -3 don't seem to have the mentioned issue either.

Finally, you can look at the PKGBUILD history, and build the old version, not too much of a hastle.

Marcel_K commented on 2013-08-19 19:38

Can someone please host a copy of libpng-1.6.2-3-x86_64.pkg.tar.xz somewhere, I just installed a 64-bit system and can't find it anywhere on the net. Thanks.

Anonymous comment on 2013-08-10 12:03

I use KDE on x86_64 and have the same icon issue. Downgrading package libpng (1.6.3-1 => 1.6.2-3) fixes the problem.

felixonmars commented on 2013-08-07 14:23

I use oxygen with KDE, still having the problem.

hobarrera commented on 2013-08-07 14:01

Probably an issue with Faenza and Faiance. I'm using xfce-elementary and no issues here.

Marcel_K commented on 2013-08-07 10:18

But I don't use gnome, just IceWM.

AlexandrePTJ commented on 2013-08-07 06:22

The problem looks to be related to icons theme. With gnome default, it works good, but with Faenza or Faience theme, icons disappears.

mwbrown commented on 2013-07-29 14:10

Confirming that downgrading from libpng 1.6.3-1 to 1.6.2-3 works at fixing the icon problem. Also using xfwm4 on x86_64.

Marcel_K commented on 2013-07-28 17:46

That didn't work for me, still the same X icons: http://i.imgur.com/f19Ac2N.png

spirtbrat commented on 2013-07-28 17:28

Try reinstalling librsvg or just do:

# /usr/bin/gdk-pixbuf-query-loaders --update-cache

See this thread:

https://bbs.archlinux.org/viewtopic.php?pid=1254075

Anonymous comment on 2013-07-28 17:27

Icons broken here with libpng 1.6.3-1. Downgrade to 1.6.2-3 fixed it. Using xfce with xfwm4 and a gnome 2 theme.

jiggak commented on 2013-07-28 16:27

No problem with latest libpng here. All icons look same as before in gnome3

hobarrera commented on 2013-07-28 12:52

No problem for me with libpng 1.6.3-1. Using compiz as a standalone WM, so app icon is shown on application switcher and scale only.

Marcel_K commented on 2013-07-28 12:39

Check. With libpng 1.6.2, everything looks fine, with 1.6.3 default X icons are shown.

felixonmars commented on 2013-07-28 12:35

Application icons on taskbar, titlebar and message boxes were not displayed since libpng 1.6.3. Anyone else could confirm this?

spleach commented on 2013-07-08 09:21

Sublime Text 2.0.2 was released today. The PKGBUILD appears only to need an updated `pkgver` and `md5sum`. Well, I've upgraded it like that and it works fine, so far...

felixonmars commented on 2013-04-10 04:50

Hi, please quote "${srcdir}" and "${pkgdir}", thanks!

zpd commented on 2013-03-18 09:40

check package with namcap and get following messages:

sublime-text E: ELF file ('opt/sublime-text/sublime_text') outside of a valid path.
sublime-text E: Missing custom license directory (usr/share/licenses/sublime-text)
sublime-text E: Dependency desktop-file-utils detected and not included (needed for update-desktop-database)
sublime-text E: Dependency hicolor-icon-theme detected and not included (needed for hicolor theme hierarchy)
sublime-text W: Dependency included and not needed ('libpng')
sublime-text W: Dependency included and not needed ('gtk2')

swdunlop commented on 2012-12-29 12:16

sublime-text.install has an additional dependency on xdg-utils for xdg-icon-resource at install time

Thanks for the PKGBUILD, jiggak.

Marcel_K commented on 2012-12-03 22:27

Please quote all instances of ${srcdir} and ${pkgdir} to allow for spaces in directory names. Also, according to namcap, libpng and gtk2 are not needed as dependencies.

milouse commented on 2012-11-29 17:58

To get rid of pidof, is it not possible to replace the PID ligne by something like PID="`ps -Af | grep -o -w ".*${BIN}" | grep -v grep`" ?

ilpianista commented on 2012-09-10 14:45

please install the license under /usr/share/licenses/${pkgname}/

evilgnome commented on 2012-09-03 22:14

Update for my previous comment: This uses pidof, so if you're using systemd you should install systemd-sysvcompat, which requires sysvinit-tools, which will provide it.

Actually, sysvinit-tools should be added as a dependency.

evilgnome commented on 2012-09-03 21:34

Update for my previous comment: This uses pidof, so if you're using systemd you should install systemd-sysvcompat, which requires sysvinit-tools, which will provide it.

TingPing commented on 2012-09-02 05:30

Should depend on sysvinit-tools for pidof

jiggak commented on 2012-08-30 17:23

@angyath, thanks updated package with your change

Anonymous comment on 2012-08-30 16:05

The sublime-text.desktop file should use

Exec=subl %F

instead of
Exec=subl %U
because sublime expects file paths and doesn't understand file:// URIs.

Phreakazoid commented on 2012-08-17 12:19

In addition to my last comment, the other two commands called in the install script depend on:

desktop-file-utils
shared-mime-info

If they are non-essential commands, perhaps either redirect all output to /dev/null or ignore their non-existence.

Phreakazoid commented on 2012-08-17 12:08

This should depend on xdg-utils, since it uses xdg-icon-resource in the install script.

hobarrera commented on 2012-08-17 01:55

The file `/usr/bin/subl` references `pidof` but:
- sysvinit is not listed as a dependency
- There's no point in using it, just run what's inside the `else`of that `if` every time.
The script works fine for me *without* sysvinit, but spits out an error every time.

nrq commented on 2012-08-14 22:07

Does anybody having an issue with running ST2? I can't run it anymore, also nothing returned if running from shell.

evilgnome commented on 2012-08-01 07:27

This uses pidof, so if you're using systemd you should install systemd-sysvinit, which will provide it.

tinhtruong commented on 2012-07-16 10:55

Really love the new icon :)

Anonymous comment on 2012-07-15 11:37

Anyone else having trouble with Package Control? I keep having to edit the script whenever I update Package Control to specify JSON encoding for json.loads(), and *now* I'm getting a message box on startup saying "The package specified, ".

Anonymous comment on 2012-07-14 21:01

FYI, another way to fix the same problem is to rename sublime-text.desktop to sublime_text.desktop. :)

jiggak commented on 2012-07-06 06:25

@goodwill you are a hero of the people. Package updated with your magical command line option.

Anonymous comment on 2012-07-06 04:28

The fix is actually fairly simple: "--class=sublime-text" needs to be passed to "/opt/sublime-text/sublime_text". this will let gnome map the window class to the .desktop file. This also fixes the problem with gnome-shell dock, docky and other bits.

my patch looks like (mind the white space at eh the end of arge):

--- subl 2011-11-10 14:55:05.000000000 -0800
+++ subl.patched 2012-07-05 21:24:15.395339439 -0700
@@ -7,10 +7,10 @@
BIN=/opt/sublime-text/sublime_text

PID=$(pidof -o %PPID ${BIN})
-ARGS=
+ARGS="--class=sublime-text ";

if [[ ${1:(-16)} == ".sublime-project" ]]; then
- ARGS="--project"
+ ARGS=+"--project"
fi

if [[ -n ${PID} ]]; then

belak commented on 2012-06-28 13:33

@jiggak

The output of lddtree in pax-utils. It shows all immediate, non dlloaded deps...
Also, the dep on libpng isn't needed because of how they load libgtk+, at least according to their changelog... they load libgtk+ using dlload which is linked with cairo, which is linked with libpng. It isn't really important to change it, just worth noting.

gtk2 is the only real dep that it needs. Glib is used by gtk, and libpcre is used by gobject (aparently).

Again, not really important, just semantics.

benoliver999 commented on 2012-06-28 09:43

Ah yes, manual sync fixed it for me too thanks.

myle commented on 2012-06-28 09:40

warning: downgrading package sublime-text (2.2181-1 => 2.0-1)

I had to manually sync with the new version since I got this message. Apart from that, everything is fine.

benoliver999 commented on 2012-06-27 22:28

Latest version is not coming through. Running 64-bit.

jiggak commented on 2012-06-27 15:08

@grayich, when the pkgver changes doesn't pkgrel always reset to 1?

grayich commented on 2012-06-27 12:54

Please renew pkgrel, 1 -> 2

grayich commented on 2012-06-27 12:53

renew pkgrel, 1 -> 2

jiggak commented on 2012-06-26 14:26

@belak, are you sure libpng is not required? The text you quoted makes it sound like it no longer requires a specific version but does still require it. And regarding the glib and libpcre deps, where did you find that these are required?

weckx commented on 2012-06-26 14:20

Version 2.0 fixes the ugly icon on gnome-shell

belak commented on 2012-06-26 14:08

Looks like the deps of this are a little off, but other than that, this works great.

Doesn't link with libpng... "Linux: GTK is loaded at runtime, removing any dependency on specific libpng versions"

Also, the actual deps aren't listed, such as glib and libpcre.

But thanks for maintaining this! This got updated between when I noticed the release and when I finished my hacky version.

Anonymous comment on 2012-06-26 13:40

Yes!! SublimeText is now 2.0 final!

Anonymous comment on 2012-06-06 07:04

The problem with the icon is that the name of the executable is sublime_text, which has the effect that a low-res icon is used to display in gnome shell. Minor issue but still irritating.

triplc commented on 2012-05-02 08:05

Please consider to add "xdg-utils" as a dependency

stfn commented on 2012-03-10 18:39

Awesome editor.

Anonymous comment on 2012-03-02 14:42

one of the best editors

Anonymous comment on 2012-02-23 16:57

new icon shows up as it should: using openbox

Anonymous comment on 2012-02-23 11:41

Same here with Xfce.

Anonymous comment on 2012-02-23 11:13

Icon isn't showing for me.

jiggak commented on 2012-02-23 01:32

Updated to build 2181... enjoy the pretty new icon!

The new icon seems to show up as expected in all the gnome3 place (ie: nautilus and gnome-shell). Let me know if other desktop managers have a problem finding it.

drizz commented on 2012-01-07 01:38

@jigakk This build does not have automatic .sublime-project handling, it's the `subl` bash-script that handles that.

Automatic handling is implemented in build 2144 which is available in the dev channel (see http://www.sublimetext.com/dev)

I am not able to replicate the bug at given time, as I don't know what's causing it.

I run into it rather often when trying to open certain files on certain occasions, from the terminal.

I will report back when I run into it again.

jiggak commented on 2012-01-06 14:56

@drizz I'm not sure what you mean. I have build 2138 which looks to be latest. This build has .sublime-project handling but I'm afraid I don't use that on a regular basis so I can't say for sure if there is a problem with it.

Are you seeing some sort of buggy behavior with build 2144? If so where did you get the build? Can you list the steps required to replicated the bug?

drizz commented on 2012-01-06 14:39

Is it still deemed necessary to control whether or not `sublime_text` processes should start in the background?

Build 2144 introduced (albeit not “stable” yet) .sublime-project handling and the current `subl` script doesn't always start it in the background like it should.

stefanwilkens commented on 2011-11-16 15:57

you should mention that this is an evaluation version, it will nag for licenses after a while.

evaluation license is unlimited in both time and functionality

jiggak commented on 2011-11-10 22:56

Package version 3 fixes a bug in the launch script causing file names with spaces to open in separate tabs.

Anonymous comment on 2011-11-06 23:42

@jiggak
Thanks for the clarification. I agree with you, subl suits ok.

Anonymous comment on 2011-11-05 15:11

to run sublime the following library is required: libpng12.
the library can be obtained from AUR libpng12 1.2.46-2 at: https://aur.archlinux.org/packages.php?ID=33795

jiggak commented on 2011-11-04 17:19

@unformatt in my comment below I mentioned the reasoning when updating to revision 2139.

On Mac OSX sublime has a command line binary named "subl" so I thought it was fitting to follow the same convention here. Less typing and easier on my brain when switching between OS's (I use sublime on all three platforms).

However, if you dislike the change just rename the script. Or create an alias by putting the following in your .bashrc file:

alias sublime=subl

Anonymous comment on 2011-11-04 17:13

why does the executable file now is called subl instead of sublime? was there any issue?

jiggak commented on 2011-11-03 17:36

Umm, sublime is distributed as a binary package. No compiling is happening, thus no need for automake or autoconf.

Anonymous comment on 2011-11-03 17:34

This package has the following unspecified dependencies:
automake
autoconf

jiggak commented on 2011-11-02 17:36

@kittmann oops, thanks for that... fixed

kirrmann commented on 2011-11-02 17:33

sublime-text.desktop calls sublime instead of subl

jiggak commented on 2011-11-02 17:23

@drizz thanks I've included your start script changes in latest package.

Also note I've made a few other changes:

1) renamed startup script to "subl" to match upstream naming on other platforms
2) move upstream revision number to package version instead of package release (package release will increment for package changes)

drizz commented on 2011-10-23 19:52

I took liberty to write a new start-script (`sublime`) that supports opening projects files as projects.

It is available at https://gist.github.com/1307801

jiggak commented on 2011-10-13 15:25

@antihero don't flag packages out of date unless there is a new version available upstream. And unless you have found a problem with the package, you need to contact the software author for support. And BTW it seems to work just fine for me in "gnome" (I assume you mean opening files from nautilus).

antihero commented on 2011-10-13 14:33

If you open stuff from within gnome, it doesn't work and seems to treat any spaces in the path as separate arguments, thus opening the wrong thing (usually nothing).

Anonymous comment on 2011-10-10 17:38

Anyone else having problems with duplicate Gnome Shell dock entries?

chmurli commented on 2011-09-29 15:11

well, my old sublime-text-2 pkg has beed deleted. Good luck with keeping frequent updates :)

Anonymous comment on 2011-09-29 02:05

@jiggak Thanks for your work. I'm too lazy for maintain a package... Now it's your responsibility. :D

jiggak commented on 2011-09-29 00:03

Just added i686 arch based on @9hills PKGBUILD. Also added gtk2 as dependency.

jiggak commented on 2011-09-28 22:13

I suppose I could have. Looks like someone else already did a few hours ago. No guarantees though that the maintainer is going to take my edits.

Anonymous comment on 2011-09-28 22:01

Instead of creating a new package, couldn't you get in touch with the old maintainer and submit an edited pkgbuild?

jiggak commented on 2011-09-28 19:33

The other package was putting files in strange places. I also added a simple launcher for use on the CLI that will either launch a new instance or open a file in the current instance.

jwa commented on 2011-09-28 19:24

why a second package?