Package Details: subsurface 5.0.8-1

Git Clone URL: https://aur.archlinux.org/subsurface.git (read-only, click to copy)
Package Base: subsurface
Description: Divelog program
Upstream URL: https://github.com/subsurface/subsurface
Licenses: GPL2
Submitter: arojas
Maintainer: lmartinez-mirror (ohli)
Last Packager: lmartinez-mirror
Votes: 3
Popularity: 0.36
First Submitted: 2021-04-22 20:29 (UTC)
Last Updated: 2022-04-05 21:18 (UTC)

Pinned Comments

lmartinez-mirror commented on 2021-07-11 23:11 (UTC)

Since I don't have a way to follow updates for this package, nor do I use it, co-maintainer spots are open for those who actively use and follow this software.

Latest Comments

ironcyborg commented on 2022-04-14 13:26 (UTC)

Thanks jrd, now it builds correctly!

jrd commented on 2022-04-10 19:59 (UTC) (edited on 2022-04-10 19:59 (UTC) by jrd)

I modified the build with this line to not try to build with QT6:

sed -i '/find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core Widgets)/s/Qt6 //' $pkgname-$pkgver/CMakeLists.txt

ironcyborg commented on 2022-04-06 08:50 (UTC)

Apparently subsurface initial Qt6 support can introduce some problems if Qt6 is installed on the system, and make fails: Failed to find Qt component "WebKitWidgets". Expected Config file at "/usr/lib64/cmake/Qt6WebKitWidgets/Qt6WebKitWidgetsConfig.cmake" does NOT exist If I understand correctly Qt6 WebKit is not (yet?) available. Maybe it should be necessary to force Qt5 libraries if Qt6 is also installed in the system.

simona commented on 2022-03-18 09:13 (UTC)

now ok

locu commented on 2021-12-26 16:22 (UTC) (edited on 2021-12-26 16:23 (UTC) by locu)

There seems to be a conflict at the moment with the current libgit2 package and subsurface:

error: failed to prepare transaction (could not satisfy dependencies) :: installing libgit2 (1:1.3.0-1) breaks dependency 'libgit2.so=1.2-64' required by subsurface

Would it be possible to update dependencies to also work with never versions of libgit2? Or is subsurface not compatible with the newer version?

chrboesch commented on 2021-11-01 09:50 (UTC)

You will find the tarball at: https://subsurface-divelog.org/downloads/ The git-repo is no longer supported!

lmartinez-mirror commented on 2021-09-29 22:12 (UTC)

@chrboesch

I couldn't find a tarball for version 5.0.3.43. Unless you can link to a git tag for it, I'm unflagging for now.

simona commented on 2021-09-27 13:48 (UTC)

l'installazione di libgit2 (1:1.2.0-1) interrompe la dipendenza 'libgit2.so=1.1-64' richiesta da subsurface

lmartinez-mirror commented on 2021-07-11 23:11 (UTC)

Since I don't have a way to follow updates for this package, nor do I use it, co-maintainer spots are open for those who actively use and follow this software.