Package Details: subtitlecomposer 0.7.0-1

Git Clone URL: (read-only)
Package Base: subtitlecomposer
Description: A KDE subtitle editor
Upstream URL:
Keywords: composer editor kde subtitle
Licenses: GPL
Submitter: Martchus
Maintainer: Martchus (maxrd2)
Last Packager: maxrd2
Votes: 20
Popularity: 0.031580
First Submitted: 2015-09-02 23:50
Last Updated: 2019-06-27 19:04

Dependencies (20)

Required by (0)

Sources (2)

Pinned Comments

Martchus commented on 2016-05-18 21:59

All my packages are managed at GitHub where you can also contribute directly:
There also exist a binary repository (i686 and x86_64, also contains Git version):

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

andre-fernando commented on 2017-05-24 06:45

I am getting a build error:

make[1]: *** [CMakeFiles/Makefile2:2470: src/speechplugins/pocketsphinx/CMakeFiles/pocketsphinxasr.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build subtitlecomposer.

any idea how to fix this?

mikronimo commented on 2017-02-08 13:48

@Martchus: i Just tried to update pocketsphinx, but, still, it requires gst0.10... anyway, i'll try what you said, thanks for the answer.

EDIT: I updated subtitlecomposer, and modified the PKGBUILD (at the prompt request about it); compilation and installation are gone well; the issue, for what about me, is solved. Thanks again.

Martchus commented on 2017-02-08 12:11

mikronimo: Did you read the comments about optional dependencies in the PKGBUILD? I propose you just comment the pocketsphinx dependencies out. There is no real benefit having it anyways because pocketsphinx integration isn't ready yet (as far as I know). But wait, hasn't pocketsphinx already been updated to use new gstreamer?

mikronimo commented on 2017-02-08 02:37

I had all working untill the last update; now that gstreamer0.10 became obsolete in manjaro, i removed it, since the new gstreamer1.10 works in his place; subtitle compser has like dependency gstreamer1.10, but pocketsphinx still have the 0.10 version, so i can't update unless i reinstall it: is there a solution without doing that?

Martchus commented on 2016-05-18 21:59

All my packages are managed at GitHub where you can also contribute directly:
There also exist a binary repository (i686 and x86_64, also contains Git version):

Martchus commented on 2016-05-10 20:56

Just to not confuse people which haven't read the last comments, I'm referring to this version of the PKGBUILD:

allum: I added pocketsphinx as optional dependency. However, to be able to build the plugin, pocketsphinx must be available at build time. There is no way around it. If you comment the pocketsphinx make-dependency out, you should also out comment the optional dependency for pocketsphinx because in the case the pocketsphinx hasn't been built and hence the package can not make use of pocketsphinx afterwards. That's actually the reason why you got the error message in the first place. I also mentioned this in the comments I've added to the PKGBUILD file itself. The version in my binary repo does not have the pocketsphinx optdep yet (just the make dep and hence the plugin is available), because I forgot to add it and I don't think it is worth to rebuild it (it will be rebuild soon enough when the next version is released).

Actually, pocketsphinx does not take long to build so it isn't an "annoying dependency" anyways. The problem is just that the version which is currently available in the AUR doesn't build. I already posted my fixed versions in the comment sections of sphinxbase and pocketsphinx, so the maintainer can fix it.

alium commented on 2016-05-10 19:54

can you make pocketsphinx as optional and no as 'hard' dependencies?

Martchus commented on 2016-05-10 16:14

I fixed the AUR package for sphinxbase and pocketsphinx and added it as make dependency so the plugin will be build.

You can find the updated packages (sphinxbase, pocketsphinx, subtitlecomposer and subtitlecomposer-git) here:

However, I don't think it makes sense to update the subtitlecomposer package here until the issues in the pocketsphinx and sphinxbase packages are fixed. Otherwise I'll probably get complaints that the package is not building.

If you don't want to build everything on your own, you can also use my binary repository (i686, x86_64):

Martchus commented on 2016-05-10 14:10

There is currently no package for pocketsphinx available in the official repositories. Last time I tried to build the version from the AUR it didn't work. That's why I didn't add pocketsphinx to the dependencies.

If you want to build the pocketsphinx plugin, add pocketsphinx to the dependencies and try to build it (eg. from the AUR) before. (You also need to build sphinxbase before.)

alium commented on 2016-05-10 13:57

Can not build - missing "pocketsphinx":

Package pocketsphinx was not found in the pkg-config search path.
Perhaps you should add the directory containing `pocketsphinx.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pocketsphinx' found
CMake Warning at src/speechplugins/CMakeLists.txt:12 (message):
PocketSphinx not found - Speech plugin will not be built

-- Configuring incomplete, errors occurred!