Package Details: subversion-1.6 1.6.23-4

Git Clone URL: https://aur.archlinux.org/subversion-1.6.git (read-only)
Package Base: subversion-1.6
Description: A Modern Concurrent Version Control System
Upstream URL: http://subversion.apache.org/
Licenses: Apache
Conflicts: subversion, svn
Provides: subversion, svn
Submitter: sLite
Maintainer: sLite
Last Packager: sLite
Votes: 15
Popularity: 0.000026
First Submitted: 2011-12-21 14:38
Last Updated: 2015-11-07 00:49

Dependencies (20)

Required by (508)

Sources (5)

Latest Comments

sLite commented on 2015-11-07 00:49

better late than never, included the proposed jkd configure option ;)

sLite commented on 2015-05-11 19:35

stativ commented on 2015-05-10 10:13

I'm having problems with JDK autodetection:

configure: error: Cannot compile JavaHL without a suitable JDK.
Please specify a suitable JDK using the --with-jdk option.

I have jdk8-openjdk installed. The problem is that Arch doesn't use JAVA_HOME anymore. It can be fixed by adding the following to configure:

--with-jdk=/usr/lib/jvm/default

sLite commented on 2015-04-22 11:44

Bumped to latest subversion release and changed source url to apache archive.

Only patch that seems to be necessary with this release is the neon version fix.

Please tell me if something doesn't work as expected.

richq commented on 2015-04-21 16:02

Do you think it would be worth bumping this up to the very last 1.6 release, 1.6.23, which is in the apache site's archive? I worry about the tigris link going away at some point.

source url is https://archive.apache.org/dist/subversion/$_pkgname-$pkgver.tar.bz2
md5 is 5d621281ce9d3448e1437cb006331f57

The kwallet fix is incorporated in to that version I think. Or maybe the patch doesn't apply for other reasons. The other patches apply fine.

sLite commented on 2015-04-21 12:00

* added make dependency for kwallet
* added --with-gnome-keyring and make dependency (hey there gnome folks!)
* added optional kwallet and gnome-keyring dependencies

alessiofachechi commented on 2015-04-13 12:50

The --with-kwallet configure option requires some KDE dependencies (probably kdelibs).

sLite commented on 2014-08-29 10:04

finally had time (and need) to update this package.

ATTENTION: This package does NOT build mod_dav_svn anymore, the apache 2.2 dependency is just too cumbersome.
As old clients can connect to newer server versions this package is targeted for client use only. If you really need subversion 1.6 and mod_dav_svn you are out of luck here ;)

sLite commented on 2014-08-20 16:48

sorry, i haven't used this in ages and don't have the time and environment anymore to keep this package up to date. I'll disown it, may anyone still working with svn 1.6 and the chance to really evaluate what's good to include or not take over.

Thanks for your understanding and sorry :>

stativ commented on 2014-08-13 16:50

The following package works for me:
http://ge.tt/7fjAs6r1/v/0?c

The package reenables kwallet integration, but disables perl bindings. I forgot to bump pkgrel, so if you update the package, don't forget to bump it.

All comments