Package Details: sunwait 0.9.1-1

Git Clone URL: https://aur.archlinux.org/sunwait.git (read-only, click to copy)
Package Base: sunwait
Description: Calculate sunrise/sunset times with civil, nautical, astronomical and custom twilights
Upstream URL: https://www.risacher.org/sunwait/
Licenses: GPL3
Submitter: tlvince
Maintainer: eclairevoyant
Last Packager: eclairevoyant
Votes: 11
Popularity: 0.004737
First Submitted: 2012-10-23 05:40 (UTC)
Last Updated: 2023-05-02 04:05 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

m040601 commented on 2023-04-14 10:50 (UTC)

Actually, Upstream URL should now be, https://github.com/risacher/sunwait. The developer is at least active on other projects on github.

As he says, http://www.risacher.org/sunwait/

 NOTE: I developed sunwait in 2000(-ish) and maintained it until 2004. In 2013, Ian Craig forked it and made it better. He maintained it until 2016. In 2019, I moved his code to a repo on GitHub and fixed a bug or two and added some features. As of 2019-03-22, the version at GitHub (https://github.com/risacher/sunwait should be considered "current".

m040601 commented on 2023-04-14 10:43 (UTC) (edited on 2023-04-14 10:45 (UTC) by m040601)

This is a nice little usefull tool.

The maintainer of this PKGBUILD, doesnt respond. Hasnt logged in since 2022 and has an INSANE ammount of AUR PKGBUILDS marked out of date, https://aur.archlinux.org/packages?K=keenerd&SeB=m

Anyone with the skills and interested in adopting it ?

So that we can submit an "orphan request".

m040601 commented on 2023-03-31 15:05 (UTC) (edited on 2023-04-03 21:42 (UTC) by m040601)

The newest version is 0.9.1

Homepage (Uptstream URL) should also be changed from

http://risacher.org/sunwait/

to

https://risacher.org/sunwait/

(or use the https://github.com/risacher/sunwait as homepage)

eclairevoyant commented on 2023-03-16 00:19 (UTC)

In addition to the out-of-date version, the license should be corrected to GPL3.

keenerd commented on 2020-06-11 02:35 (UTC)

The github repo has no releases, and this is not a -git package. Please don't flag until there is a version 0.9.

NRG commented on 2018-04-17 18:32 (UTC)

The PKGBUILD file misses the compatibility flag for armv7h. I added that locally, and the package is now seemingly running fine on my Raspberry Pi using Arch on ARM. Can the maintainer please update the package, adding armv7h and what else might be useful? Thank you!