Package Details: sup 0.22.1-1

Git Clone URL: (read-only)
Package Base: sup
Description: Sup is a console-based email client for people with a lot of email. Great mutt alternative.
Upstream URL:
Licenses: GPL
Conflicts: sup-git
Submitter: Garoth
Maintainer: asch
Last Packager: asch
Votes: 53
Popularity: 0.025658
First Submitted: 2009-05-12 15:12
Last Updated: 2015-07-15 09:39

Latest Comments

ainola commented on 2015-08-17 14:58

I've migrated ruby-rmail-sup over as it hadn't made the transition to AUR4. I've orphaned as I'm not interested in maintaining it.

Thanks for maintaining this PKGBUILD. :)

sysfu commented on 2014-03-14 20:25

error below appears to have been resolved by an update to one of the ruby dependencies. I installed sup on another workstation today and sup-config will run now.

sysfu commented on 2014-02-20 21:40

Installed on another workstation succesfully, but getting this error when running sup-config

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'highline' (>= 0) among 18 total gem(s) (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/sup-config:22:in `<main>'

asch commented on 2014-01-13 23:17


sysfu commented on 2014-01-13 21:49

this release still broken from the ruby-mime-types error reported below by WaReZ

sysfu commented on 2013-12-22 20:33

@asch kudos for getting the update out so quick, impressive.

asch commented on 2013-11-21 15:42

Ups, my fault. I didn't notice that ruby-mime-types were updated. I will fix this in a few days.

WaReZ commented on 2013-11-21 15:40

Thanks for the fast answer.

I did it but it's not resolving the issue :(

asch commented on 2013-11-21 15:13

@WaReZ: Please use package 'sup-git' instead of 'sup' for this time. 'sup-git' is much more stable with current ruby libs. 'sup' will be updated soon to use newer packages, so we have to wait, because creating new pkgbuild for old packages for a short time is not viable. Thank you.

WaReZ commented on 2013-11-21 14:07

The new ruby-mime-types (2.1) update broke sup :

/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'mime-types' (~> 1.0) - did find: [mime-types-2.0] (Gem::LoadError)
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1196:in `block in activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `each'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1167:in `activate'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
from /usr/bin/sup:22:in `<main>'

All comments