Package Details: sup 1.0-1

Git Clone URL: (read-only, click to copy)
Package Base: sup
Description: Sup is a console-based email client for people with a lot of email. Great mutt alternative.
Upstream URL:
Licenses: GPL
Conflicts: sup-git
Submitter: Garoth
Maintainer: asch
Last Packager: asch
Votes: 52
Popularity: 0.000000
First Submitted: 2009-05-12 15:12
Last Updated: 2020-07-14 09:39

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

sysfu commented on 2013-12-22 20:33

@asch kudos for getting the update out so quick, impressive.

asch commented on 2013-11-21 15:42

Ups, my fault. I didn't notice that ruby-mime-types were updated. I will fix this in a few days.

WaReZ commented on 2013-11-21 15:40

Thanks for the fast answer.

I did it but it's not resolving the issue :(

asch commented on 2013-11-21 15:13

@WaReZ: Please use package 'sup-git' instead of 'sup' for this time. 'sup-git' is much more stable with current ruby libs. 'sup' will be updated soon to use newer packages, so we have to wait, because creating new pkgbuild for old packages for a short time is not viable. Thank you.

WaReZ commented on 2013-11-21 14:07

The new ruby-mime-types (2.1) update broke sup :

/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'mime-types' (~> 1.0) - did find: [mime-types-2.0] (Gem::LoadError)
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1196:in `block in activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `each'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1167:in `activate'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
from /usr/bin/sup:22:in `<main>'

asch commented on 2013-10-18 18:01

Yes, the warning is non-critical. You have to realize that sup is not yet fully supporting ruby 2.0.

sysfu commented on 2013-10-18 17:51

I installed the xapian-core-old package from the AUR and now sup-config runs correctly.

Only outstanding issue is this error message everytime sup launched, however I believe it's non-critical.

usr/lib/ruby/gems/2.0.0/gems/sup-0.14.1/lib/sup/mbox.rb:164: warning: without a block is deprecated; use Object#to_enum

sysfu commented on 2013-10-18 17:33

I think I understand you now. I was confused by the earlier comment because I interpreted it as assuming a version of xapian-core was already installed on my system, which was not the case.

asch commented on 2013-10-18 07:24

Trust me, just install xapian-core 1.2.15.

sysfu commented on 2013-10-18 07:21

i think it may be something else. I already had ruby-xapian-ruby 1.2.15 installed and there is no xapian-core package installed on my system.

% pacman -Qs xapian
Xapian libraries and ruby bindings.