Package Details: sup 0.22.1-1

Git Clone URL: https://aur.archlinux.org/sup.git (read-only)
Package Base: sup
Description: Sup is a console-based email client for people with a lot of email. Great mutt alternative.
Upstream URL: http://sup-heliotrope.github.io/
Licenses: GPL
Conflicts: sup-git
Submitter: Garoth
Maintainer: asch
Last Packager: asch
Votes: 52
Popularity: 0.000002
First Submitted: 2009-05-12 15:12
Last Updated: 2018-09-03 15:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

asch commented on 2013-10-15 06:07

Fixed, try it now.

sysfu commented on 2013-10-15 00:08

Werd, thanks for getting that out pronto.

Hey I tried to install the new sup pkg using both packer and manually downloading/extracting the tarball and running makepkg. Fails due to a "rubygems" dependency.

==> Missing dependencies:
-> rubygems

Which version of rubygems should I install? I see the following versions available in aur, none found in the official packages.

aur/rubygems1.8 1.3.7-2 (160)
aur/ruby-latest-rubygems 1.9.3_p0-1 (1)
aur/rubygems1.8.25 1.3.7-2 (0)

asch commented on 2013-10-14 21:36

Updated!

sysfu commented on 2013-10-10 22:46

14.1 is out if you have time to update the package.

http://www.mail-archive.com/sup-talk@rubyforge.org/msg04604.html

asch commented on 2013-05-15 19:58

I think it is better to wait for sup 0.14 with recent ruby support. Version 0.13 does not work with ruby 2.0 thus package makes no sence. I recommend manual gem installation with rvm and ruby 1.8.

asch commented on 2013-04-29 05:02

I know, I'm checking new release carefully and will be updating asap.

sysfu commented on 2013-04-29 03:15

The original author William has made contact with the new maintainers, a new maintenance release sup-0.13 is out soon http://www.mail-archive.com/sup-talk@rubyforge.org/msg04564.html

asch commented on 2013-02-17 22:22

Cannot figure out why it does not work with ruby 1.9.3 -- orphaning.

asch commented on 2012-09-24 11:59

Sup is dead, don't use it unless you want to hack it. And if you want to hack it, do it with git version. Good luck.

arch-nemesis commented on 2012-09-24 11:48

Cannot build. Annoyingly, most of the dependencies are not in the main repositories, AUR only. ruby-locale is in neither repositories or AUR.